RELEASED: Vehicle Test 41
36 36

1545 posts in this topic

Recommended Posts

Found bug(or not) when i press "drop" to the car seat or trunk i can overload them :P not working with dragging.

 

Didnt play some time...

Well can i leave my feedback as casual player? :)

 

1.Vehicle condition.
I feel myself like on junk yard. Half of the cars cant travel even 10 miles XD... tires...just blowing up...oh... leaking gas tanks... lol... , trunks... losing cargo...haha. Really, funniest vehicles i ever seen before.
Who the hell was owners of this garbage, and how they... just lol.
Maybe just reduce quantity for higher quality of vehicles? no?

2. Mehanic skill.
Cant force myself to level up this. Gas stations dont work without electricity (of course i cant access to the storage directly or power up station), vehicles almost all without fuel. Yes i can fuel them at start of the game, but two weeks running with gas cans each start...boring. Even that, fuel consumption of all cars is huge, no, ridiculous!

Well. Overall. 30-50 hours of gameplay for leveling skill just for 3-4 hours of driving on perfect car, dont know, seems useless. Without mods and cheats at least.

3. Zombies.
So many now. After a month ingame time... lol, its like rush hour in megapolis. Every house full of zombies. Doors, windows, players...all gone. This zombie horde is unstoppable, not bad, but, but... its just corner of small town. I surely need more weapons for this, or "turn undead" spell?... dont know.
Maybe they will be more dangerous bul less hordeous :)
Other is great, great game.

 

20171219221023_1.jpg

Share this post


Link to post
Share on other sites

Started a new MP game:

 

- Had a strange issue where the car HUD disappeared and only thing that showed was the speedometer. Can't figure out if this was due to accidentally pressing some button on the keyboard or a bug, but we couldn't figure out how to get it back.
F37E468AD3F688CB31C0A77C86FBBEBAE7EFF4F3

 

- Items still delete when taking them out of the trunk. Initially we thought this was fixed when we tested it as it seemed to be fine. Upon further testing this acted very strangely, where sometimes items would disappear a second after taking them out and other times they wouldn't. Sometimes only certain items got deleted while others got transferred just fine. 
- Same thing happened when putting items on the floor and moving them over to inventory, some items got deleted when transferring.
- Corpses get deleted when picking them up and dropping them on the floor.
- Can confirm that mechanic books don't work.

- Performance wise it feels pretty good, except for some choppiness when driving fast or going into the center of towns (such as West Point). But general gameplay doesn't seem to have any major lag issues compared to before. I assume the stuttering is still linked to multi story buildings. Have yet to test performance in a longer game, will update.

Share this post


Link to post
Share on other sites

Can confirm experiencing all those issues (save the HUD disappearing), iwawa. I noticed performance was very good for me in Rosewood at the start, but then after getting to peak zombie population and driving to West Point, it got noticeably bad.

 

The desync issues and missing items bugs seem the worst to me out of all of them. That issue with moving items from the floor to inventory also happens consistently moving items from the floor straight to a nearby container. Waiting until Thursday to see if they get fixed. It's no fun losing items or seeing car part conditions get wonky and seemingly randomly change/reset. Seems worse to me as time went on and after moving to West Point, but I don't know if that's just a coincidence and noticing it more.

Share this post


Link to post
Share on other sites

I've noticed far fewer locked cars in build 30.  This seems strange.

 

Also, for a first-day event, WAY too many cars are out of gas. Pristine cars under awnings or in the bank parkinglot? siphoned dry. This makes sense for six months later, but on day one most of the cars might be expected to have some gas, as the gas stations still work...

 

I don't mind that half the cars have crappy tires and are on a quarter tank because its kentucky, and believe me my car was crappy, but it did always have at least a quarter tank.

Edited by thiosk

Share this post


Link to post
Share on other sites

I strongly advise against making house alarms tripping constnatly, a thing.

 

On i3-6100 this MURDERS performance. Besides, there's a glitch. I have set house alarms frequency to never, and they still go off every 5 minutes.

 

This game is really broken now... Thanks to zombies migrating so much to alarms, game stutters, slows down to a crawl, lags and overall is just as unplayable as it was before optimisation patch.

 

Devs, don't you think this game puts a but too much strain on processor with so much content and dependencies in it to process? I feel like you are going to need to strip game from some features in future because YOU WILL NOT be able to optimise it from the looks of it.

Edited by Eggtooth

Share this post


Link to post
Share on other sites
1 hour ago, Eggtooth said:

I strongly advise against making house alarms tripping constnatly, a thing.

 

On i3-6100 this MURDERS performance. Besides, there's a glitch. I have set house alarms frequency to never, and they still go off every 5 minutes.

 

This game is really broken now... Thanks to zombies migrating so much to alarms, game stutters, slows down to a crawl, lags and overall is just as unplayable as it was before optimisation patch.

 

Devs, don't you think this game puts a but too much strain on processor with so much content and dependencies in it to process? I feel like you are going to need to strip game from some features in future because YOU WILL NOT be able to optimise it from the looks of it.

I always suspected that the alarms thing was a bug just from the way they addressed feedback about it, they said they plan to improve the way it happens or whatever I'm too lazy to go find the quote, just gotta hope build 31 does things better. It's a beta feature, they can abandon it whenever. They respond to the community here on the forms pretty good so if it's too AIDS they'll probably take it out. You can always pick up a gun or hop in a car to start making counter noise after the alarm if Z's migrating to wherever you were hunkering down is a problem. 

Share this post


Link to post
Share on other sites

It was actually a surprise side effect of some of the 'vehicle environmental collision' work that Yuri put in I think. A bug that looked like a feature :D

 

I'll put a task in to see if we can refine it a bit - seems like something that could do with some investigation anyways, as it got some positive responses.

Share this post


Link to post
Share on other sites
On 18.12.2017 at 12:49 PM, MSKRod said:

Can someone confirm that Mechanics books are working for them? I went out of my way to find a mechanics book in my already started game (had to go to different town), read it and it just disappeared from my inventory, without giving any xp multiplier bonus. Figuring it's an existing-save bug, I started a new game, turned off zeds just to test that it works in a new start - same effect (no xp multiplier, book vanieshes after finishing)

 

Is it a me bug, or a game bug?

same thing for me, doesnt give bonus (or at least the arrows arent showing) and book disappears after reading.

 

 

Also not sure if the food/weight system works properly. Someone mentioned the character gaining weight even after not eating/starving.

After playing a bit today I tried not eating for longer times and my character didnt loose weight and i think even gained a little...

Edited by Genom

Share this post


Link to post
Share on other sites

Build Vehicle 31:

 

[New]

  • Added a zombie house alarm triggering sandbox options, default false, set it to true to allow zombies to trigger alarms by entering houses.

 

[Balance]

  • Rebind default horn hotkey to Q (same as "shout").

 

[Bug Fix]

  • Fixed Mechanics skill books disappearing after reading.
  • Fixed broken-lock window sync in multiplayer.
  • Fixed new object-sync code not updating the Loot Window.
  • Fixed "template!" calls setting gearRatio to default values.
  • Fixed Cars being oversized on 1x textures.
  • Fixed street lights always working despite electricity shut-off
  • Fixed null pointer when using horn.
  • Fixed IsoObject sprite name being changed (should fix campfires rain barrels etc)
  • Fixed radios (and other things) not working when placed on the ground in multiplayer.
  • Fixed server exception when removing objects from the map.
  • Fixed audio not being muted in the menu in singleplayer.
  • Fixed the vehicle gauge and dashboard flickering and overlap.
  • Fixed character walking to the front of a vehicle to install tail-lights.
  • Fixed van rear windows requiring a door to be installed, when there are no rear doors.
  • Fixed black paint window frame color issue.
  • Fixed vehicles sometimes respawning loot when they shouldn't.
  • Fixed server not handling multiple containers or vehicle-part containers.
  • Fixed new object-sync code not updating the Loot Window.
  • Fixed the loot window not updating when a vehicle door is opened/closed in multiplayer.
  • Fixed players teleporting in multiplayer while inside a vehicle breaking everything.
  • Fixed zombies only spawning Muldraugh map.
  • Fixed some typos in Sandbox texts.

Share this post


Link to post
Share on other sites

@RobertJohnson The break chance of parts needs a serious rebalance.

 

My character has maxed out mechanics and metalworking.

 

I started by removing an old muffler from a car - When the RNG decided I had successfully completed the task, it was at 0% condition coming from 42%, and within 5-8 tries.

 

So then I attempted to install a 100% muffler into the car.

 

After maybe 10 tries, the part finally installed... at 35%

 

Keep in mind that I am maxed out in terms of applicable skills and tools, and I could not install a part without breaking it beyond the initial part's condition, making the attempt to fix it entirely useless. 

 

At level 10 in anything, the chance of breaking parts during a replacement (replacement, not part repair) should be zero percent. I can't imagine how bad the odds will be at lower skill levels. 

 

These same drastic issues also apply to bodywork. I could not replace any part without damaging it beyond where I started.

 

The break chance for removal/installation of these parts did not display either.

 

This being said, I did not experience any bugs with the install. The values need a massive drop in break chance as I cannot imagine replacement work being feasible at all at level 10, let alone level 3 or level 5.

 

 

Edited by Kim Jong Un

Share this post


Link to post
Share on other sites
3 hours ago, RobertJohnson said:

Build Vehicle 31:

 

[New]

  • Added a zombie house alarm triggering sandbox options, default false, set it to true to allow zombies to trigger alarms by entering houses.

 

[Balance]

  • Rebind default horn hotkey to Q (same as "shout").

 

[Bug Fix]

  • Fixed Mechanics skill books disappearing after reading.
  • Fixed broken-lock window sync in multiplayer.
  • Fixed new object-sync code not updating the Loot Window.
  • Fixed "template!" calls setting gearRatio to default values.
  • Fixed Cars being oversized on 1x textures.
  • Fixed street lights always working despite electricity shut-off
  • Fixed null pointer when using horn.
  • Fixed IsoObject sprite name being changed (should fix campfires rain barrels etc)
  • Fixed radios (and other things) not working when placed on the ground in multiplayer.
  • Fixed server exception when removing objects from the map.
  • Fixed audio not being muted in the menu in singleplayer.
  • Fixed the vehicle gauge and dashboard flickering and overlap.
  • Fixed character walking to the front of a vehicle to install tail-lights.
  • Fixed van rear windows requiring a door to be installed, when there are no rear doors.
  • Fixed black paint window frame color issue.
  • Fixed vehicles sometimes respawning loot when they shouldn't.
  • Fixed server not handling multiple containers or vehicle-part containers.
  • Fixed new object-sync code not updating the Loot Window.
  • Fixed the loot window not updating when a vehicle door is opened/closed in multiplayer.
  • Fixed players teleporting in multiplayer while inside a vehicle breaking everything.
  • Fixed zombies only spawning Muldraugh map.
  • Fixed some typos in Sandbox texts.

Don't know if this has been addressed or not, but I don't see it under bug fix. In 30.3 car alarms and house alarms were going off while the sandbox options had them set to never

Share this post


Link to post
Share on other sites
41 minutes ago, TheLeonBM said:

Sometimes there is a delay in actions, if you assign your char to do something It will take up to 5 or 6 second to start doing it. I've been experiencing this since I started playing this branch (b29).

Do you mean when you try to do an action that involves the player walking to some place (including getting in a vehicle)?  I noticed this, it happens when a lot of zombies are waiting to find a path of their own.  The player has to wait until the zombies' paths are calculated.  This will need to be changed so player paths are handled first.

Share this post


Link to post
Share on other sites

I have a problem with game

 

Exception in thread "GameLoadingThread" java.lang.OutOfMemoryError: GC overhead limit exceeded
        at java.util.HashMap.entrySet(HashMap.java:1006)
        at zombie.iso.IsoMetaGrid.savePart(IsoMetaGrid.java:582)
        at zombie.iso.IsoMetaGrid.save(IsoMetaGrid.java:551)
        at zombie.iso.IsoMetaGrid.save(IsoMetaGrid.java:1185)
        at zombie.iso.IsoCell.save(IsoCell.java:5832)
        at zombie.GameWindow.save(GameWindow.java:1992)
        at zombie.GameWindow.save(GameWindow.java:1903)
        at zombie.gameStates.GameLoadingState$1.runInner(GameLoadingState.java:324)
        at zombie.gameStates.GameLoadingState$1.run(GameLoadingState.java:222)
        at java.lang.Thread.run(Thread.java:745)

Share this post


Link to post
Share on other sites
16 minutes ago, EasyPickins said:

Do you mean when you try to do an action that involves the player walking to some place (including getting in a vehicle)?  I noticed this, it happens when a lot of zombies are waiting to find a path of their own.  The player has to wait until the zombies' paths are calculated.  This will need to be changed so player paths are handled first.

 

Yes, but also in other tasks like building, picking up or placing moveables, placing and removing sheet ropes, plastering. Sometimes those actions do require that the char moves from one place to another, but it still happens even if I'm right next to the thing I want to do, don't know if that's what you mean by path.

Edited by TheLeonBM

Share this post


Link to post
Share on other sites
49 minutes ago, EasyPickins said:

Do you mean when you try to do an action that involves the player walking to some place (including getting in a vehicle)?  I noticed this, it happens when a lot of zombies are waiting to find a path of their own.  The player has to wait until the zombies' paths are calculated.  This will need to be changed so player paths are handled first.

It'll eventually stop working entirely, as zombies in that cell path. It doesn't seem as touchy in build 31, but in build 30, I could lock up for a second by honking the horn. Do it two or three times in different spots and all timed actions along with the vehicle menu would break.


Earlier builds didn't seem to have this problem, though the horn/alarm stuff wasn't available then.

e.g. 

 

This must have been just after zombie hearing distance was changed (the further away the zombie is from the sound, the less it updates), as you can see zombies pathing to the old position of the car, standing still, and not walking unendingly when they hit a blocked tile. 

 

I'm pretty sure zombies didn't do this until recently, but here in build 31 you can see zombies walking infinitely against the building instead of stopping or pathing around it, for example. If this is not normal, maybe it's linked to timed actions in some way?

 

 

Share this post


Link to post
Share on other sites
3 minutes ago, EnigmaGrey said:

It'll eventually stop working entirely, as zombies in that cell path. It doesn't seem as touchy in build 31, but in build 30, I could lock up for a second by honking the horn. Do it two or three times in different spots and all timed actions along with the vehicle menu would break.


Earlier builds didn't seem to have this problem, though the horn/alarm stuff wasn't available then.

e.g. 

 

This must have been just after zombie hearing distance was changed (the further away the zombie is from the sound, the less it updates), as you can see zombies pathing to the old position of the car, standing still, and not walking unendingly when they hit a blocked tile. 

 

I'm pretty sure zombies didn't do this until recently, but here in build 31 you can see zombies walking infinitely against the building instead of stopping or pathing around it, for example. If this is not normal, maybe it's linked to timed actions in some way?

 

 

 

I've also noticed A TON of zeds stuck walking against fences and walls everywhere, forgot to mention it. 

Share this post


Link to post
Share on other sites

Just was playing with friends and tried to go to the shopping mall to loot it, in 2 separate vehicles with 4 players. The game started to get really slow and then the Steam-hosted server disconnected for all of us and game crashed for a couple of us. Loaded it back up and I'm having trouble finding the vehicle I was in, though I found the other. It disconnected once again trying to find it on my own, but loading it a second time, it ran better moving very slowly (so the engine had time to load things I assume), although ultimately it ended up crashing with part of the map not even loading.

 

I think it's performance related and the game just couldn't handle the huge parking lot packed with zeds and vehicles. I'm about to load it up on a dedicated server with 16 GB of RAM rather than 8 GB and hosted through the game, see if I can find my car and if it runs any better. This is also why I suggested a spawncar admin command, since if I do lose my car, it wouldn't be a big deal if I could spawn another of the same type and colour (as it was a rather rare one).

 

Item desyncs and disappearances seem a lot better after the last patch, though car conditions are still a bit funky. If you crash it often doesn't seem to show damage immediately and only does after a server restart, which I've consistently noticed. Trunks really don't like being repaired and reset after a restart. Conditions seem to desync and change for other reasons (somewhat randomly) but I find it hard to narrow down.

 

edit: still had the error on a dedicated server but performance is a bit better, here's the error when I got the disconnect in the mall parking lot

 

Spoiler

1513811836477 Waiting for player-connect response from server
Processing delayed packets...
1513811836590 LuaNet: Loading...
FirstNAME:Sowilo
COMMAND QUEUE stallCount = 0 peakUsage = 3376
MISSING in .bank car/04
419305288
MISSING in .bank car/05
419306488
MISSING in .bank car/06
419302888
MISSING in .bank car/07
527411864
MISSING in .bank car/08
532934120
MISSING in .bank car/09
5953095480
MISSING in .bank car/10
5953095880
MISSING in .bank car/11
5953099480
MISSING in .bank car/12
5953096280
MISSING in .bank car/13
5953100680
MISSING in .bank car/14
5953097480
MISSING in .bank car/15
5953100280
MISSING in .bank car/16
5953097880
MISSING in .bank car/17
5953098680
MISSING in .bank car/18
5953101080
MISSING in .bank car/19
5953101480
MISSING in .bank car/20
5953096680
MISSING in .bank car/21
5953094680
MISSING in .bank car/22
5953097080
MISSING in .bank car/23
5953095080
MISSING in .bank car/24
5953099880
MISSING in .bank car/25
5953098280
MISSING in .bank car/26
5953093880
MISSING in .bank car/27
5953099080
MISSING in .bank car/28
5953094280
MISSING in .bank car/29
5818627592
MISSING in .bank car/30
5818621992
MISSING in .bank car/31
5818623992
MISSING in .bank car/32
5818628392
MISSING in .bank car/33
5818627992
MISSING in .bank car/34
5818627192
MISSING in .bank car/35
5818624392
MISSING in .bank car/36
5818626392
MISSING in .bank car/37
5818620792
MISSING in .bank vehicle_start
5818621592
MISSING in .bank vehicle_failing_to_start
5818621192
MISSING in .bank vehicle_turned_off
5818625192
MISSING in .bank vehicle_running_out_of_gas
5818622392
MISSING in .bank vehicle_skid
5818622792
MISSING in .bank IdleEngine
COMMAND QUEUE stallCount = 0 peakUsage = 5760
COMMAND QUEUE stallCount = 0 peakUsage = 7200
1513811955165 ERROR: missing tile location_shop_mall_signs_01_88
Error with packet of type: 164
java.lang.IllegalArgumentException
        at java.nio.Buffer.position(Buffer.java:244)
        at zombie.iso.ObjectsSyncRequests.receiveGridSquareObjects(ObjectsSyncRequests.java:353)
        at zombie.network.GameClient.SyncObjectsReq(GameClient.java:4161)
        at zombie.network.GameClient.mainLoopDealWithNetData(GameClient.java:799)
        at zombie.network.GameClient.update(GameClient.java:296)
        at zombie.GameWindow.logic(GameWindow.java:594)
        at zombie.GameWindow.run(GameWindow.java:1282)
        at zombie.GameWindow.maina(GameWindow.java:1058)
        at zombie.gameStates.MainScreenState.main(MainScreenState.java:183)
1513811957250 playNightAmbient: PercussiveAmbient
Error with packet of type: 164
java.lang.IllegalArgumentException
        at java.nio.Buffer.position(Buffer.java:244)
        at zombie.iso.ObjectsSyncRequests.receiveGridSquareObjects(ObjectsSyncRequests.java:353)
        at zombie.network.GameClient.SyncObjectsReq(GameClient.java:4161)
        at zombie.network.GameClient.mainLoopDealWithNetData(GameClient.java:799)
        at zombie.network.GameClient.update(GameClient.java:296)
        at zombie.GameWindow.logic(GameWindow.java:594)
        at zombie.GameWindow.run(GameWindow.java:1282)
        at zombie.GameWindow.maina(GameWindow.java:1058)
        at zombie.gameStates.MainScreenState.main(MainScreenState.java:183)
COMMAND QUEUE stallCount = 0 peakUsage = 7376
1513811957988 ERROR: missing tile vegetation_foliage_01_2
COMMAND QUEUE stallCount = 0 peakUsage = 7632
Error with packet of type: 164
java.lang.IllegalArgumentException
        at java.nio.Buffer.position(Buffer.java:244)
        at zombie.iso.ObjectsSyncRequests.receiveGridSquareObjects(ObjectsSyncRequests.java:353)
        at zombie.network.GameClient.SyncObjectsReq(GameClient.java:4161)
        at zombie.network.GameClient.mainLoopDealWithNetData(GameClient.java:799)
        at zombie.network.GameClient.update(GameClient.java:296)
        at zombie.GameWindow.logic(GameWindow.java:594)
        at zombie.GameWindow.run(GameWindow.java:1282)
        at zombie.GameWindow.maina(GameWindow.java:1058)
        at zombie.gameStates.MainScreenState.main(MainScreenState.java:183)
Error with packet of type: 164
java.lang.IllegalArgumentException
        at java.nio.Buffer.position(Buffer.java:244)
        at zombie.iso.ObjectsSyncRequests.receiveGridSquareObjects(ObjectsSyncRequests.java:353)
        at zombie.network.GameClient.SyncObjectsReq(GameClient.java:4161)
        at zombie.network.GameClient.mainLoopDealWithNetData(GameClient.java:799)
        at zombie.network.GameClient.update(GameClient.java:296)
        at zombie.GameWindow.logic(GameWindow.java:594)
        at zombie.GameWindow.run(GameWindow.java:1282)
        at zombie.GameWindow.maina(GameWindow.java:1058)
        at zombie.gameStates.MainScreenState.main(MainScreenState.java:183)
COMMAND QUEUE stallCount = 0 peakUsage = 9056
1513811958615 ERROR: missing tile vegetation_groundcover_01_22
1513811958615 ERROR: missing tile vegetation_groundcover_01_19
1513811958622 ERROR: missing tile vegetation_groundcover_01_18
1513811958632 ERROR: missing tile vegetation_groundcover_01_21
1513811958641 ERROR: missing tile vegetation_groundcover_01_23
COMMAND QUEUE stallCount = 0 peakUsage = 15424
Error with packet of type: 164
java.lang.IllegalArgumentException
        at java.nio.Buffer.position(Buffer.java:244)
        at zombie.iso.ObjectsSyncRequests.receiveGridSquareObjects(ObjectsSyncRequests.java:353)
        at zombie.network.GameClient.SyncObjectsReq(GameClient.java:4161)
        at zombie.network.GameClient.mainLoopDealWithNetData(GameClient.java:799)
        at zombie.network.GameClient.update(GameClient.java:296)
        at zombie.GameWindow.logic(GameWindow.java:594)
        at zombie.GameWindow.run(GameWindow.java:1282)
        at zombie.GameWindow.maina(GameWindow.java:1058)
        at zombie.gameStates.MainScreenState.main(MainScreenState.java:183)
Error with packet of type: 164
java.lang.IllegalArgumentException
        at java.nio.Buffer.position(Buffer.java:244)
        at zombie.iso.ObjectsSyncRequests.receiveGridSquareObjects(ObjectsSyncRequests.java:353)
        at zombie.network.GameClient.SyncObjectsReq(GameClient.java:4161)
        at zombie.network.GameClient.mainLoopDealWithNetData(GameClient.java:799)
        at zombie.network.GameClient.update(GameClient.java:296)
        at zombie.GameWindow.logic(GameWindow.java:594)
        at zombie.GameWindow.run(GameWindow.java:1282)
        at zombie.GameWindow.maina(GameWindow.java:1058)
        at zombie.gameStates.MainScreenState.main(MainScreenState.java:183)
COMMAND QUEUE stallCount = 0 peakUsage = 16960
COMMAND QUEUE stallCount = 0 peakUsage = 17072
Error with packet of type: 164
java.lang.IllegalArgumentException
        at java.nio.Buffer.position(Buffer.java:244)
        at zombie.iso.ObjectsSyncRequests.receiveGridSquareObjects(ObjectsSyncRequests.java:353)
        at zombie.network.GameClient.SyncObjectsReq(GameClient.java:4161)
        at zombie.network.GameClient.mainLoopDealWithNetData(GameClient.java:799)
        at zombie.network.GameClient.update(GameClient.java:296)
        at zombie.GameWindow.logic(GameWindow.java:594)
        at zombie.GameWindow.run(GameWindow.java:1282)
        at zombie.GameWindow.maina(GameWindow.java:1058)
        at zombie.gameStates.MainScreenState.main(MainScreenState.java:183)
COMMAND QUEUE stallCount = 0 peakUsage = 17344
COMMAND QUEUE stallCount = 0 peakUsage = 17632
Error with packet of type: 164
java.lang.IllegalArgumentException
        at java.nio.Buffer.position(Buffer.java:244)
        at zombie.iso.ObjectsSyncRequests.receiveGridSquareObjects(ObjectsSyncRequests.java:353)
        at zombie.network.GameClient.SyncObjectsReq(GameClient.java:4161)
        at zombie.network.GameClient.mainLoopDealWithNetData(GameClient.java:799)
        at zombie.network.GameClient.update(GameClient.java:296)
        at zombie.GameWindow.logic(GameWindow.java:594)
        at zombie.GameWindow.run(GameWindow.java:1282)
        at zombie.GameWindow.maina(GameWindow.java:1058)
        at zombie.gameStates.MainScreenState.main(MainScreenState.java:183)
COMMAND QUEUE stallCount = 0 peakUsage = 19200
COMMAND QUEUE stallCount = 0 peakUsage = 28512
5814685352
COMMAND QUEUE stallCount = 0 peakUsage = 32768
COMMAND QUEUE stallCount = 1 peakUsage = 32768
COMMAND QUEUE stallCount = 1 peakUsage = 33248
MISSING in .bank vehicle_door_open
532932920
MISSING in .bank vehicle_door_close
5818070184
1513812017610 stop ambient PercussiveAmbient
1513812033095 ERROR: Missing translation "UI_ServerOptionDesc_TimeMultiplier"
1513812040711 playNightAmbient: RhythmicAmbient
1513812042259 ERROR: missing tile vegetation_foliage_01_12
1513812042259 ERROR: missing tile vegetation_foliage_01_10
1513812042260 ERROR: missing tile vegetation_foliage_01_9
1513812042260 ERROR: missing tile vegetation_foliage_01_14
1513812042260 ERROR: missing tile vegetation_foliage_01_8
1513812042366 ERROR: missing tile vegetation_foliage_01_11
1513812042401 ERROR: missing tile vegetation_foliage_01_13
1513812056231 playNightAmbient: PercussiveAmbient
1513812061426 playNightAmbient: VoiceAmbient
1513812088025 playNightAmbient: IntenseAmbient
1513812101893 stop ambient RhythmicAmbient
1513812116549 stop ambient PercussiveAmbient
1513812135820 stop ambient VoiceAmbient
1513812140883 playNightAmbient: VoiceAmbient
1513812144360 stop ambient IntenseAmbient
1513812161090 playNightAmbient: PercussiveAmbient
1513812192410 ERROR: receiveGridSquareObjects null
Error with packet of type: 164
java.lang.IllegalArgumentException
        at java.nio.Buffer.position(Buffer.java:244)
        at zombie.iso.ObjectsSyncRequests.receiveGridSquareObjects(ObjectsSyncRequests.java:353)
        at zombie.network.GameClient.SyncObjectsReq(GameClient.java:4161)
        at zombie.network.GameClient.mainLoopDealWithNetData(GameClient.java:799)
        at zombie.network.GameClient.update(GameClient.java:296)
        at zombie.GameWindow.logic(GameWindow.java:594)
        at zombie.GameWindow.run(GameWindow.java:1282)
        at zombie.GameWindow.maina(GameWindow.java:1058)
        at zombie.gameStates.MainScreenState.main(MainScreenState.java:183)
Error with packet of type: 164
java.lang.IllegalArgumentException
        at java.nio.Buffer.position(Buffer.java:244)
        at zombie.iso.ObjectsSyncRequests.receiveGridSquareObjects(ObjectsSyncRequests.java:353)
        at zombie.network.GameClient.SyncObjectsReq(GameClient.java:4161)
        at zombie.network.GameClient.mainLoopDealWithNetData(GameClient.java:799)
        at zombie.network.GameClient.update(GameClient.java:296)
        at zombie.GameWindow.logic(GameWindow.java:594)
        at zombie.GameWindow.run(GameWindow.java:1282)
        at zombie.GameWindow.maina(GameWindow.java:1058)
        at zombie.gameStates.MainScreenState.main(MainScreenState.java:183)
Error with packet of type: 164
java.lang.IllegalArgumentException
        at java.nio.Buffer.position(Buffer.java:244)
        at zombie.iso.ObjectsSyncRequests.receiveGridSquareObjects(ObjectsSyncRequests.java:353)
        at zombie.network.GameClient.SyncObjectsReq(GameClient.java:4161)
        at zombie.network.GameClient.mainLoopDealWithNetData(GameClient.java:799)
        at zombie.network.GameClient.update(GameClient.java:296)
        at zombie.GameWindow.logic(GameWindow.java:594)
        at zombie.GameWindow.run(GameWindow.java:1282)
        at zombie.GameWindow.maina(GameWindow.java:1058)
        at zombie.gameStates.MainScreenState.main(MainScreenState.java:183)
Error with packet of type: 164
java.lang.IllegalArgumentException
        at java.nio.Buffer.position(Buffer.java:244)
        at zombie.iso.ObjectsSyncRequests.receiveGridSquareObjects(ObjectsSyncRequests.java:353)
        at zombie.network.GameClient.SyncObjectsReq(GameClient.java:4161)
        at zombie.network.GameClient.mainLoopDealWithNetData(GameClient.java:799)
        at zombie.network.GameClient.update(GameClient.java:296)
        at zombie.GameWindow.logic(GameWindow.java:594)
        at zombie.GameWindow.run(GameWindow.java:1282)
        at zombie.GameWindow.maina(GameWindow.java:1058)
        at zombie.gameStates.MainScreenState.main(MainScreenState.java:183)
Error with packet of type: 164
java.lang.IllegalArgumentException
        at java.nio.Buffer.position(Buffer.java:244)
        at zombie.iso.ObjectsSyncRequests.receiveGridSquareObjects(ObjectsSyncRequests.java:353)
        at zombie.network.GameClient.SyncObjectsReq(GameClient.java:4161)
        at zombie.network.GameClient.mainLoopDealWithNetData(GameClient.java:799)
        at zombie.network.GameClient.update(GameClient.java:296)
        at zombie.GameWindow.logic(GameWindow.java:594)
        at zombie.GameWindow.run(GameWindow.java:1282)
        at zombie.GameWindow.maina(GameWindow.java:1058)
        at zombie.gameStates.MainScreenState.main(MainScreenState.java:183)
Error with packet of type: 164
java.lang.IllegalArgumentException
        at java.nio.Buffer.position(Buffer.java:244)
        at zombie.iso.ObjectsSyncRequests.receiveGridSquareObjects(ObjectsSyncRequests.java:353)
        at zombie.network.GameClient.SyncObjectsReq(GameClient.java:4161)
        at zombie.network.GameClient.mainLoopDealWithNetData(GameClient.java:799)
        at zombie.network.GameClient.update(GameClient.java:296)
        at zombie.GameWindow.logic(GameWindow.java:594)
        at zombie.GameWindow.run(GameWindow.java:1282)
        at zombie.GameWindow.maina(GameWindow.java:1058)
        at zombie.gameStates.MainScreenState.main(MainScreenState.java:183)
1513812215213 stop ambient VoiceAmbient
1513812221420 stop ambient PercussiveAmbient
1513812272151 playNightAmbient: RhythmicAmbient
1513812280965 playNightAmbient: IntenseAmbient
Error with packet of type: 164
java.lang.IllegalArgumentException
        at java.nio.Buffer.position(Buffer.java:244)
        at zombie.iso.ObjectsSyncRequests.receiveGridSquareObjects(ObjectsSyncRequests.java:353)
        at zombie.network.GameClient.SyncObjectsReq(GameClient.java:4161)
        at zombie.network.GameClient.mainLoopDealWithNetData(GameClient.java:799)
        at zombie.network.GameClient.update(GameClient.java:296)
        at zombie.GameWindow.logic(GameWindow.java:594)
        at zombie.GameWindow.run(GameWindow.java:1282)
        at zombie.GameWindow.maina(GameWindow.java:1058)
        at zombie.gameStates.MainScreenState.main(MainScreenState.java:183)
1513812289578 playNightAmbient: ZombieAmbient
1513812290642 playNightAmbient: CreepyAmbient
1513812305047 znet: ZNetFriends::OnPersonaStateChange
1513812332462 stop ambient RhythmicAmbient
1513812332717 playNightAmbient: PercussiveAmbient
1513812334134 znet: ZNetFriends::OnPersonaStateChange
1513812337296 stop ambient IntenseAmbient
1513812346828 stop ambient ZombieAmbient
1513812360974 stop ambient CreepyAmbient
1513812393036 stop ambient PercussiveAmbient
1513812511202 znet: Connection closed: reason=2 port=1
1513812511204 RakNetPeerInterface.connectionStateChangedCallback state=Disconnected message= thread=Thread[UdpEngine,5,main]
1513812511205 Connection Lost
STATE: yield zombie.gameStates.IngameState
STATE: enter zombie.gameStates.ServerDisconnectState

 

edit2: things seem totally broken in the mall area for me, everything is weird, some of the cars float or parts of the map don't load properly, my awesome car disappeared after a dc, etc. If any more info is needed I'd be happy to provide screenshots, videos or more error logs.

Edited by NorthRoad

Share this post


Link to post
Share on other sites

Okay so FINALLY i got a chance to test out Build 30. Here are my notes:

 

- Car wrecks are floating a few feet off the ground with noticeable shadows underneath

- FPS has definitely improved, still stutters when there are large hordes or in urban areas but that's probably just my weak system

- Pressing H to honk the horn in vehicles also brings up the Health tab, which is annoying. Speaking of which...

- The horn is still f*cking awful, for every vehicle. It's glitchy and scratchy and tinny. It's just horrible. 

- The whole interior/exterior cutaway thing, in my opinion, just isn't working out. Too often I lose sight of my character behind buildings that haven't cut away resulting in my guy blundering into an unseen zombie and getting killed. Plus it's super frustrating when trying to barricade windows, whenever you move the building keeps flashing full/cut away. It's a nightmare on the eyes. I honestly had no problem with how it was before. 

- Certain items and textures like trash piles still overlap vehicles

- I am unable to build an effective wall around my base due to a vehicle in the way, a vehicle that doesn't have a key. The best I could try to do right now is move it with another vehicle, but that might be more trouble than it's worth. There needs to be an option to physically push cars out of the way. It would be slow, yeah, but it could definitely help with stuff like wrecks blocking the highway. 

 

That's all for now

 

Share this post


Link to post
Share on other sites
4 hours ago, Brex said:

Okay so FINALLY i got a chance to test out Build 30. Here are my notes:

 

- Car wrecks are floating a few feet off the ground with noticeable shadows underneath

- FPS has definitely improved, still stutters when there are large hordes or in urban areas but that's probably just my weak system

- Pressing H to honk the horn in vehicles also brings up the Health tab, which is annoying. Speaking of which...

- The horn is still f*cking awful, for every vehicle. It's glitchy and scratchy and tinny. It's just horrible. 

- The whole interior/exterior cutaway thing, in my opinion, just isn't working out. Too often I lose sight of my character behind buildings that haven't cut away resulting in my guy blundering into an unseen zombie and getting killed. Plus it's super frustrating when trying to barricade windows, whenever you move the building keeps flashing full/cut away. It's a nightmare on the eyes. I honestly had no problem with how it was before. 

- Certain items and textures like trash piles still overlap vehicles

- I am unable to build an effective wall around my base due to a vehicle in the way, a vehicle that doesn't have a key. The best I could try to do right now is move it with another vehicle, but that might be more trouble than it's worth. There needs to be an option to physically push cars out of the way. It would be slow, yeah, but it could definitely help with stuff like wrecks blocking the highway. 

 

That's all for now

 

I agree with everything this post has to say

Share this post


Link to post
Share on other sites

The Horn key i've changed is the default one, meaning in your case it has been binded to "h" already, it'll be for new player (or delete your keybinding file).

 

Pushing car, i mean, why not, but pushing a car that is parked? No one can do that.. It's more like a 4-6 men job to carry the vehicle away. Or it'll require you to break the window/remove the park break... But we don't really have a park break yet. Best way is to ram it then :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
36 36