Jump to content

How to fix updated mods in Build 41 Multiplayer


AuthenticPeach
 Share

Recommended Posts

Hello All! I made this guide to assist the many bug reports that have come in regarding mods that have updated after the release of Build 41 Multiplayer.

I have put together all the walkthroughs and guides here so you don't have to fish around for odd ends and bits. More may come as things develop.

 

One of the main issues that sprung up with the release of Project Zomboid's Build 41 Multiplayer is the issue of mods updating after a local or dedicated server uses the mod for its save.  

This issue occurs because, in the last six months, steam's servers have been unreliably updating mod data for clients.

Some things to know:

  • Workshop ID's for mods are located on the bottom of each mod's workshop page.
    bandicam 2021-12-12 10-38-15-742.jpg
    Figure 1: Mod Workshop ID of Authentic Z 
     
  • When you enable a mod for a server, there are two locations involved: 
    • A server directory for each mod
    • A client directory for each mod

 

When it comes to PZ Multiplayer, all of the files in both locations must be identical as it is used as an anti-cheat measure. Therefore:

  • Since the client's copy may be mismatched with the server copy, the client will be rejected with a message:  "Workshop item version is different than server's"

 

1092062183_bandicam2021-12-1121-09-30-241.thumb.jpg.b66cb4140dac72fde657d4a1a88c08c9.jpg

Figure 2: Mod mismatch from the host end.

bandicam 2021-12-11 21-18-54-302.jpg

Figure 3: Mod mismatch from the client end.

 

The Fixes

There are a few fixes and workarounds that people have found to have fixed this issue.

 

Method 1: 

Copy, delete, paste method

 Note: this method may only apply to Local Hosted servers. 

1: Copy mod folder from "...\steam\steamapps\workshop\content\108600"

2: Delete the old and Paste the mod folder in  "...\Steam\steamapps\common\ProjectZomboid\steamapps\workshop\content\108600"

 

Example:

Copy the 2335368829 folder (Authentic Z mod folder) from
"...\steam\steamapps\workshop\content\108600"

and pasted it to "...\Steam\steamapps\common\ProjectZomboid\steamapps\workshop\content\108600"

bandicam 2021-12-12 00-17-33-084.jpg

Figure 4:  Step 1 on Left, Step 2 on Right. Notice how the right location was older than the left location. Delete the old, paste in the newer one from the left side. 

 

 

Method 2: 

E6 Method (from user Глеб) 

1. Delete the "appworkshop_108600.acf" file that's inside the "C:\Program Files (x86)\Steam\steamapps\common\ProjectZomboid\steamapps\workshop" path, if you are running a dedicated server it would be in "\SteamLibrary\steamapps\common\Project Zomboid Dedicated Server\steamapps\workshop"

after that run the server and it will force update the mods of your server

 

 

Method 3: 

Klean Method

 Note: this method  only applies  to Dedicated servers. 

"For klean's server, after Filibuster's updated, this worked so that the server would update to the updated version of Filibusters. Should work for mods that recently updated, although the clients also need to ensure that they have updated versions of the mods as well

In the installation directory for the dedicated server, you'll have a steamapps folder. Just delete it, as it only contains mod info, including Steam's manifest. If there's an issue with the manifest updating (or it thinks its already updated), the game won't download the mods.
It should then work the next time you start the server."


Regarding Local hosted servers
go into steam and into the game's properties, browse local files, inside the PZ folder, delete the entire steamapps folder. 

 

Method 4: 

Spiffo Bot Method

Many instances of mismatching mod versions have been fixed by unsubscribing from the mod(s), restarting Steam, and then resubscribing to the mod(s). Alternatively, in the installation directory for the dedciated server, you'll have a *steamapps *folder. Just delete it, as it only contains mod info, including Steam's manifest. If there's an issue with the manifest updating (or it thinks its already updated), the game won't download the mods. The mod might then work when restarting the server.

 

Please also make sure you are not subscribing to random mod packages that simply upload an unedited version of a mod. When the original mod authors update their mods, you will have to rely on whoever uploaded that modpack to keep the mods up to date. Instead, use the workshops "Collections" feature. Modpacks that upload mods without the approval of the mod authors are also subject to be removed from the workshop at any point.

 

 

Method 5: 

The Nuclear Route (To get it working at all costs)

1: Delete world

2: Remove problematic mod(s) from server settings and save this. 

3: Close game and unsubscribe from problematic mod(s)

4: Completely Close Steam

5: Re-subscribe to problematic mod(s) , start game up, readd them in settings, create new world. 

 

Some other helpful reads:

 

https://steamcommunity.com/sharedfiles/filedetails/?id=2681173441

https://steamcommunity.com/app/108600/discussions/0/3198115500363908004

https://steamcommunity.com/app/108600/discussions/0/3198116134628473049/

https://steamcommunity.com/workshop/filedetails/discussion/2335368829/3198116134629549910/

 

More methods may come at a later time. 

Edited by AuthenticPeach
Link to comment
Share on other sites

I haven't switched over to the MP version of the Beta cause I'm not ready to leave my current playthrough, and it seems your Mods aren't working for 41.56.  When I look at the mods list it says the Tsars Library is only available for version 41.60 and newer.  Is there a way you can keep a version available for those still using older versions of the Beta active?  Or is there a work around so I don't lose mod functionality for the version I'm playing? Either way, great content, just wish I didn't lose everything I had in my trailer when your wonderful mods decided to only support the new version.  =(

 

I'm using your...

Tsar Library

AutoTrailers

Aquastar Yacht Club

 

Thanks for any information you can provide.

 

Cheers.

Link to comment
Share on other sites

Hi, while working with the "True Music [41.54+]" mod on the b41multiplayer version through -debug I came across this error. Moving on to the location, I realized that most likely the developers changed the name in ProceduralDistribution.lua, indeed the name was changed from GarageMechanic to GarageMechanics. After I fixed it in the TCloading.lua file - Everything worked in multiplayer too. But either I went overboard with the chance of spawning in the server settings, or these changes affected the overall list. If you have any questions, I'm ready to answer.
 


 1.png.84737bca91e79f1746b2d8fdc01a5162.png

Link to comment
Share on other sites

  • 3 weeks later...

Hey guys I need help I’m new to zomboid and can’t get my mods to activate in server I guess they work on solo but want to play with my buddies so when I go to host and just load a game up and enable all the mods none of them work there all enabled but it just don’t put them in the game or server spent hours fighting ut and can’t figure it out don’t see what I’m missing 

Link to comment
Share on other sites

Important note, that can also help to finally make your modded Zomboid work (discovered when i was trying to start heavily modded server):

In some cases there is a error when starting local server, that looks like "File doesn't exist on the client: ..."

And usually it points at some file from some mod, in my case it pointed at file from "APOCALYPSE MACHINES 2 WHEELZ" (2638496761).

For some reason this problem can be completely not related to mod which includes this file (and to file itself).

In my case problem was caused by "MRE mod" (2605507108), i found it by adding mods by groups, and then disabling last added mods one by one when facing problem until it's gone. (I thought about this when i managed to start server only with mod that was seems to cause problem)

After finding this and re-subscribing on this mod i manadged to successfully start server with all mods without mismatches and without disabling any mod.

 

Also not saw here any tips about checking "console.txt" and "coop-console.txt" in "C:\Users\[USER]\Zomboid", sometimes it can help a lot with dealing with mismatches and other problems. Especially it helpful when dealing with "Workshop item version is different than server's" mismatches, after getting this error we just need to check "console.txt", there will be some like:

LOG  : General     , 1641925028047> ConnectToServerState: item state CheckItemState -> Ready ID=2643751872
LOG  : General     , 1641925028048> ConnectToServerState: GetItemState()=Subscribed|Installed ID=2398253681
LOG  : General     , 1641925028048> 1641925028048 znet: Java_zombie_core_znet_SteamWorkshop_n_1GetItemInstallTimeStamp
LOG  : General     , 1641925028048> ConnectToServerState: item state CheckItemState -> Ready ID=2398253681
LOG  : General     , 1641925028049> ConnectToServerState: GetItemState()=Subscribed|Installed ID=2459400130
LOG  : General     , 1641925028050> 1641925028050 znet: Java_zombie_core_znet_SteamWorkshop_n_1GetItemInstallTimeStamp
LOG  : General     , 1641925028050> ConnectToServerState: item state CheckItemState -> Fail ID=2459400130
LOG  : General     , 1641925028052> 1641925028052 znet: Java_zombie_core_raknet_RakNetPeerInterface_disconnect
LOG  : General     , 1641925028052> Disconnecting,

And then we just need to find mod with this ID and re-subscribe on it, and problem is gone.

Link to comment
Share on other sites

  • 9 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...