Search the Community

Showing results for tags 'Answered'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News & Announcements
    • News
  • Project Zomboid
    • PZ Updates
    • General Discussions
    • Bug Reports
    • PZ Support
    • PZ Multiplayer
    • PZ Community & Creativity
    • PZ Suggestions
  • PZ Modding
    • Tutorials & Resources
    • Mods
    • Items
    • Mapping
    • Mod Ideas and Requests
  • General Games Development
    • Indie Scene
  • Other Discussions
    • General Discussion
    • Forum Games & Activities
    • Pen & Paper / Community RPGs

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Twitter


Interests

Found 6 results

  1. Edit:Topic reopened because more is known about the problem, here is the new info as I posted bellow: I am trying to change a few items in hydrocraft ( http://steamcommunity.com/sharedfiles/filedetails/?id=498441420&searchtext=hydrocraft ) using darkslayer's item teaker api ( http://steamcommunity.com/sharedfiles/filedetails/?id=566115016&searchtext=Item+Tweaker+API ). I was under the impression that this code would do what I want: but it does not seem to work (Nothing changes in game) even after restarting the world. I am attaching the full structure of the mod I created to do this with the code in it. Thank you to anyone who can help. BetterCarts.zip
  2. demeggy

    (Newb) LUA not Triggering

    Afternoon all, Full disclosure; I feel like an absolute wally for not being able to crack this, I've got plenty of experience with LUA and the likes to have gotten the scripting working on other games and platforms - but for the life of me, my very basic opening script just won't trigger on the GameStart Event. Could someone very kindly point out what a mere simpleton like myself is doing wrong? Saving the .lua to Mod Dir: C:\Users\Demeggy\Zomboid\mods\practise01a\media\lua\addItem.lua local function addItems()local player = getSpecificPlayer(0); -- Java: get player onelocal inv = player:getInventory(); -- Java: access player inv-- Java: add the actual items to the inventoryinv:AddItem("Base.Screwdriver");player:Say("Look at my shiny Screwdriver!");endEvents.OnGameStart.Add(addItems);Many, many thanks from a frustrated individual. D Edit: Worth me also noting that the Mod is being picked up by the ModLoader, and is enabled!
  3. Hi guys, I'm curently working on a vision diseaes related mod and I would love to be able to add it some overhauls by controling the zoom (lock it, change it etc...) I'm searching for example the code I could use to "lock" the zoom really close to the player for example But I don't know wich function I should call to prevent the player from de-zooming when he has lost his glasses for example... Anyway, hope you guys could give me some leads
  4. I'm on Ubuntu and I used "arecord -f cd -t raw -d 2 | oggenc - -r -o chainsaw.ogg" to record a file. oggenc crashed, but I can still play the file with ogg123, however, PZ won't play the file. Answer: (I can't seem to reply to my own post: the reply merges into the original) When I did ogginfo on a PZ sound ogg file that would play and my file I noticed that ogginfo pointed out that my file didn't have an EOF (which makes sense since oggenc crashed). I switched to record a wav file with arecord (-t wav) and then encoded the wav file with oggenc; after that PZ would play my (silly placeholder) ogg file.
  5. ToastedFishSandwich

    Spawning Zombies

    Hi all. I've just started making a mod in which killing a zombie will spawn two zombies. Unfortunately I don't know how to spawn even a single zombie. So far literally all I've got is: function duplicateFunction(player,item) zombie.scripting.commands.World.SpawnZombie(); zombie.scripting.commands.World.SpawnZombie(); end Events.OnZombieDead.Add(duplicateFunction); Edit: I was searching through the JavaDocs and I found the bold parts, are they right? How do I tell the game where to put them? I've got pretty much no prior knowledge of modding or, indeed, lua so please don't overcomplicate things. I basically just need some kind of function to spawn a zombie and I guess I'll need to find the position of the original re-dead'd zombie. Halp pls.
  6. NOTE : The latest update of 400kb 12th of November 2013 has fixed this issue by providing two new .bat files, one for 64 bit and one for 32 bit. These both launch using compatibility mode and use 1GB memory by default (64-bit) or 3/4GB (for 32-bit). Personally I would increase the maximum memory for the 64-bit version to a higher value (I use 3GB to be safe) if you have the RAM, as 1GB induces to much stuttering on my systemHello Purchased and downloaded PROJECT ZOMBOID from Steam about 6 hours ago on STEAM. So far I have been unable to play the game at all. At the moment I have 2 problems. 1. Have been unable to start the game through either STEAM, STEAM Compatibility Mode or either of the two executable (32bit or 64bit). Upon trying any of these a DOS CMD Window spawns and then closes before posting a single error msg to the console : "Could Not Load Main Client". SOLUTIONS TRIED : a). Full Clean Re-Install after deleting local content. Performed 3 times. 2). Download latest 32-BIT and 64-BIT JAVA RUNTIME. Performed twice. c). Run the ProjectZomboid.bat batch file that launches java directly. This allowed me to get far enough into the game to actually begin a new "campaign". So great we have a workaround for 1, but this leads to problem 2. 2. Having launched PZ, and begun a new game I am presented with a screen that seems to render the UI perfectly (can read the tutorial hints, get into inventory, stuff like that) but cannot see anything of the in game area. In other words I cannot see my avatar, the houses, zombies, grass etc etc; its ALL black. SOLUTION TRIED : a). Installed the latest NVidia video driver 331.65 (had the 327.?? driver previously). 2). Tried moving around the scene for 5 - 10 minutes at a time, as some threads mentioned that time fixed the problem. c). Tried saving and then reloading, and then moving/waiting. d). Altered the .bat file to allow for more memory being made available to PZ, as per one of the threads on this/steam forums. e). Altered the .bat file to spawn using SAFEMODE (ie prefixed with -D) which is supposedly meant to fix issues with the BLACK SCREEN by forcing compatibility mode which uses compressed textures. f) Reduced in-game GRAPHICS SETTING from HIGHEST and then incrementally down to LOW (as VERY LOW is meant to be broken according to the forums). So now I am completely out of options. Now here are my system specs. Now I realise my processor is currently BELOW what is listed in the STORE page, but consider this to be an extremely unlikely cause for issues, especially considering my FPS is decent and the problem appears to be graphical in nature. DUAL CORE 2.97GHZ NVidia GTX 280 * 2 SLI (have tried single GPU and SLI mode, fiddled with various SLI rendering modes, even created my own using NVidia inspector). 6GB DDR3 Mem Windows 7 64-BIT So any ideas, as I have exhausted all of the internet's advice that I could find ? I would appreciate some Indie Stone support here if possible (especially as it seems I am not the only one having this issue), but anyone is welcome to assist where they can. Also is there a list somewhere of the video cards that currently are supported for the shader's setting in the video options? Yes extremely optimistic asking about that given I cannot even run the game, but still while I'm here and all that Thanks Everyone BTW If you need more info, please just ask as I will be online for another few hours, lamenting all the zombies I could have been slaying (errrr hiding from). SOLUTION (AS PROVIDED BY ENIGMA GREY) Problem (1). No solution is available right now, the .BAT file is the only workaround. Problem (2). The games .bat file is a little "outdated" and has issues, the solution was to replace the original file with a simple one provided by Enigma Grey that would still enforce the safemode/compatibility mode (Respone #45 of this THREAD : http://theindiestone.com/forums/index.php/topic/2891-black-screen-upon-new-game-dsafemode-does-not-fix/?p=40771 . The code for which I have copied below : 64-BIT JRE ".\jre64\bin\java.exe" -Djava.library.path=./ -cp lwjgl.jar;lwjgl_util.jar;./ zombie.gameStates.MainScreenState -safemode PAUSE 32-BIT JRE ".\jre\bin\java.exe" -Djava.library.path=./ -cp lwjgl.jar;lwjgl_util.jar;./ zombie.gameStates.MainScreenState -safemode PAUSE Just copy the above code (depending on what bit-width of JAVA you have) into the file : ProjectZomboid.bat Located at (NOTE : If you are using Windows XP, 32-BIT VISTA, etc, then this will be "Program Files" not "Program FIles (x86)", also if you installed STEAM to a non-default location then my file location will NOT match yours.) : C:\Program Files (x86)\Steam\steamapps\common\ProjectZomboidNOTE : (Depending on your OS and settings the .bat extension may or may not be shown by your FileExplorer/Command Line Window. There is only one file called "ProjectZomboid" in that directory, the only similar ones that could confuse you are ProjectZomboid32 and ProjectZomboid64 (these you can ignore). This will then hopefully allow you to play the game if you were having the same problem as I was in (2). CAVEAT : As this file has been greatly simplified it has no memory qualifiers included which could (and probably will) mean you will get fairly bad stuttering in game. This can be rectified by adding the appropriate -Xms and -Xmx qualifiers to the file. I have provided two examples of this below, the first uses the memory settings of the original .bat file, and the second uses a modified version for people with more then 4GB of memory. For more information regarding JAVA Command Line Arguments and Memory, see the following links : JAVA Command Line Arguments http://docs.oracle.com/javase/6/docs/technotes/tools/windows/java.html JAVA Memory http://www.vogella.com/articles/JavaPerformance/article.html FYR : -Xms sets the minimum amount of RAM that JAVA/PZ will use and -Xmx sets the maximum that it is allowed to use. Do not set your maximum too high or your system will not have any spare memory for anything else and you will get reduced performance as a result. The settings I use work well for the 6GB system I have and got rid of stuttering that was occurring due to memory issues. NOTE : The "m" on the end qualifies the units as being in MB. Original Memory Settings That Shipped with the game (3/4 - 1GB) : -Xms768m -Xmx1024m So for example the BATCH file would look like this for a 32-BIT version : ".\jre\bin\java.exe" -Xms768m -Xmx1024m -Djava.library.path=./ -cp lwjgl.jar;lwjgl_util.jar;./ zombie.gameStates.MainScreenState -safemode PAUSE The settings to use more memory, as I do in mine (1-3GB) : -Xms1024m -Xmx3072mSo for example the BATCH file would look like this for a 64-BIT version, with my ALTERED memory settings : ".\jre64\bin\java.exe" -Xms1024m -Xmx3072m -Djava.library.path=./ -cp lwjgl.jar;lwjgl_util.jar;./ zombie.gameStates.MainScreenState -safemodePAUSE You can set the memory settings to whatever you want, but setting too high probably wont gain you much, and going over say 2GB max for a 32-BIT system is probably not a good idea. If it does not work or causes issues you can always change it back. Anyway hope that helps, now if I could only work out how to set a post to ANSWERED on these forums <sigh> Thanks again Enigma Grey for your help.