Jump to content
nexitem

Ubuntu 14.04 - Server Public Release won't start

Recommended Posts

I'm not sure whats wrong, but I have been trying to fix this problem for 6 hours now, reinstalling and installing packages etc etc. I'm kinda tired so I will just ask on the forum now.
I also don't understand the errors it throws, its random bullshit and honestly I think the whole server package is a mess anyways but I guess you guys know more, here is the log from last startup.

 

Things I know:
No other PZ is running on the same port, so that cant be it

I reinstalled PZ from the normal release AND also IWBUMS and both have the same error.

The error at the end about the map is confusing, I dont even know if thats the cause I doubt it is, I think some library is missing, but It worked before I updated.

The user I am running the server with has all the permissions needed to access the folder and also /zomboid

 

Update/Install script looks like this:

./steamcmd.sh +login #### #### +force_install_dir /home/gameserver/PZ/ +app_update 380870 validate +exit

I did also try to use the normal game app ID, but same problems there, even worse cause shit's missing.

Any help is greatly appreciated!

pzlogs.txt

 

TEMPORARY SOLUTION: 

 

Edited by nexitem

Share this post


Link to post
Share on other sites
2 minutes ago, Jacksay said:

Hi,

If you will use the Dedicated Server, The APP ID is wrong...

 

makes no difference. In case you mean 108600 which is the ID from the Game.

Edited by nexitem

Share this post


Link to post
Share on other sites

I have read the logfile,

 

I think you have to upgrade the distrib. Ubuntu 14x is based on Debian Wheezy.

Exception with libstdc++.so.6 wil be solved in Disto based on Debian Stretch (9).

 

Work for me

Share this post


Link to post
Share on other sites
21 minutes ago, Jacksay said:

I have read the logfile,

 

I think you have to upgrade the distrib. Ubuntu 14x is based on Debian Wheezy.

Exception with libstdc++.so.6 wil be solved in Disto based on Debian Stretch (9).

 

Work for me

 

Can't do that, a lot of programs and games run on this server so I rather not upgrade. I'm sorry to say but this ain't gonna help and I doubt I'm the only one running Ubuntu 14.04 (which is still supported by everyone else).

Share this post


Link to post
Share on other sites

I haven't other solution... 

Keep in mind that Stretch Debian is the new stable version, and many disto like Ubuntu/Mint must be upgraded. It's specificly true for game servers. Debian Stretch will be here for a long time.

Sorry about that

Share this post


Link to post
Share on other sites

Fixed it by using the files from the older version.

Now I do have to say I have not tested this completely yet but so far it seems to work fine. I seriously doubt that they need to update that stuff to the latest of the latest every time, I think this is just something that is done automatically.

 

Anyways, if anyone happens to run into the same problem, here you go, put the files I uploaded into the /natives folder replacing the new ones, Should do the trick until the next update... what a mess.

 

 

oldifles.zip

Share this post


Link to post
Share on other sites

Yes, it's done automatically. In this case there was some.confusion on whether to use the system install, Steam's install, or static linking. Most of us don't have the greatest affinity with Linux, but try to support it when we can. ( For example it's pretty easy to update libgcc on Ubuntu and the current LTS ships with the right vers, but doing it on Debian Wheezy is a right pain.)

 

A better build system is being looked into that the team's expanded, as well.

Share this post


Link to post
Share on other sites
58 minutes ago, EG Bot said:

Yes, it's done automatically. In this case there was some.confusion on whether to use the system install, Steam's install, or static linking. Most of us don't have the greatest affinity with Linux, but try to support it when we can. ( For example it's pretty easy to update libgcc on Ubuntu and the current LTS ships with the right vers, but doing it on Debian Wheezy is a right pain.)

 

A better build system is being looked into that the team's expanded, as well.


I know, I understand it can also be a pain in the ass keeping all the versions of PZ in tact but honestly what we really need is ONE guide that works. Even most of the guides in this very forum that are sticky (!) are horrible outdated. and someone should look into that.

Share this post


Link to post
Share on other sites

Yes, but finding the time is the problem. At best  I can at least remove the guides (the one on Steam is the most up to date).

 

These guides also don't touch on this issue, itself a temporary one.

 

Edit: I'll look at restructuring the server sections (hiiding all the outdated  history), and updating the tutorials this weekend.

Share this post


Link to post
Share on other sites
16 minutes ago, EG Bot said:

Yes, but finding the time is the problem. At best  I can at least remove the guides (the one on Steam is the most up to date).

 

These guides also don't touch on this issue, itself a temporary one.

 

Edit: I'll look at restructuring the server sections (hiiding all the outdated  history), and updating the tutorials this weekend.

Thanks, I mean I could probably try to make a guide thats working but I'm not sure where to start when it comes to fixing the usual problems one has like for example the one I had here... Is it a good idea suggesting to use older library etc? I don't think so.

Share this post


Link to post
Share on other sites

It's probably fine right now. This is the updated lib required for the vehicle build. A bunch of stuff was ported over to make the transition easier once IWBUMS is released, but none of the vehicle stuff is actually present in the public vers. of build 38.


It needs to be fixed regardless. Most people aren't going to come to the forums and ask for a fix. :P

Share this post


Link to post
Share on other sites
44 minutes ago, EG Bot said:

It's probably fine right now. This is the updated lib required for the vehicle build. A bunch of stuff was ported over to make the transition easier once IWBUMS is released, but none of the vehicle stuff is actually present in the public vers. of build 38.


It needs to be fixed regardless. Most people aren't going to come to the forums and ask for a fix. :P

So when the vehicle update is coming, the new lib's will be required? Better prepare...

Share this post


Link to post
Share on other sites
15 minutes ago, nexitem said:

So when the vehicle update is coming, the new lib's will be required? Better prepare...

Nah.  Point is the lib needs to be compiled with the correct vers of libgcc, or pointed to a new version (such as Steam's). This is the wrong one.

Share this post


Link to post
Share on other sites
2 hours ago, EG Bot said:

Nah.  Point is the lib needs to be compiled with the correct vers of libgcc, or pointed to a new version (such as Steam's). This is the wrong one.

Yeah of course, hopefully that will be the case in the next update.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...