Jump to content

[41.78.12] Crash on start (steam)


TheHolySpork
 Share

Recommended Posts

• Version: 41.78.12
Crash on start. No mods. Can't even get to menu.

 

I got the game to run on the steam deck but not on my PC. It crashes as it is starting up. Have not been able to get to the loading screen at all. I tried a number of "fixes" found online including starting the game with - novoip and -Djinput.useDefaultPlugin=false —. Tried to run as admin as well. Graphics and audio drivers are up-to-date (as all other drivers). Log file attached.

 

THS

logs.zip

Edited by TheHolySpork
Link to comment
Share on other sites

On 11/24/2022 at 4:55 AM, Beard said:

Can you share the latest “hs_err_pid” file found in your main game folder “Steam\steamapps\common\ProjectZomboid” as well?

 

I could not find a file with that name in the main game folder (or sub folders) or in the folder found under "users". :(

Link to comment
Share on other sites

There is not too much info in the logs, so we would need to try and get more info or try a few things to see if they work.
First, try going to your Steam Library > Right click Project Zomboid > Properties > Set Launch Options > Type -novoip > Start the game
If that does not help, can you try typing -nosound instead? This is to check if it is a sound related issue.

If none of those help, do you perhaps have multiple monitors connected?

Link to comment
Share on other sites

Just an update: I was able to find the error with the Windows Event Viewer and tracked it down to an NVidia OnenGL Driver Error (errorcode 3, subcode 2). Apparently the game was trying to run using integrated graphics rather than my dedicated GPU (3080). I had left the the setting in auto-select mode and this is the first time I had this issue. I fixed it by forcing the system to always use my GPU.

 

Not quite sure why that would happen as all other applications default to the NVidia card.

 

THS

Link to comment
Share on other sites

1 minute ago, Beard said:

There is not too much info in the logs, so we would need to try and get more info or try a few things to see if they work.
First, try going to your Steam Library > Right click Project Zomboid > Properties > Set Launch Options > Type -novoip > Start the game
If that does not help, can you try typing -nosound instead? This is to check if it is a sound related issue.

If none of those help, do you perhaps have multiple monitors connected?

 

In case this helps in the future: I tried -novoip but that did not work. I have three monitors.

 

I tried setting the "preferred graphics processor" to auto select again, disabled all but one monitor, and it crashed again. So, in my case, it seems like it is related to the system defaulting to integrating graphics. I was able to replicate the error with 1, 2 and 3 monitors with the setting on auto (in the Nvidia control panel -> Manage 3D settings). When I forced the system to use the NVidia GPU it ran with 1, 2, and 3 monitors.

 

THS

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...