Jump to content
Val

"Choose Mods" in "Load" causes empty Screen

Recommended Posts

Hi,

 

i encountered this bug, when i wanted to add another mod to my already running game. When you click on the "choose mods" button when loading the game, you get an empty screen (only the background picure of the game still exists).

Now, this bug doesnt happen, if you clicked atleast once on the "Mods" button in the main menu before attempting to do this (once per game start is enough).

As i found out, the reason for this is, that the game tries to display a box with text, using a function that does not exist. In the file "ISModsNagPanel.lua" in the location Steam\steamapps\common\ProjectZomboid\media\lua\client\OptionScreens in line 32:
    self.richText:setText(getText("UI_ModsNagPanel_Text"))
The function "setText" doesnt exist. Replacing it with:
   self.richText.text=(getText("UI_ModsNagPanel_Text"))
fixes the problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...