Jump to content

Random Freezing/Crashing when hosting a dedicated server


Avonyx

Recommended Posts

serverlog.txt

 

Looking for a little help! I've been hosting a dedicated server for my wife and I. We play on the same router. At first, I had no issues except for a crash consistently every few hours. The problem has progressed to a point where I can't play in my own server for more than 20min before the game freezes/crashes. I've opened the ports steam requires and reset the server with no change. It seems related to the "znet" messages? We're playing vanilla with 0 mods. Any advice?

UPDATE: -nosteam let me play for about half an hour uninterrupted, I can test for longer later.

 

UPDATE 2: Uninstalled and reinstalled SteamCMD by suggestion of another similar post. Game still crashes after just a few minutes of playing on the dedicated server. Similar log to the one attached.

 

AMD 6750

I7-3770

500gb SSD

 

Edited by Avonyx
Update
Link to comment
Share on other sites

Can you share your logs.zip file found in C:\Users\YourUserName\Zomboid?

Additionally, is it only the client that crashes or does the whole server crash?

Link to comment
Share on other sites

Posted (edited)

logs.zipAttached the logs!!

 

What usually happens is the game itself will freeze. After a few seconds, my wife will be kicked from the server. Zomboid eventually closes after the freeze (15-30sec) and either freezes so bad I can't even open task manager, forcing me to restart the PC or tries to restart on it's own, usually also forcing me to restart the system.

 

I had the same issue running in -nosteam as well :(

Edited by Avonyx
Link to comment
Share on other sites

Just to understand, you host a dedicated server, and while playing your whole PC basically freezes, which forces you to restart? That might be a big problem, can I ask how much RAM you assigned to the dedicated server? Since you might be running out of it.

Link to comment
Share on other sites

In that case, can you check the Windows Reliability monitor for any ProjectZomboid application crashes there? If you do find any, can you share a screenshot of the Technical Details section so we can check the errors that show up there?

https://www.computerworld.com/article/3575353/troubleshooting-windows-10-with-reliability-monitor.html

https://www.dell.com/support/kbdoc/sk-sk/000178177/how-to-use-windows-reliability-monitor-to-identify-software-issues

Link to comment
Share on other sites

Unfortunately, it is just a generic "AppHang" error, which is the equivalent of saying "Game stopped working" without any specific reason.
Since the game logs do not point to anything specific either, more testing would be required.

How long does it take for the game to crash? And does it only crash when hosting the server, or does it crash if you play on a a random public server as well?

Link to comment
Share on other sites

Hey Beard, good news! I upgraded my GPU to a 1070 and I've been hosting and playing uninterrupted for hours. I also believe my previous graphics card may have been a fake based on some images that matched mine on Alexiexpress, but that's between me and the guy who sold me the rig.

 

Anywho, the problem was still happening when my wife and I would try to host on a 3rd computer. Very interesting. I didn't have these sorts of issues with other games on the old GPU.

 

Thanks so much for your help and time! It's awesome to see support for a game I've enjoyed for YEARS be so active and helpful!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...