Jump to content

Aiming not working during battle


Recommended Posts

Version 41.78.16 Steam


No mods



Sometimes in the middle of a gunfight, the aim just stops working.

After killing dozens, sometimes hundreds of zombies, the aim mark suddenly stop turning green.

The weather is great, no fog or rain, middle of the day with perfect visibility.

My character is not tired, the gun is in pristine condition and even if I change to a melee weapon, the aim does not come back.
Even though I am in range, I've tried shooting without the green and also tried swinging melee weapons in this condition (no green and in range), and cannot hit the zombies.

I've tried moving to a different location, miles away, and engaging other zombies. No good.

I've tried going back to the base, doing other stuff and sleeping, coming back the next day all rested. No good.

I've tried closing the game to desktop and reopening. No good.

The only way to be able to fight again is to quit the game and restart the computer.


This happened to me 5 times already in this playthrough. (I've killed more than 6,000 Zeds in this 300+ hours playthrough)

By the way, my playthrough is completely vanilla, no mods whatsoever

Edited by Helio
Link to comment
Share on other sites

I am not sure if we can help much if it is totally random, as it might be extremely difficult to pinpoint the issue, since it may be caused by any sort of Windows settings or other applications causing issues with the input to the game. Only a lot of testing would be able to find out the exact issue once we can figure out if its reproducible.

Link to comment
Share on other sites

I have been thinking, maybe it helps if I pause the game, copy the save file and upload it here or in another place that can get large files next time it happens.

Let me know if this would help.

I do not run any other application while playing and am using Windows 10, if this information is somewhat useful.

Thanks for the quick reply and support.

Edited by Helio
Link to comment
Share on other sites

Reloading the save will not help for me without restarting the computer.
I imagine that if I send you the file, you will not be able to reproduce it directly since you will be in a "restarted" computer anyway.

But maybe you could spot some inconsistency in the save.

I know Zomboid also has some log files, not sure if this would help either. If does, please let me know what/where the files are located so I can also send them.


Another thing that I can try and do is to pause the game, prepare it to stream, and capture some actions when this happens again so you guys would be able to see what happens.

Please let me know what other options/tasks I should do to give you enough information to work with.


For now, it has not happened in a few days even though I have been playing hard this weekend/week.

Link to comment
Share on other sites

23 hours ago, Beard said:

There might be a clue there, does the issue persist even if you load a new save without restarting your PC?

Yes, I've tried to just quit to desktop and get back to the game using the "Continue" option and the issue persisted.

The only way to get rid of it (as far as I was able to test), was by restarting the computer.

Link to comment
Share on other sites

16 hours ago, Beard said:

Additionally, could you check your Mouse Options in your Windows as well? Do you have any settings there enabled that differ from the default? Such as Click Lock?

No, my mouse is configured exactly as in your picture.
I am using windows 10 and never changed any mouse configuration.

Link to comment
Share on other sites

I can only point to some sort of other application or Windows setting causing an issue with the mouse, since it persists even after reloading the game. Meaning I can only suggest making sure to turn off all applications in your Icon Tray if you have any and see if that helps.

Link to comment
Share on other sites

There are no other applications running, and I did not change any windows settings.

I also do not have any explanation, I can only point to what I see happening.

Fortunately it didn't happen again in the last few days, if it do, I'll try and make a video of it.

Link to comment
Share on other sites

  • 2 months later...

Just to add some more info.

I discovered that this situation happens after  I do some running.

Usually when running in a direction that needs me to press 2 keys plus the running key.

I changed the key bindings to use the keyboard arrow keys to move, and the right <Alt> as the running key.

Some combination of those keys makes the aiming not function.
If I press <Esc> and then <Alt><Tab> out of the game give a few seconds and go back, the aiming usually resumes functionality.


Hope this helps finding the bug.

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...