Jump to content

Zoom not working on steam deck


Recommended Posts

    • Version - 41.78.16 (Steam)
    • Singleplayer
    • Mods - none
    • Problem with new game or existing save
    • Reproduction steps: ?


Running the above on the Steam Deck, zoom does not work in any capacity.  I've tried enabling auto-zoom for all players, but the zoom level will not change.  I've tried starting a new game and the problem remains.  Much tinkering with the display settings, enabling/disabling zoom, trying different zoom levels, but I cannot get the zoom to change from the default.  I've rebound the zoom buttons to different keys just in case there was some sort of a conflict there, but still.


I installed PZ on my desktop PC and Zoom predictably works fine.  I did notice that during the tutorial that changing the zoom level is one of the first things PZ introduces you to in the desktop version, but the Steam Deck doesn't mention anything about zooming, so I suspect there is something in the Steam Deck version of the software that is influencing zoom.  Any help offered appreciated, otherwise I'll wait for the next release until it's possibly fixed.

Link to comment
Share on other sites

  • 1 month later...

I just want to add my two cents. I was playing the Linux (non-Proton) version on the Steam Deck. I ran into a situation where the game keeps crashing right after loading back up. I suspected the issue might be an issue with a mod (no complaints about the game/mod compatibility, I include this just to provide some background).

I changed to Proton (Compatibility mode) and launched the game to see if the problem with the fame crashing persisted. I noticed that the zoom had stopped working as described by OP.

While digging into this I found that Zomboid recognises controller as X-Input in Compatibility mode. In Linux mode the controller is recognised as a Steam Virtual GamePad.

This is probably known by the team, and not sure if it is a fix that needs to be done by Indie Stone or Valve/in Proton. My last question is. Is there a way to change the config files to force the controller to use Steam virtual Gamepad in Proton? I tried to copy the Joypad file from the Linux file directory to the Proton game directories and change the config to point to the correct Joypad file in the ProtonDB version, but no joy. Any tips?

Link to comment
Share on other sites

It would be Safemode that does that. And "Compatibility Mode" is just the term that Steam uses for Proton, while the game itself has its own term for the Safemode. If you play natively you can see that you can launch the game in "Compatibility Mode" once you click Play in Steam, which would be the safemode.

I have also just done a test to launch the game with Proton and zoom works just fine there. Can you make sure that you do not have Zoom disabled in your game options? Or that you are not using any extra Launch Parameters in the Properties in Steam?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...