Jump to content

[41.73][Network] "map download from server timed out" Extremely abnormal.

Recommended Posts

Heavily modded server, 

loading 73626 zones from map_zone.bin

More than a thousand people have already joined the server at least once.

Some players played normally, suddenly they can't join anymore.
their client log, nothing anomalous, just:
(It is more frequent to see 0/529)

LOG  : General     , 1663283296812> 0> Received 89 / 529 chunks
LOG  : General     , 1663283297814> 0> Received 89 / 529 chunks
LOG  : General     , 1663283298817> 0> Received 89 / 529 chunks
ERROR: General     , 1663283298919> 0> ExceptionLogger.logException> Exception thrown java.io.IOException: map download from server timed out at WorldStreamer.requestLargeAreaZip line:850.
ERROR: General     , 1663283298919> 0> DebugLogStream.printException> Stack trace:
java.io.IOException: map download from server timed out
	at zombie.iso.WorldStreamer.requestLargeAreaZip(WorldStreamer.java:850)
	at zombie.iso.CellLoader.LoadCellBinaryChunk(CellLoader.java:440)
	at zombie.iso.IsoWorld.init(IsoWorld.java:2605)
	at zombie.gameStates.GameLoadingState$1.runInner(GameLoadingState.java:261)
	at zombie.gameStates.GameLoadingState$1.run(GameLoadingState.java:218)
	at java.base/java.lang.Thread.run(Unknown Source)
LOG  : General     , 1663283298919> 0> LuaEventManager: adding unknown event "OnPreUIDraw"
LOG  : General     , 1663283298919> 0> LuaEventManager: adding unknown event "OnPostUIDraw"
LOG  : General     , 1663283311401> 0> 1663283311401> znet: ZNetFriends::OnPersonaStateChange
LOG  : General     , 1663283311402> 0> 1663283311402> znet: ZNetFriends::OnPersonaStateChange
LOG  : General     , 1663283325698> 0> 1663283325698> znet: ZNetFriends::OnPersonaStateChange

Here comes the weird part.

I created a copy of the Zomboid folder, renamed it to Zomboid2, changed the default port to 17261, the RCON to 27016 and I started the server with the argument "-cachedir=C:\Users\Administrator\Zomboid2"

Two identical servers, running at the same time, same mods, same map, same metadata. A perfect copy, one hosted on port 16261 and one on 17261.
Players with the problem are able to connect perfectly to the "copy server" (17261), but cannot connect to the original server due to "map download from server timed out".

The only real difference is that the "copy server" is empty. While the original always has 3-30 players.
Why only a specific group of players can't download the map on the original server, but can join the "copy server"?

It's not firewall,
It's not network connection quality,
It's not connection speed,
It's not server performance (Server is not dropping connections or "Server is too busy".)
It's just me and my server, for 15 days trying to figure out why some players can't connect.

Share this post

Link to post
Share on other sites

Things I've already tried.

1. Completely remove the player, deleting all his entries from both databases
2. Reduce resolution to 1280x720 (load less map)
3. Log into player account via admin/debug
4. Completely reset my network, including router and firewall.
5. Players tried using "Alternate Launch"
6. Player uninstalled Project Zomboid, Steam and renamed Zomboid folder to Zomboid2 (as a way to backup and generate new default files)
7. Increase the RAM values assigned to the JVM
8. Change server ports to 17261
EDIT: 9. While on the players account, I dropped all the loot on the ground and teleported them to the water, where the map files are smaller.
EDIT: 10. Players tried with two different VPN's and public proxy's

Edited by P_menta
9 and 10

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...