Jump to content

Cannot see generator or fireplace info in the overview


Recommended Posts

When I click on a generator info or a fireplace info, it used to put a window at the top of my screen showing the info...but now it doesn't do that, it just shows a small vertical bar.


You can see the bar in the attached pic to the right of cupboard inventory...it used to show how much fuel was remaining and condition of the generator or fuel remaining and time for the fireplace.


I only use a couple of mods, but I disabled them and tried it with a new save and the same thing happened.


Link to comment
Share on other sites

1 hour ago, Yana M.D. said:

Have you tried deleting the mods and  verifying local files after that?
If you are referring to this info UI then here it is:


Yeah, that's it...it's missing in my game now after the latest update, it just flashes and then leaves a small vertical bar.


I'm using steam.  I disabled the mods (I only use irrigation pipes and flibuster cars). 


I'm pretty new to this, would I delete them by unsubscribing to them in Steam?  How do I check local files?







Link to comment
Share on other sites

1. Steam>Workshop>Your files>Subscribed items>Unsubscribe from all.
2. Make sure there is no mod leftover files in  C:\Program Files (x86)\Steam\steamapps\workshop\content\108600
3. Then go to Steam Library> Project zomboid> Properties> Local files> Verify integrity of game files.
4. Restart Steam.

Create a new save and see if the issue persists 

Link to comment
Share on other sites

Okay, I tried all of 4 of those items and it's still doing it.  And I tried a new save it was doing it there too.


I did notice something though, in the past when I did it I would see the image you posted and I would move it up towards the top of  my screen so I could monitor it while in my base.  But now when I click on them, they flash at the top of the screen and just leaves that vertical bar(s).  


Could it have something to do with pinning me pinning the UI up there somehow?  Is that a setting in options or something maybe?  



Link to comment
Share on other sites

Something else I noticed, if I minimize and change the size of the window that it's playing in....those verticval bars for the UI are still there and move around depending on how shrink or expand the window.


I tried using all the UI hotkeys to turn things on/off but that did nothing either.  They seem to be pinned up there but the whole UI is not appearing, just those two vertival bars which is probably the far left border/outline of their respective UIs.


Edited by gordyzx9r
Link to comment
Share on other sites

So, I unistalled and reinstalled the game...same thing.


Finally fixed it by deleteing the layout file in the Lua folder.  I had read that as a fix for someone else's issue they were having.


EDIT:  So...sorta fixed it, after I quit the game and go back it does it again unless I delete the layout file in the lua folder first.

Edited by gordyzx9r
Link to comment
Share on other sites

  • 6 months later...
  • 3 months later...

Never is too late I guess.


I find out this is cause when  you close the game with the generator info tab minimized with the little pin button in the top corner.



What works for me is delete/rename the layout.ini inside X:\Users\USERNAME\Zomboid


I found this in https://steamcommunity.com/app/108600/discussions/0/522730075766434429/


Is one year later for the original poster but I hope this helps somebody else.

Link to comment
Share on other sites

  • 9 months later...

So I just wanted to say that as of today (March of 2024) this is still an issue. If you log out of game with the generator info UI Pinned, upon next and all subsequent logins, it will be present only as the two small bars which are unable to be moved, closed, unpinned, etc. and the only fix still appears to be deleting the layout.ini file, removing all other modifications you've made to your UI layout. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...