Buying & Running a Linux Project Zomboid Server
9 9

311 posts in this topic

Recommended Posts

It's glibc :)

This'll confirm what version you've got:

dpkg -l | grep libc6
Also, make sure you've run my script!

I get this:

ii libc6:i386 2.13-38+deb7u1 i386 Embedded GNU C Library: Shared libraries

And I did run your script from root, just like instructed in Connall's guide.

Share this post


Link to post
Share on other sites

 

It's glibc :)

This'll confirm what version you've got:

dpkg -l | grep libc6
Also, make sure you've run my script!

 

I get this:

ii libc6:i386 2.13-38+deb7u1 i386 Embedded GNU C Library: Shared libraries

And I did run your script from root, just like instructed in Connall's guide.

 

 

You're definitely running the wrong version! Can you try running the script again, and posting the output?

Share this post


Link to post
Share on other sites

You're definitely running the wrong version! Can you try running the script again, and posting the output?

Running debian wheezy, continuing

Adding unstable repository

Hit http://ftp.debian.org sid Release.gpg

Hit http://ftp.debian.org sid Release

Hit http://ftp.de.debian.org wheezy Release.gpg

Get:1 http://ftp.debian.org sid/main i386 Packages/DiffIndex [7876 B]

Hit http://ftp.de.debian.org wheezy-updates Release.gpg

Get:2 http://ftp.de.debian.org wheezy/updates Release.gpg [836 B]

Get:3 http://ftp.debian.org sid/main Translation-en/DiffIndex [7876 B]

Hit http://ftp.de.debian.org wheezy Release

Hit http://ftp.de.debian.org wheezy-updates Release

Get:4 http://ftp.de.debian.org wheezy/updates Release [102 kB]

Hit http://ftp.de.debian.org wheezy/main Sources

Hit http://ftp.de.debian.org wheezy/contrib Sources

Hit http://ftp.de.debian.org wheezy/non-free Sources

Hit http://ftp.de.debian.org wheezy/main i386 Packages

Hit http://ftp.de.debian.org wheezy/contrib i386 Packages

Hit http://ftp.de.debian.org wheezy/non-free i386 Packages

Hit http://ftp.de.debian.org wheezy/contrib Translation-en

Hit http://ftp.de.debian.org wheezy/main Translation-en

Hit http://ftp.de.debian.org wheezy/non-free Translation-en

Hit http://ftp.de.debian.org wheezy-updates/main i386 Packages/DiffIndex

Hit http://ftp.de.debian.org wheezy-updates/contrib i386 Packages

Hit http://ftp.de.debian.org wheezy-updates/non-free i386 Packages

Hit http://ftp.de.debian.org wheezy-updates/contrib Translation-en

Hit http://ftp.de.debian.org wheezy-updates/main Translation-en/DiffIndex

Hit http://ftp.de.debian.org wheezy-updates/non-free Translation-en

Get:5 http://ftp.de.debian.org wheezy/updates/main i386 Packages [163 kB]

Get:6 http://ftp.de.debian.org wheezy/updates/contrib i386 Packages [14 B]

Get:7 http://ftp.de.debian.org wheezy/updates/non-free i386 Packages [14 B]

Get:8 http://ftp.de.debian.org wheezy/updates/contrib Translation-en [14 B]

Get:9 http://ftp.de.debian.org wheezy/updates/main Translation-en [90.2 kB]

Get:10 http://ftp.de.debian.org wheezy/updates/non-free Translation-en [14 B]

Fetched 373 kB in 3s (121 kB/s)

Reading package lists... Done

Installing packages

Reading package lists... Done

Building dependency tree

Reading state information... Done

You might want to run 'apt-get -f install' to correct these:

The following packages have unmet dependencies:

libc6-dev : Depends: libc-dev-bin (= 2.17-97) but it is not going to be installed

Depends: linux-libc-dev but it is not going to be installed

Recommends: gcc but it is not going to be installed or

c-compiler

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Disabling unstable repository

E: Malformed line 7 in source list /etc/apt/sources.list (type)

E: The list of sources could not be read.

glibc upgraded

Share this post


Link to post
Share on other sites

Script output:

Running debian wheezy, continuing

Adding unstable repository

Hit http://ftp.debian.org sid Release.gpg

Hit http://ftp.debian.org sid Release

Hit http://ftp.de.debian.org wheezy Release.gpg

Hit http://ftp.debian.org sid/main i386 Packages/DiffIndex

Hit http://ftp.de.debian.org wheezy-updates Release.gpg

Hit http://ftp.de.debian.org wheezy/updates Release.gpg

Hit http://ftp.debian.org sid/main Translation-en/DiffIndex

Hit http://ftp.de.debian.org wheezy Release

Hit http://ftp.de.debian.org wheezy-updates Release

Hit http://ftp.de.debian.org wheezy/updates Release

Hit http://ftp.de.debian.org wheezy/main Sources

Hit http://ftp.de.debian.org wheezy/contrib Sources

Hit http://ftp.de.debian.org wheezy/non-free Sources

Hit http://ftp.de.debian.org wheezy/main i386 Packages

Hit http://ftp.de.debian.org wheezy/contrib i386 Packages

Hit http://ftp.de.debian.org wheezy/non-free i386 Packages

Hit http://ftp.de.debian.org wheezy/contrib Translation-en

Hit http://ftp.de.debian.org wheezy/main Translation-en

Hit http://ftp.de.debian.org wheezy/non-free Translation-en

Hit http://ftp.de.debian.org wheezy-updates/main i386 Packages/DiffIndex

Hit http://ftp.de.debian.org wheezy-updates/contrib i386 Packages

Hit http://ftp.de.debian.org wheezy-updates/non-free i386 Packages

Hit http://ftp.de.debian.org wheezy-updates/contrib Translation-en

Hit http://ftp.de.debian.org wheezy-updates/main Translation-en/DiffIndex

Hit http://ftp.de.debian.org wheezy-updates/non-free Translation-en

Hit http://ftp.de.debian.org wheezy/updates/main i386 Packages

Hit http://ftp.de.debian.org wheezy/updates/contrib i386 Packages

Hit http://ftp.de.debian.org wheezy/updates/non-free i386 Packages

Hit http://ftp.de.debian.org wheezy/updates/contrib Translation-en

Hit http://ftp.de.debian.org wheezy/updates/main Translation-en

Hit http://ftp.de.debian.org wheezy/updates/non-free Translation-en

Reading package lists... Done

Installing packages

Reading package lists... Done

Building dependency tree

Reading state information... Done

You might want to run 'apt-get -f install' to correct these:

The following packages have unmet dependencies:

gcc : Depends: cpp (>= 4:4.8.2-2) but 4:4.7.2-1 is to be installed

Depends: gcc-4.8 (>= 4.8.2-5~) but it is not going to be installed

libc6-dev : Depends: libc-dev-bin (= 2.17-97) but it is not going to be installed

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Disabling unstable repository

E: Malformed line 6 in source list /etc/apt/sources.list (type)

E: The list of sources could not be read.

Share this post


Link to post
Share on other sites

Right, this is odd. Can you run

cat /etc/apt/sources.list

 for me, and post the output? I'm going to have to walk you through a few operations. Do you know a command line text editor (nano, vi, emacs)? If not, it's not a problem, I'll just have to give you some commands to run.

Share this post


Link to post
Share on other sites
deb http://ftp.de.debian.org/debian wheezy main contrib non-freedeb-src http://ftp.de.debian.org/debian wheezy main contrib non-freedeb http://ftp.de.debian.org/debian wheezy-updates main contrib non-freedeb http://ftp.de.debian.org/debian-security wheezy/updates main contrib non-free
Yeah I've used vi a little to modify sources.list

 

 

The script is complaining about a line in the sources.list that doesn't exist anymore .. I guess you edited it out? ;)

 

But, ok, add this line to sources.list:

deb http://ftp.debian.org/debian sid main

Then run:

apt-get -t -f sid install libc6 libc6-dev libc6-dbg linux-libc-dev gcc

And then remove the line we just added to your sources.list

 

Any errors, let me know

Share this post


Link to post
Share on other sites

I'm kind of feeling like either Indie Stones or steam is trolling me :P

 

I've been running

./steamcmd.sh +login steamusername steampassword +force_install_dir directory/you/want/to/install/to* +app_update 108600 -beta onlinetest validate +exit

for about 40 minutes now without getting the dediserver.sh

 

Is there anything at all that can be done to get a hold of this file? Could Indie Stones give permissions for this file alone to be hosted else where?

Share this post


Link to post
Share on other sites

But, ok, add this line to sources.list:

deb http://ftp.debian.org/debian sid main
Then run:

apt-get -t -f sid install libc6 libc6-dev libc6-dbg linux-libc-dev gcc
And then remove the line we just added to your sources.list

 

Any errors, let me know

I'm gettin an error: "Option -t requires an argument." when trying to run that script.

Share this post


Link to post
Share on other sites

 

But, ok, add this line to sources.list:

deb http://ftp.debian.org/debian sid main
Then run:

apt-get -t -f sid install libc6 libc6-dev libc6-dbg linux-libc-dev gcc
And then remove the line we just added to your sources.list

 

Any errors, let me know

 

I'm gettin an error: "Option -t requires an argument." when trying to run that script.

 

Argh, sorry, my fault.

Here:

apt-get -t sid -f install libc6 libc6-dev libc6-dbg linux-libc-dev gcc

I'm kind of feeling like either Indie Stones or steam is trolling me :P

 

I've been running

./steamcmd.sh +login steamusername steampassword +force_install_dir directory/you/want/to/install/to* +app_update 108600 -beta onlinetest validate +exit

for about 40 minutes now without getting the dediserver.sh

 

Is there anything at all that can be done to get a hold of this file? Could Indie Stones give permissions for this file alone to be hosted else where?

 

Run steamcmd.sh, then each command preceeded by plus, so -

login steamusername steampassword

then

force_install_dir directory/you/want/to/install/to*

etc

Share this post


Link to post
Share on other sites

Now getting this:

Reading package lists... Done

Building dependency tree

Reading state information... Done

You might want to run 'apt-get -f install' to correct these:

The following packages have unmet dependencies:

gcc : Depends: cpp (>= 4:4.8.2-2) but 4:4.7.2-1 is to be installed

Depends: gcc-4.8 (>= 4.8.2-5~) but it is not going to be installed

libc6-dev : Depends: libc-dev-bin (= 2.17-97) but it is not going to be installed

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Share this post


Link to post
Share on other sites

And now getting this:

Reading package lists... Done

Building dependency tree

Reading state information... Done

Correcting dependencies... Done

The following extra packages will be installed:

libc6

Suggested packages:

glibc-doc

Recommended packages:

libc6-i686

The following packages will be upgraded:

libc6

1 upgraded, 0 newly installed, 0 to remove and 353 not upgraded.

1 not fully installed or removed.

Need to get 0 B/2277 kB of archives.

After this operation, 352 kB of additional disk space will be used.

Do you want to continue [Y/n]? y

Preconfiguring packages ...

dpkg: warning: files list file for package 'libc6:i386' missing; assuming package has no files currently installed

dpkg: warning: files list file for package 'liblzma5:i386' missing; assuming package has no files currently installed

dpkg: warning: files list file for package 'libavahi-common-data:i386' missing; assuming package has no files currently installed

(Reading database ... 28877 files and directories currently installed.)

Preparing to replace libc6:i386 2.13-38+deb7u1 (using .../libc6_2.17-97_i386.deb) ...

Checking for services that may need to be restarted...

Checking init scripts...

A copy of the C library was found in an unexpected directory:

'/lib/i386-linux-gnu/libc-2.13.so'

It is not safe to upgrade the C library in this situation;

please remove that copy of the C library or get it out of

'/lib/i386-linux-gnu' and try again.

dpkg: error processing /var/cache/apt/archives/libc6_2.17-97_i386.deb (--unpack):

subprocess new pre-installation script returned error exit status 1

Errors were encountered while processing:

/var/cache/apt/archives/libc6_2.17-97_i386.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)

Share this post


Link to post
Share on other sites

And now getting this:

Reading package lists... Done

Building dependency tree

Reading state information... Done

Correcting dependencies... Done

The following extra packages will be installed:

libc6

Suggested packages:

glibc-doc

Recommended packages:

libc6-i686

The following packages will be upgraded:

libc6

1 upgraded, 0 newly installed, 0 to remove and 353 not upgraded.

1 not fully installed or removed.

Need to get 0 B/2277 kB of archives.

After this operation, 352 kB of additional disk space will be used.

Do you want to continue [Y/n]? y

Preconfiguring packages ...

dpkg: warning: files list file for package 'libc6:i386' missing; assuming package has no files currently installed

dpkg: warning: files list file for package 'liblzma5:i386' missing; assuming package has no files currently installed

dpkg: warning: files list file for package 'libavahi-common-data:i386' missing; assuming package has no files currently installed

(Reading database ... 28877 files and directories currently installed.)

Preparing to replace libc6:i386 2.13-38+deb7u1 (using .../libc6_2.17-97_i386.deb) ...

Checking for services that may need to be restarted...

Checking init scripts...

A copy of the C library was found in an unexpected directory:

'/lib/i386-linux-gnu/libc-2.13.so'

It is not safe to upgrade the C library in this situation;

please remove that copy of the C library or get it out of

'/lib/i386-linux-gnu' and try again.

dpkg: error processing /var/cache/apt/archives/libc6_2.17-97_i386.deb (--unpack):

subprocess new pre-installation script returned error exit status 1

Errors were encountered while processing:

/var/cache/apt/archives/libc6_2.17-97_i386.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)

 

Your system is non-standard, I'm sorry, I cannot support your further without direct system access, and I'm not really up for that right now. I recommend checking for solutions on stackoverflow/google etc. Take backups, lots of backups. Good luck!

Share this post


Link to post
Share on other sites

Your system is non-standard, I'm sorry, I cannot support your further without direct system access, and I'm not really up for that right now. I recommend checking for solutions on stackoverflow/google etc. Take backups, lots of backups. Good luck!

Hmm, well is it possible if I just switch to Ubuntu?

Share this post


Link to post
Share on other sites

 

Your system is non-standard, I'm sorry, I cannot support your further without direct system access, and I'm not really up for that right now. I recommend checking for solutions on stackoverflow/google etc. Take backups, lots of backups. Good luck!

Hmm, well is it possible if I just switch to Ubuntu?

 

Yes, you won't need to worry about glibc then either.

Share this post


Link to post
Share on other sites

Your system is non-standard, I'm sorry, I cannot support your further without direct system access, and I'm not really up for that right now. I recommend checking for solutions on stackoverflow/google etc. Take backups, lots of backups. Good luck!

Hmm, well is it possible if I just switch to Ubuntu?

Yes, you won't need to worry about glibc then either.
Alright, and I should be able to install java? My hosting company is offering me Ubuntu 12.04 x86.

But thanks for helping, much appreciated!

Share this post


Link to post
Share on other sites

 

 

 

Your system is non-standard, I'm sorry, I cannot support your further without direct system access, and I'm not really up for that right now. I recommend checking for solutions on stackoverflow/google etc. Take backups, lots of backups. Good luck!

Hmm, well is it possible if I just switch to Ubuntu?

 

Yes, you won't need to worry about glibc then either.

 

Alright, and I should be able to install java? My hosting company is offering me Ubuntu 12.04 x86.

But thanks for helping, much appreciated!

 

 

yes. If you can, use 64bit version, not x86

Share this post


Link to post
Share on other sites

Hey umm. So i've been running the app_update 108600 -beta onlinetest validate for about an hour now.

Is there anything i can do to get the projectzomboidserver.sh file?

Cause this could possibly take days.

Share this post


Link to post
Share on other sites

Hey umm. So i've been running the app_update 108600 -beta onlinetest validate for about an hour now.

Is there anything i can do to get the projectzomboidserver.sh file?

Cause this could possibly take days.

 

Run steamcmd.sh, then each command preceeded by plus, so -

login steamusername steampassword
then

force_install_dir directory/you/want/to/install/to*
etc

 

Share this post


Link to post
Share on other sites

yep, been doing that for a full day now. no change. 

 

Running each command, one by one? You've got the -beta flag, right? It's really important. If so, copy and paste one of your attempts here.

Share this post


Link to post
Share on other sites
Here you go.

app_update 108600 -beta onlinetest validate
 Initial App state (0x4) installed
 App state (0x20104) validating, progress: 0.00 (1706 / 1380326654)
 App state (0x20104) validating, progress: 4.71 (64981061 / 1380326654)
 App state (0x20104) validating, progress: 12.71 (175427284 / 1380326654)
 App state (0x20104) validating, progress: 20.09 (277375543 / 1380326654)
 App state (0x20104) validating, progress: 23.45 (323630132 / 1380326654)
 App state (0x20104) validating, progress: 25.96 (358335162 / 1380326654)
 App state (0x20104) validating, progress: 33.61 (463967334 / 1380326654)
 App state (0x20104) validating, progress: 37.81 (521961022 / 1380326654)
 App state (0x20104) validating, progress: 42.58 (587694234 / 1380326654)
 App state (0x20104) validating, progress: 48.58 (670630226 / 1380326654)
 App state (0x20104) validating, progress: 55.97 (772500386 / 1380326654)
 App state (0x20104) validating, progress: 64.41 (889062522 / 1380326654)
 App state (0x20104) validating, progress: 71.48 (986670641 / 1380326654)
 App state (0x20104) validating, progress: 77.50 (1069795386 / 1380326654)
 App state (0x20104) validating, progress: 91.63 (1264756286 / 1380326654)
 App state (0x20104) validating, progress: 97.67 (1348170161 / 1380326654)
 App state (0x20104) validating, progress: 99.93 (1379424910 / 1380326654)
Success! App '108600' already up to date.
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
9 9