How to run a Server
2 2

74 posts in this topic

Recommended Posts

When attempting to open the db file after launching the server first then shutting it down to add myself as a admin without having to login as a admin username, I get this error in SQLite Administrator

 

"qAdmin cannot perform this operation on a closed dataset" I have tried completely deleting the db file, reloading the server, reinstalling the whole game and nothing seems to work.

 

The servertest folder in the Zomboid directory is also empty despite a server being run and saved.

Share this post


Link to post
Share on other sites

 

Hi, ty for you'r game it is exellent !
 
But now i have a little problem, i have donwload the new build with IWBMS but it is impossible for me to connect on my own servers.
I have  ID_DISCONNECTION_NOTIFICATION in the console and Connection Failed in the game. I have already set my whitelist.
 
Any idea ?
 
Ty for the reply !

 

 

My friend has the same problem. He can host with "online test" branch, but he can't with version 25. Any idea about what's going on?

Share this post


Link to post
Share on other sites

to upgrade to a higher version of PZ i need to reinstall or is there a way to force update the server with a command? 

 

You running on Windows or Linux?

Share this post


Link to post
Share on other sites

Okey, so i went to C:\Users\<Username>\Zomboid and there was no folder called "server". I have a steam version of the game, beta online tests set on, and there is no such folder. What the hell i have to do now?

 

Edit: And before you ask. Yes i started server.bat first. Still nothing. Then I verify game catche. Still nothing. So what the hell?

 

Share this post


Link to post
Share on other sites

 

Okey, so i went to C:\Users\<Username>\Zomboid and there was no folder called "server". I have a steam version of the game, beta online tests set on, and there is no such folder. What the hell i have to do now?
 
Edit: And before you ask. Yes i started server.bat first. Still nothing. Then I verify game catche. Still nothing. So what the hell?
 

 

 

When you launch the game, is there any error in console ? (or just copy/paste me the console thingy in spoiler tags)

Share this post


Link to post
Share on other sites

 

Okey, so i went to C:\Users\<Username>\Zomboid and there was no folder called "server". I have a steam version of the game, beta online tests set on, and there is no such folder. What the hell i have to do now?
 
Edit: And before you ask. Yes i started server.bat first. Still nothing. Then I verify game catche. Still nothing. So what the hell?
 

 

 

Are you on "onlinetest" or "iwillbackupmysave" beta branch, since it needs to be the latter, not the former.

Share this post


Link to post
Share on other sites

Hi having trouble working out how to add extra ram to server for larger player support can some one please give me instructions i,m on windows 7 running steam version build 26

 

http://theindiestone.com/forums/index.php/topic/6016-multiplayer-faq/#RAM

 

A: You’ll need to edit the projectzomboid-dedi-server.sh file or the ProjectZomboidServer.bat file and find lines that look like:

 

-Xms1024m \ -Xmx1024m \

 

These are your RAM values. It is advised that you don’t use more than 80% of your available RAM. If you’re running the server from a home computer, then the RAM values should be tonned down significantly more.

 

Hope that helps. :)

Share this post


Link to post
Share on other sites
SpawnItems=Base.Ramen,Base.Ramen,Base.KitchenKnife,Base.Bandaid,Base.WaterBottleFull,Base.Duffelbag

thats my servers starting loadout

 

 

and her is two more example

SpawnItems=Base.Ramen,Base.Ramen,Base.Axe,Base.FishingRodSpawnItems=Base.KitchenKnife,Base.Bandaid,Base.WaterBottleFull,Base.Duffelbag

hope that helps

 

also i released my Server Admin Tools

http://theindiestone.com/forums/index.php/topic/8149-server-admin-tools/#entry106981

Share this post


Link to post
Share on other sites
SpawnItems=Base.Ramen,Base.Ramen,Base.KitchenKnife,Base.Bandaid,Base.WaterBottleFull,Base.Duffelbag

thats my servers starting loadout

 

 

and her is two more example

SpawnItems=Base.Ramen,Base.Ramen,Base.Axe,Base.FishingRodSpawnItems=Base.KitchenKnife,Base.Bandaid,Base.WaterBottleFull,Base.Duffelbag

hope that helps

 

also i released my Server Admin Tools

http://theindiestone.com/forums/index.php/topic/8149-server-admin-tools/#entry106981

 

very helpful i can see where i went wrong now thank you.

one more question where do i save abundant loot and insane zombie population is it in the main project zombie folder or some where ells?

Share this post


Link to post
Share on other sites

So I'm not really sure what I'm doing wrong, I was trying to get the Bedford map running on a server that im hosting. I can't get it to run at all. Well that's not true, Bedford loads fine in single player. My problem is and I tested both with out mods, and on two new installs is this. The server loads fine ( with no mods ) but it only loads once, if I close the server then any time I run the server file to load it again it just hangs at the end and says "press any key to continue" but when you press a key it just closes, I can still connect to other games just fine but it won't reload the server. can anyone offer me some help ?

Share this post


Link to post
Share on other sites

I can't run the server since Build 26. :sad:

 

When I run the server.bat as admin it says:

C:\Windows\system32>".\jre64\bin\java.exe" -Xms2048m -Xmx2048m -Djava.library.pa
th=./ -cp lwjgl.jar;lwjgl_util.jar;sqlitejdbc-v056.jar;./ zombie.network.GameSer
ver
Das System kann den angegebenen Pfad nicht finden.
(translation: System could not find path)

C:\Windows\system32>PAUSE
Drücken Sie eine beliebige Taste . . .
(translation: Press any key to continue)

 

 

 

When I run regular:

D:\Spiele\Project Zomboid Build 26>".\jre64\bin\java.exe" -Xms2048m -Xmx2048m -D
java.library.path=./ -cp lwjgl.jar;lwjgl_util.jar;sqlitejdbc-v056.jar;./ zombie.
network.GameServer
Loading RakNet from: ./
Exception in thread "main" java.lang.UnsatisfiedLinkError: D:\Spiele\Project Zom
boid Build 26\RakNet64.dll: %1 ist keine zulõssige Win32-Anwendung
(translation: boid Build 26\RakNet64.dll: %1 is no proper Win32-application)
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1957)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1882)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1872)
        at java.lang.Runtime.loadLibrary0(Runtime.java:849)
        at java.lang.System.loadLibrary(System.java:1087)
        at zombie.core.raknet.RakNetPeerInterface.init(RakNetPeerInterface.java:
19)
        at zombie.network.GameServer.main(GameServer.java:85)

D:\Spiele\Project Zomboid Build 26>PAUSE
Drücken Sie eine beliebige Taste . . .
(translation: Press any key to continue)

 

 

 

Any suggestions?

I installed Java and checked firewall before.

Share this post


Link to post
Share on other sites

I can't run the server since Build 26. :sad:

 

When I run the server.bat as admin it says:

C:\Windows\system32>".\jre64\bin\java.exe" -Xms2048m -Xmx2048m -Djava.library.pa

th=./ -cp lwjgl.jar;lwjgl_util.jar;sqlitejdbc-v056.jar;./ zombie.network.GameSer

ver

Das System kann den angegebenen Pfad nicht finden.

(translation: System could not find path)

C:\Windows\system32>PAUSE

Drücken Sie eine beliebige Taste . . .

(translation: Press any key to continue)

 

 

 

When I run regular:

D:\Spiele\Project Zomboid Build 26>".\jre64\bin\java.exe" -Xms2048m -Xmx2048m -D

java.library.path=./ -cp lwjgl.jar;lwjgl_util.jar;sqlitejdbc-v056.jar;./ zombie.

network.GameServer

Loading RakNet from: ./

Exception in thread "main" java.lang.UnsatisfiedLinkError: D:\Spiele\Project Zom

boid Build 26\RakNet64.dll: %1 ist keine zulõssige Win32-Anwendung

(translation: boid Build 26\RakNet64.dll: %1 is no proper Win32-application)

        at java.lang.ClassLoader$NativeLibrary.load(Native Method)

        at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1957)

        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1882)

        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1872)

        at java.lang.Runtime.loadLibrary0(Runtime.java:849)

        at java.lang.System.loadLibrary(System.java:1087)

        at zombie.core.raknet.RakNetPeerInterface.init(RakNetPeerInterface.java:

19)

        at zombie.network.GameServer.main(GameServer.java:85)

D:\Spiele\Project Zomboid Build 26>PAUSE

Drücken Sie eine beliebige Taste . . .

(translation: Press any key to continue)

 

 

 

Any suggestions?

I installed Java and checked firewall before.

Do not run it as admin. The .bat is trying to run using 64-bit Java (bundled with the game, your Java installation has nothing to do with PZ) which doesn't work on your 32-bit Windows. Edit the .bat file and replace

".\jre64\bin\java.exe" -Xms2048m -Xmx2048m

with

".\jre\bin\java.exe" -Xms850m -Xmx850m

and if it runs out of memory, try lowering the memory values even more. As a warning, you won't be able to host for a large number of people on 32-bit Windows because of the memory limitations.

Share this post


Link to post
Share on other sites

Thanks, I tried this with the following result:

 

 D:\Spiele\Project Zomboid Build 26>".\jre64\bin\java.exe" -Xms850m -Xmx850m -Dja
va.library.path=./ -cp lwjgl.jar;lwjgl_util.jar;sqlitejdbc-v056.jar;./ zombie.ne
twork.GameServer
Loading RakNet from: ./
Exception in thread "main" java.lang.UnsatisfiedLinkError: D:\Spiele\Project Zom
boid Build 26\RakNet64.dll: %1 ist keine zulõssige Win32-Anwendung
(translation: boid Build 26\RakNet64.dll: %1 is no proper Win32-application)
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1957)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1882)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1872)
        at java.lang.Runtime.loadLibrary0(Runtime.java:849)
        at java.lang.System.loadLibrary(System.java:1087)
        at zombie.core.raknet.RakNetPeerInterface.init(RakNetPeerInterface.java:
19)
        at zombie.network.GameServer.main(GameServer.java:85)

D:\Spiele\Project Zomboid Build 26>PAUSE
Drücken Sie eine beliebige Taste . . .

(translation: Press any key to continue)

 

In fact, I'm running a 64-bit Windows version.

Share this post


Link to post
Share on other sites

Any other admin get the same error after the update today? I tried everything (reinstall PZ with deleted everything, reinstalling java, tested Windows and Linux, tried Stable and IWBUMS).

I assume you restarted Steam and switched branches and then back to "none" just to make sure you got the recent update?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
2 2