Jump to content

failed to establish p2p connection with server

Recommended Posts

Hi team,


Every time I try to join a server this error pops up: "failed to establish p2p connection with server".


I searched on the internet and I tried deleting the "Save" and "Server" folders from Zomboid folder, I tried deelting the game and reinstalling it, I tried deleting steam as well but nothing worked out. Could I have some assistance please? I mainly bought the game to play with my friends and enjoy it but it's not happening :(


Thanks in advance:D

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...