Jump to content

[41.71] Error! Check record device frequency

Recommended Posts

Posted (edited)

I had just installed a discrete streaming microphone (edit: on my pc, which is running) an existing PZ installation from Steam, and got this error today.

The game was previously working fine before this change, so I can say with fair certainty that installing a microphone (in my case the Sudotack ST-900) can reproduce the issue. Another post I found had to do with an Elgato capture device, and another with a Blue Yeti microphone.

I've searched for previous posts in and out of the forums, so based on that I tried to change the sampling rate of my recording/input device -- but still get the error. Understandably, no audio plays from the game due to the error with the recording device.

Attached logs file for review. Please let me know if you need other info/data.


Edited by steev

Share this post

Link to post
Share on other sites

Generally this issue happens if the frequency of the audio device is way too high. Try going to your Sound settings and set the sampling rate of the microphone to 41 000hz or 48 000hz and see if that helps.

Share this post

Link to post
Share on other sites

Thanks for the reply @Beard -- I did some troubleshooting based on some googling I've done so far, it seems to be resolved at this point.  Note that I have Voicemeeter installed (failed to mention this at the OP)

For anyone else running into this topic by forum search/Google -- If you're installing a new microphone and you already had Project Zomboid and Voicemeeter installed -- then you run into this error;

  • Install your mic and do some testing. Make sure, that at a base level, the mic itself has no issues.
    • Ensure that the frequency of all your audio devices (input and output) are set to 48000hz, to avoid other potential issues. This includes whatever changes you need to implement in Voicemeeter.
    • Backup your last known working settings for Voicemeeter. Or just what you have on settings now.
  • Uninstall VB-Cable (if you have it) and Voicemeeter.
  • Restart your PC
  • Reinstall Voicemeeter, then restart your PC
  • Load your settings using the backup file you just created
  • Run PZ through whichever method you usually start it.

I suspect that the issue has to do with whatever settings Voicemeeter and/or PZ are configured for since you last installed it, so adding a new audio device that might run on a higher frequency may cause the error to happen.

TL;DR: Set your audio frequency settings to 48,000hz at maximum, then reinstall Voicemeeter.


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...