Jump to content
  • 0
Cryfer

Game won't use my eGPU

Question

Posted (edited)

I play on an old laptop with integrated intel graphics (hd graphics 4600), but I have an egpu (r7 m265). The game does not want to use the full power of the external video card, I don’t know why. But if I disable the external graphics card in the device manager, then the integrated graphics work at full capacity, but if I disable the integrated graphics, the game does not start at all.

Screenshot_1.png

Screenshot_2.png

Edited by Cryfer

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
13 hours ago, Beard said:

I tried this many times, it didn't help. As I understand the problem in opengl, it is not able to switch graphics

Share this post


Link to post
Share on other sites

  • 0

OpenGL has nothing to do with the inability of the graphics card to be switched, its just a game rendering engine.
Can you launch the game again through the external card and then share your console.txt file found in C:\Users\YourUserName\Zomboid?
After that can you also share the latest “hs_err_pid” file found in your main game folder “Steam\steamapps\common\ProjectZomboid”?

Share this post


Link to post
Share on other sites

  • 0
18 hours ago, Beard said:

OpenGL has nothing to do with the inability of the graphics card to be switched, its just a game rendering engine.
Can you launch the game again through the external card and then share your console.txt file found in C:\Users\YourUserName\Zomboid?
After that can you also share the latest “hs_err_pid” file found in your main game folder “Steam\steamapps\common\ProjectZomboid”?

 

console.txt hs_err_pid7740.log

Share this post


Link to post
Share on other sites

  • 0

Seems like from the logs the game does use the correct graphics card, though there seem to be some driver issues. Could you update the drivers for your Intel graphics card and your external one as well? Since based on the version info they may be outdated.

Share this post


Link to post
Share on other sites

  • 0

There are also errors with mods. It’d be best to disable them.

 

 Set fullscreen to false in the Options.ini file found in %userprofile%\zomboid if updating drivers doesn’t work.

Share this post


Link to post
Share on other sites

  • 0

Oh, I see. The hs_err is actually from May 1st, so it's probably not relevant if the game is running.

 

There might not be much we can suggest here, if the main problem is just that it's not running at full capacity vs. crashing because it's ultimately going to be decided by the OS/GPU drivers.

 

Are you running it on the laptop's native display? You might get better results if you have the option of plugging in an external monitor to the eGPU. 

Share this post


Link to post
Share on other sites

  • 0

I am using native display. Perhaps this is the problem that the integrated graphics are tied to the native display. Although the problem may be in the drivers, I tried to download the drivers from the official AMD website, but they did not work. From the website of the laptop manufacturer, the drivers worked

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


×
×
  • Create New...