Jump to content

Latest TileZed, WorldEd and Tilesets (March 14 2022)


Recommended Posts


Tileset images


These are the same tilesets released on February 16.


For Windows

TileZed + WorldEd 32-bit

TileZed + WorldEd 64-bit


The 32-bit version of WorldEd seems unable to load all the tilesets due to high memory usage, displaying ??? for some tiles.



TileZed + WorldEd 64-bit


This was built on Ubuntu 20 and won't work with older versions of glibc.

If WorldEd is crashing when opening cells, try turning off the "Use hardware-accelerated drawing (OpenGL)" option.



TileZed changes

  • The format of texture .pack files was changed.  The old format used a certain sequence of bytes to mark the end of each PNG image.  The new format writes the length of the image followed by the image itself.  This was done to fix a bug where a PNG image contained the same sequence of bytes that was used to mark the end of the image in the .pack file.
Link to comment
Share on other sites

LINUX !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
@EasyPickinsAre you check new TileZed and WorldEd before publishing ?
New TileZed can't see new roads blends tiles ?
TileZed can't read Tileset.txt correctly.

What are heck ? Every fucked versions critical bugs and not worked instruments. Endless unfixed bullshit.

How to fix it tha bullshit ?

Link to comment
Share on other sites

On 3/15/2022 at 4:02 AM, Alree said:

do you plan to change all tiles pack to the new format ?

What about the DDS ? Characters.pack

There shouldn't be any need to, but if any changes to the .pack files are made, they will be updated to the new format.  Characters.pack isn't used.


2 hours ago, Nazarito22 said:

@EasyPickinsWhere is rounded roads tiles for new roads ? Can't find them. 

They are the street_curbs_blend_xxx.png files.

Link to comment
Share on other sites

7 minutes ago, EasyPickins said:

They are the street_curbs_blend_xxx.png files.


I don't see them in TileZed, but new another Tiles exist in TileZed. Only roads curbs don't see.

I tried to put /root/.Tilezed/Tilesets.txt to /TileZed/share/config/Tilesets.txt   Not working

/root/.Tilezed/Tilesets.txt  -  here is correct file
/TileZed/share/config/Tilesets.txt  -  here is not correct file and using by default

Link to comment
Share on other sites

  • 2 months later...
1 hour ago, Pydy said:

Hi, just a quick question. After generating the worldmap.xml my building and etc is showing up in-game on the minimap but the roads not.
What is the trick for it ? 

Have you added poly's (the new in game map options in WorldEd) in worldEd with the correct definitions over your roads? (highway - primary, highway - secondary etc?)

Link to comment
Share on other sites

  • 1 month later...

I need help. I try to make a new map but when i choose "BMP To TMX"  and click, the WE say:

"A tile listed in Rules.txt could not be found.

 The missing tile is called 'blends_natural_01_080'.


 Please fix the invalid tile index or add the tileset

 if it is missing using the Tilesets dialog in TileZed.


 (while reading Rules.txt)"


I try a lot but its impossible, i don't know what to do.

(And yes, i read 1 post about this question but the answer didn't help me)


Well, the error fix himself because idk (really, i only restart my pc and the now the last error doesn't appear, but but I leave the text in case you have above in case you have any idea for my new error)

Now i can create the map, but when i click "finished" i cant see the map change and when i click the map this appear: (See images)



Edited by Dazer
I found a new problem :(
Link to comment
Share on other sites

You need to point WorldEd to the Tiles folder you downloaded. In WorldEd click on Edit and then Preferences, then make sure the "Tiles Directory" is pointed to the Tiles folder you downloaded and NOT the 2x folder inside of it, once done restart TileZed and WorldEd and you should be good to go.

Link to comment
Share on other sites

I have a new error.

The WE and the TZ don't recognize the colors 127,0,0 and 0,128,0 and 255,0,0 (only the one on the grass, road and water is visible, no other color is recognize)

I using the tutorial made in this forum, i use paint.net and i turn off antialiasing and change the blend mode to overwrite mode




Edited by Dazer
no detect any colors more than 3
Link to comment
Share on other sites

  • 1 month later...

Hi , first time to use software like that , i have donwload the 64bit windows version and unzip. when I trying to run PZWorldEd.exe and TileZed.exe both pop-up the same error. Can that be fix myself ? Or just my move is wrong.

Edited by YAUSS
Link to comment
Share on other sites

  • 1 month later...

There is something wrong with the UI2.pack. I simply cannot unpack it anymore since v41.7X

It was just fine with .66, no matter which Tool I used. My last hope died with this tool.


Please update to the newest encryption (or whatever hinders the tool from actually progressing any further than a single .png file and that even being half corrupted).


I have no issues unpacking UI.pack btw, but that one does not interest me, as the bright logos I want to saturate down are in UI2.

Link to comment
Share on other sites

  • 4 months later...
On 7/9/2022 at 5:04 PM, Adilaz-diaz said:
I have this problem, does anyone know how to solve it?

Sin título.png



I solved this problem.
Back up all your bmp,tmx files and tiles first.
Remove the existing tilezed and tileset located in the specified path.
Then you go back to the first part of the post.
Download the tileset (file), tilezed (program).
Run worldEd.
You will then be prompted for the tile directory.
If it doesn't show, try entering the properties.
Please proceed to step bmp to tmx again.
Failed message is displayed because tileset's tile of the path with tiled set was not found.

Edited by nero82ra
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...