Jump to content

Archived

This topic is now archived and is closed to further replies.

  • 0
BlgJ0E

Poor performance and game randomly minimizes

Question

I've had PZ since it was on desura and had played it throughout the years without any performance problems. Recently, I reinstalled it and decided to give it another go, but I cant get the games performance to a playable state. Im getting about 12fps, even the main menu is laggy.  Also, the game will minimize at random, this does not occur with any other game I have (the minimizing).

 

Using:

Windows 10 home 64 bit (build 19042)

NVIDIA GTX1080

 

Ive tried to change the settings a bit, but it doesnt seem to make too much of a difference.

 

Thanks

console.txt

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

There doesnt seem to be anything wrong in the console, except maybe that you are a few Nvidia driver updates behind, so I would recommend you update that for the best performance. Most likely the bad game performance comes from something externally affecting the game, for example any overlay programs, antivirus software or any settings forced on the game by anything can cause issues (for example the Nvidia control panel forcing anti aliasing or any other setting), therefore I would recommend you check any of those factors first.

Share this post


Link to post
Share on other sites

So I updated the Nvidia driver, checked for windows updates, stopped all non-essential services i could find, then went to the nvidia control panel and reset all of the settings (i dont think i ever changed them) and then made sure that all of the settings were then set to application specific or to max performance. The framerate went from a max of 12 to 16. Im not too sure what else I can do. Are there any more suggestions?. Could there be an old settings file carried over from a previous version that doesn't get deleted when uninstalling and then reinstalling the game? 

Share this post


Link to post
Share on other sites

Thanks for the help Beard.

 

I was able to get a better frame rate yesterday by adjusting dpi in the compatibility tab in “projectszomboid64.exe.” Im now at about 20-22 fps with all the graphics turn down. Its playable, but still not that great.

 

Launching “Projectzomboid32.bat”  and the other .bat and .exe’s in the steamapps folder gives me a small window that only takes up part of the screen in the top left. I’ve played around with the dpi’s in both the .exe’s settings and cant seem to get it to resize properly. The game launches in proper full screen from steam with the reduced frame rate. I cant seem to get the frame rate to display when i launch it through the .bat. It does feel a bit smoother, hard to tell in the small window though. 

 

Share this post


Link to post
Share on other sites

Have you tried disabling the DPI scaling globally in the Windows settings and not per application? It could fix the tiny window issue, you could also change the settings to launch the game in windowed mode, which should fix that as well and you could test the 32 bit version performance like that.

Share this post


Link to post
Share on other sites

I’m not too sure how to disable dpi scaling globally other than move the windows slider back to 100%. I did that, and it may be a coincidence, but I can now see the fps when launching from the .bat files in the zomboid folders. Launching zomboid32.bat, zomboid64.exe, or zomboid64.bat I can get a framerate of about 90 when i up the locked frames, but the window is compressed to the upper left corner. I can change the settings to windowed and maximize it and i still get high fps (unfortunately the task bar is still showing). When i launch from either steam or zomboid64.exe i get the full fullscreen, but the frames dont go higher than 22 with frequent drops.

Share this post


Link to post
Share on other sites

You can check more info about DPI here:
https://steamcommunity.com/app/108600/discussions/0/1642041886384669880/

Though as you said, seems like launching the 64 bit version causes the frame drops while the 32 bit runs fine, this might be due to your Windows version being out of date or there being an issue with your Java installation, either try updating Windows or play in 32 bit version with the Window fixed with the DPI fix. You can simply apply it to the 32 bit exe and it should run fine I assume?

Share this post


Link to post
Share on other sites

On 10/9/2021 at 2:02 PM, BlgJ0E said:

 Also, the game will minimize at random, this does not occur with any other game I have (the minimizing).

 

 

I have the same problem that the game minimizes sometimes randomly (but actually not the time to try to find out why it is like this).

It was not a big problem until now - I had the luck not to die with my character because of it - one second and I am back in the game.

 (Just for you and the developers to know.)

 

I will have a look in this topic - if you have some solution, some description haw it was solved would be nice in here.

Share this post


Link to post
Share on other sites



×
×
  • Create New...