Jump to content
Inthegrave

Game crash when using throwable bomb from elevation

Recommended Posts

I noticed when throwing a bomb like a Molotov, Flame Trap or a Aerosol bomb from the tops of buildings the game will crash throwing you back out to the menu.

The game will also generate a crash backup save. A red error message will display in the bottom right corner, error code 1.

 

The specific building I had this happen on was on top of the "Mama Mcfudgeington's" building in downtown Rosewood.

The point of interest I mentioned is labeled here:

https://map.projectzomboid.com/?#0.3304595560081354,0.2816890293392594,486.176905713021

 

I was trying to throw a bomb down to the parking lot out back at a bunch of zombies, but what would happen instead was the game would freeze before the bomb was even thrown

as the player drew their arm back in a throwing motion. Even reloading the game and trying again would yield the same results each time. I have replicated the issue on other buildings.

 

This is in IWBUMS build 41.50. Using no mods.

Edited by Inthegrave

Share this post


Link to post
Share on other sites

Hmm.. doesn't crash for me :(

 

Could you tell us your system specs - ram and graphics card specifically? As well as, share the "console.txt" file found in "C:\Users\YourUserName\Zomboid" to a site like pastebin.com and then post a link to that here so we can take a look (do this after the crashobviously :) )

 

 

Share this post


Link to post
Share on other sites

Strange, the issue is 100 percent repeatable for me on almost every building roof I could find. I even started a new game to just simply

test throwing a Flametrap out a window and got the same result.

 

System specs: RAM 32 GB 3200 mhz, Graphics card: RTX 2080 SUPER, CPU: 9900k.

 

Hope you don't mind Media Fire:

console.txt file:

https://www.mediafire.com/file/nlv6qkt4niqlvn8/console.txt/file

 

Crash backup save file generated from a test game attempting to throw a bomb out the window (Not the roof like I previously mentioned in my other saves):

https://www.mediafire.com/file/nzn4jgix6nxwds2/15-07-2021_09-01-08_crash_crash.7z/file

 

The crash stops you from actually spending the item so the file still has the Flametrap in my inventory, try throwing it out the window the character is facing.

 

A few other details: I was using a controller to do this and not the keyboard and mouse and I was using a 1440p resolution.

(Wouldn't think any of that would matter but I figured I should mention it).

 

 

I must say I have been playing Project Zomboid the past few months and the game is REALLY stable overall and I have ran into little to no bugs

and no crashes until now. So normally my experience with the game is butter smooth aside from some stuttering from long distance travel in cars.

Edited by Inthegrave

Share this post


Link to post
Share on other sites

Can I ask, do you use a game pad or controller to play the game? I do and I have this exact same issue!

I was playing the "You have one day challenge" just so I could use the cheat/item spawner and go nuts testing out the guns and munitions, like the moltovs. 

I waited for the hordes and standing on one of the rooftops, I hurled one over, only for the game to freeze, go black and crash. I thought it was maybe there were too many zombies when the same thing happened a second time.

I ran into a bug a while back involving the playable media not working for me and it turns out, it was an input bug linked to the controller. Maybe... this is another?

Share this post


Link to post
Share on other sites

On 7/27/2022 at 2:02 PM, Pandorea said:

Gotcha, it is a controller related issue! Added to our internal bug tracker ( somehow I've managed to miss previous message where it specifies to use a controller for this :( )

Ahhh so glad I mentioned it in that case!
Don't feel too bad, as far as I know, I'm the only one who uses a controller set up for this :D Well, now I know there's at least one more! <3
Good luck with the fix guys!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


×
×
  • Create New...