Jump to content
  • 0
zmokn02

Build 41 no audio on Linux

Question

Hi, I've recently tried to play PZ after a couple of weeks, but there's no sound coming from the game and KDE doesn't show PZ as an audio source. From the game settings I noticed that the microphone option is empty.

I think it might have something to do with PipeWire since it's the only thing (that I can think of) that is sound related that I installed/modified recently.
Also tried the compatibility mode but there was no sound either.

Seems to work with Proton, but there's a bit of a performance hit.


Currently running Arch Linux with 5.11.15 kernel

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hi. Tried a few of the solutions proposed in the Arch Wiki, but there's no sound still.

 

I completely agree, it might have something to do with the system itself since the last time I played was around early march and everything was ok, but I don't know if PipeWire is the culprit here, might try disabling first to make sure.

Share this post


Link to post
Share on other sites
  • 0

Been busy for the last couple of months, but here's a quick update:

The sound issue persists. I assume it has something to do with pipewire, which is now a dependency for some programs, KDE (and soon Gnome) included, so I don't have a simple way to test my hypothesis.

Share this post


Link to post
Share on other sites
  • 0

Since I had zero luck trying to fix it, I'll try to explain the issue in more detail:

 

So this is the output of

pactl info

As of today, I'm running PipeWire 0.3.30
Screenshot_20210614_002419.png.7de40301ac32b218c7faa3fb5d6b8a87.png

 

I've tried the solution proposed on the arch wiki, but still no luck. I've also tried verifying the game files through steam, even reinstalled once.

Screenshot_20210614_002951.png.926f0b029d40c68a75d8fc0e5cd42cfc.png

 

Everything looks ok at this point, so let's open zomboid

Screenshot_20210614_003157.thumb.png.a8d81aea529b26bd1152b97e1b5ad61c.png

 

The volume levels are correct, but notice that there are no recording devices available, which is weird.

Screenshot_20210614_003325.png.afb173374b84e806c56339283e34c853.png

 

And as you can see, both Firefox and Spotify are working, but PZ doesn't appear on the list of applications outputting sound.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Another update:

 

I was reading the game logs and found something interesting:
 

[15-06-21 18:19:05.415] LOG  : General     , 1623802745415> [javafmodJNI] Init: Start.
[15-06-21 18:19:05.421] LOG  : General     , 1623802745420> Creating display. If this fails, you may need to install xrandr..
[15-06-21 18:19:05.424] LOG  : General     , 1623802745424> 1623802745424 fmod: Java loging: OK.
[15-06-21 18:19:05.424] LOG  : General     , 1623802745424> 1623802745424 fmod: System Create: OK.
[15-06-21 18:19:05.504] LOG  : General     , 1623802745504> 1623802745504 fmod: Create DSP for capture sound.
[15-06-21 18:19:05.505] LOG  : General     , 1623802745505> 1623802745505 fmod: ERRPR: FMOD_System_CreateDSP return 30.
[15-06-21 18:19:05.505] LOG  : General     , 1623802745505> ERROR: FMOD_System_CreateChannelGroup exception:An invalid object handle was used...

 

And as it turns out, it's a know issue with FMOD and PipeWire.

Edited by zmokn02
Typo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...