Jump to content
Sign in to follow this  
Bugged_Host

Win10 Server Hosting: No Port Listening?

Recommended Posts

Hi,

 

TL;DR - Port forwarding works.  Not blocked by firewall or A/V.  I can connect to non-PZ servers that I host (and simple apps, like netcat), both locally and over the internet.  I've hosted PZ Servers (years ago), without any hassle.  Netstat indicates PZ Server isn't listening on ANY ports.  Please help?

 

I'm pretty comfortable working my way around CMD, routers, firewalls, and have hosted servers for games before (years ago I even hosted for PZ!).  I just returned to the game and wanted to host, but seem to be getting a bizarre issue.  Project Zomboid server is NOT listening on any ports.  Am I supposed to configure this somewhere?  My understanding is that it's supposed to listen on 16261-16262, at the bare minimum.  Please see my below troubleshooting steps, if it helps.  I am using Windows 10 and bought the game through Steam, fyi.  I've attempted running the server via Steam's dedicated tool, via the *.exe file, and most importantly the *.bat (how I used to run it years ago).  Also, all below troubleshooting steps were attempted with both administrative and non-administrative modes.

 

Step 1.  Configured router port forwarding for TCP/UDP of 16261-16262 (I'll add more when I seek to add more players)

Step 2.  Configured OS Firewall to permit activity on those ports.
Step 3.  When I launched the PZ Server batch file, firewall asked me to allow the application.  I selected yes.
Step 4.  Ran PZ Server.  Tried to connect via game, no dice.  Tried using an online port checker, no dice.  Tried using netcat (via localhost, as well as external IP address), no dice.
Step 5.  Ran a netcat listener on ports 16261/16262, then attempted to connect to them (via localhost, as well as external IP address) using another netcat instance, worked like a charm.
Step 6.  From CMD, ran:  netstat -an | find "16261"    Can discover when netcat listener is running, but not PZ Server.
Step 7.  From CMD, ran:  netstat -abno    Can't discover any applications running with "PZ" or "Zom" in the name (varied both, in case of case-sensitivity).
Step 8.  Scrutinized the output of the PZ Server CMD window, but found nothing alluding to errors or warnings.  Seems to have started up just fine.
Step 9.  Read a few other posts (both in this forum, as well as online) trying a few other things, but nothing worked.  Querying for "port" problems mostly turns up people who are confused about router management, so the answer I seek is probably out there, but totally buried by those seeking help on how to do port forwarding (which again, is not the issue).
Step 10.  Sighed heavily, tried to reset the password for my old PZ Forum acct (from years ago), Indie Stone password reset email requests hanged for over two hours, tried again, still no luck (even checked spam mail!).  Decided to make a new forum account, but discovered Indie Stone limits 1 acct, per email address.  Decided to create a temporary email account using GuerillaMail, discovered the US Govt forced them to shut down on Nov 4th.  Googled to find an alternative temporary email generator (until such time that Indie Stone send me a password reset, so I may respond later with my actual account, hopefully), and brought you this delightful story of technology fighting me.  :P

 

Note:  For those wondering, no, I didn't run a netcat listener and the PZ Server concurrently at any point.  So, there was no battle for port ownership.

Edited by Bugged_Host

Share this post


Link to post
Share on other sites

6 days later, ~100 views, no responses...has the PZ community died and turned undead?  I thought y'all were survivors!  Any help would be appreciated, as I'm at a loss here without diving into the developers' code and re-programming their efforts (which would be silly and far too much work).

Edited by Bugged_Host

Share this post


Link to post
Share on other sites

I'm way too out of the loop with anything MP related to be of much help, and it seems like you've already tried a lot. 

Is the issue purely that it's not listening to ports right after starting the server? Did clients actually try to connect to the server?

Could it technically be a case of the gameserver not listening for the TCP ports until after it got a game client connection attempt through the UDP port? 

Did you try to connect to the server yourself and what error pops up on the client and server log, if any?

Share this post


Link to post
Share on other sites

It'd have been better to put this in support, as no one ever really posts in this section, but I understand why -- the name's rather fitting, isn't it?


Do you need a dedicated sever? If not, all you have to do these days is launch PZ -> press host -> invite anyone off your Steam list. Assuming your router/OS has UPnP enabled, this'll automagically handle port setup for you.

Share this post


Link to post
Share on other sites

Thank you both for your responses!

 

@nasKoThat's correct; there's no TCP port (or UDP port) listening.  Thus, when I (and a friend) attempt to connect, there are no errors generated by the server, nor logs captured, because it's deaf to all connectivity attempts.  To analogize, it's akin to trying a thousand different ways of displaying and verbalizing how 1+1 = 2, but the person you're attempting to educate is 100% blind and deaf.  So that person just keeps humming along doing their own thing, completely unaware of your presence.

 

@EnigmaGreyTHANK YOU.  This worked.  I hadn't realized how much effort had gone into this (since I didn't seen anything online about this feature and my initial test of it failed [as you mentioned, UPnP enablement required], so I assumed [wrongly] that it was an incomplete feature while alpha development continues).  I am now able to host and friends were able to join.  :D  Much obliged!  Btw, having now gone through this process, I thought I'd provide two suggestions to improve experience for server hosts.

1.  Server setup options:  I noticed most the options had mouse-over tips.  As a feature suggestion for server hosts, a mouse-over for the electricity/water shut-off would be helpful, too.  For instance, the default for the easiest and second easiest modes are "600" and "14", respectively.  I "presume" this means in-game "days" (i.e. unless modified from default, 600 or 14 hours real-life gameplay).  That's somewhat inferable, but what isn't inferred is if this is an absolute time or a range time (i.e. water shuts off in 600 days or within 600 days).  Also, if it's the later (i.e. within X days), the code might also be extensible to provide a min and max range (i.e. shut-off water/electricity between X [4] and Y [10] in-game days, for those that want some randomness, but not necessarily no water/power within the first hour of gameplay [if terribly unlucky]).

2.  When using the server hosting approach you recommended above, there's a tool tip provided for hosts, so as to successfully invite people.  Mentioning the UPnP enablement for router and OS would prevent others from experiencing what I had.  Granted, most probably have these on by default; I had assumed (wrongly), from past hosting experiences, it would leverage the port forwarding rules I had setup.

Edited by Bugged_Host

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...