Jump to content
nasKo

IWBUMS 41.39 RELEASED

Recommended Posts

NEW

 

  • translationProblems.txt lists missing ItemName_xxx instead of the old DisplayName_xxx.
  • Removed the true|false debug console spam.
  • Added buttons to access the Attachment Editor, Chunk Debugger, and Vehicle Editor to the debug menu.
  • Added DebugType.Mod for controlling the display of mod-related debug messages to the console.
  • Updated latest Community Translations

 

 

FIXES

 

  • Used Docker to create libjassimp64.so and libLighting64.so with a version of GCC that will not cause issues with some Linux setups
  • Fixed the vehicle editor not selecting the correct vehicle in the scripts combobox.
  • Fixed the tutorial breaking at the zoom in/out stage when not using double-sized textures.
  • Fixed rendering error when the Bucket Hat is on the ground.
  • Fixed a vehicle shader not compiling on some systems.
  • Fixed GameTime.getMinutesStamp() having a resolution of 2 minutes instead of 1.
  • Fixed weapon models not being updated after removing weapon parts (scopes, etc) when the weapon is attached to the player.
  • Fixed the HuntingRifle (MSR788 Rifle) scope not being displayed.
  • Fixed not detecting when multiple active mods use the same tile definition file numbers. These file numbers are specified by "tiledef=" in mod.info files.
  • Fixed being able to pick up a propane barbeque without removing the propane tank.
  • Fixed the animation editor not setting the Reverse checkbox when selecting animations.
  • Fixed the animation for removing a magazine from a firearm.
  • Fixed lua error when fishing and the last lure breaks.
  • Fixed incorrect instruction in tutorial re: tall fence
  • Fixed (hopefully) the last of the 'red dot on tiles' issues
     

Share this post


Link to post
Share on other sites
33 minutes ago, Maris said:

Is it shown as 41.38? I've got update via Steam but it's still 41.38

 

 

 

Hello! Yes, this is the 39th version. I checked one of the bugs (Guess which one) - this bug is fixed, so we can say that the update was installed successfully ^-^ 

Share this post


Link to post
Share on other sites
55 minutes ago, Maris said:

Is it shown as 41.38? I've got update via Steam but it's still 41.38

 

 

 

Yes the version number didn't update correctly. It's still .39.
A hotfix will be pushed to correct the version number, soon.

Share this post


Link to post
Share on other sites
18 hours ago, nasKo said:

NEW

 

  • translationProblems.txt lists missing ItemName_xxx instead of the old DisplayName_xxx.
  • Removed the true|false debug console spam.
  • Added buttons to access the Attachment Editor, Chunk Debugger, and Vehicle Editor to the debug menu.
  • Added DebugType.Mod for controlling the display of mod-related debug messages to the console.
  • Updated latest Community Translations

 

 

FIXES

 

  • Used Docker to create libjassimp64.so and libLighting64.so with a version of GCC that will not cause issues with some Linux setups
  • Fixed the vehicle editor not selecting the correct vehicle in the scripts combobox.
  • Fixed the tutorial breaking at the zoom in/out stage when not using double-sized textures.
  • Fixed rendering error when the Bucket Hat is on the ground.
  • Fixed a vehicle shader not compiling on some systems.
  • Fixed GameTime.getMinutesStamp() having a resolution of 2 minutes instead of 1.
  • Fixed weapon models not being updated after removing weapon parts (scopes, etc) when the weapon is attached to the player.
  • Fixed the HuntingRifle (MSR788 Rifle) scope not being displayed.
  • Fixed not detecting when multiple active mods use the same tile definition file numbers. These file numbers are specified by "tiledef=" in mod.info files.
  • Fixed being able to pick up a propane barbeque without removing the propane tank.
  • Fixed the animation editor not setting the Reverse checkbox when selecting animations.
  • Fixed the animation for removing a magazine from a firearm.
  • Fixed lua error when fishing and the last lure breaks.
  • Fixed incorrect instruction in tutorial re: tall fence
  • Fixed (hopefully) the last of the 'red dot on tiles' issues
     

Guys, what the hell?) Stunned.  Inside your car there is a salon, doors and windows open.  I have no words, this is super cool.  Will it be soon for all cars?

32924083-8485-4CA0-8C03-08649F571EE2.jpeg

Share this post


Link to post
Share on other sites
Posted (edited)

Thank you for sharing the above photo

 

I guess the sports car (Corvette) takes the popup headlights with it when the hood opens. 

Correction, this is not an issue, I just had to remind myself what the engine bay looked like. 

Edited by Kim Jong Un

Share this post


Link to post
Share on other sites
25 minutes ago, Kim Jong Un said:

Thank you for sharing the above photo

 

Minor issue, but I guess the sports car (Corvette) takes the popup headlights with it when the hood opens. 

 

If possible, the quick-fix would be to cut the squares for them out of the hood and anchor them to the engine bay. Until they are functional, this will do.

No, no, no problems, everything works correctly.  Animation, sound, everything works fine.  I was just surprised when I saw this.  It was unusual. My post is not about an error, but about the fact that I noticed this detail!  :)

Share this post


Link to post
Share on other sites
2 minutes ago, Zed_Slava said:

No, no, no problems, everything works correctly.  Animation, sound, everything works fine.  I was just surprised when I saw this.  It was unusual. My post is not about an error, but about the fact that I noticed this detail!  :)

Yeah, I agree! I also got my complaint wrong - I forgot the C4 actually does take the headlights with the hood as it lifts. No need to "fix" it either.

Share this post


Link to post
Share on other sites
6 hours ago, Kim Jong Un said:

Yeah, I agree! I also got my complaint wrong - I forgot the C4 actually does take the headlights with the hood as it lifts. No need to "fix" it either.

 

I'd say there is, since

 

one, it looks bad

 

and, more importantly, two, c4's hood doesn't open like the car in OP's picture

 

 

corvette.jpg

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/23/2020 at 3:29 AM, blackray said:

Is this only me who has very poor performance and a lot of stuttering introduced since 41.48?

I had a download of Fps in the current version of iwbums
Edited by Massi

Share this post


Link to post
Share on other sites

GOG galaxy has 41.38 and 41.39 but ithey're both shaded out and won't let me download, even if I try to auto-update the game, so I'm stuck with 41.37 for now.  I'm using the DRM free version.

Share this post


Link to post
Share on other sites
On 6/23/2020 at 12:23 PM, Zed_Slava said:

Guys, what the hell?) Stunned.  Inside your car there is a salon, doors and windows open.  I have no words, this is super cool.  Will it be soon for all cars?

32924083-8485-4CA0-8C03-08649F571EE2.jpeg

How did you get the trunk open like that? Did you edit the model in debug mode?

Share this post


Link to post
Share on other sites
13 hours ago, Kappatao said:

Как ты открыл багажник? Вы редактировали модель в режиме отладки?

No. I did not do anything. Apparently this was done by the developers and accidentally added to the assembly. It should be in all cars soon.

Share this post


Link to post
Share on other sites
Posted (edited)

Can you guys look at fixing guns for this upcoming patch? They have had a bug where the longer they fire the slower the fire rate becomes until it actually starts to seemingly chug. Pistols are fine, anything thats fully auto or similar has issues. 


I understand this might be a B42 ticket but its infuriating.

Edited by sharkstertheshark

Share this post


Link to post
Share on other sites
10 hours ago, sharkstertheshark said:

Can you guys look at fixing guns for this upcoming patch? They have had a bug where the longer they fire the slower the fire rate becomes until it actually starts to seemingly chug. Pistols are fine, anything thats fully auto or similar has issues. 


I understand this might be a B42 ticket but its infuriating.

 

Could you be more specific as to which guns do this? Are these vanilla guns or mod guns?

Share this post


Link to post
Share on other sites

When is 41 going to get out of beta? I would like to get some friends into zomboid but they wanna wait until the new engine hits the regular game.

Share this post


Link to post
Share on other sites

So, I haven't played since May 2017. I also haven't played on my new computer yet, so I had to reinstall the game. After I did that, it downloaded a bunch of stuff. But, when I am in the main menu, it says that I'm playing version 40.43. Is this a bug? Or do I need to download the latest version somewhere? Thanks, and super excited to get back to playing PZ! =)

Share this post


Link to post
Share on other sites
On 7/2/2020 at 5:23 PM, sharkstertheshark said:

 

Use any gun that can go automatic?

There is only one automatic weapon in the game and last time I checked you could still only get in one of the challenge maps. This tells me you're using a mod which could be the real problem.

Share this post


Link to post
Share on other sites
On 7/6/2020 at 9:22 PM, PaladinHeart said:

So, I haven't played since May 2017. I also haven't played on my new computer yet, so I had to reinstall the game. After I did that, it downloaded a bunch of stuff. But, when I am in the main menu, it says that I'm playing version 40.43. Is this a bug? Or do I need to download the latest version somewhere? Thanks, and super excited to get back to playing PZ! 😃

You have to move on IWBUMS beta branch ;)

 

Another subject, I just notice the new UI of PZ site (https://projectzomboid.com/blog/) NICE, but one question, no Thursdoid this week? (I just come for that at the beginning ^^)

Share this post


Link to post
Share on other sites
On 7/9/2020 at 7:16 AM, link8dragon said:

You have to move on IWBUMS beta branch ;)

 

Another subject, I just notice the new UI of PZ site (https://projectzomboid.com/blog/) NICE, but one question, no Thursdoid this week? (I just come for that at the beginning ^^)

Your Thursdoid here https://projectzomboid.com/blog/news/2020/07/looks-different-somehow/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...