Jump to content
  • 0
MajAngelo

IWBUMS 41.37 Unexplained Mid-game Crashes

Question

Posted (edited)

Short Explanation: PZ has been crashing harder than most bethesda games ever will and have as of late. I got back into playing some Zomboid, and got a fresh install going. Had it running with hydrocraft and Superb Survivors. Seemingly worked out fine, until the game suddenly froze, as did all sound. Did ye old Ctrl Alt Del to get to desktop to see the APPCRASH window. Closing the window caused a short burst of the music to continue before Zomboid terminated.

I've tried reinstalling, vertifying, messing with every setting that seemingly could cause issues, running the game with -novoip, running it from the bat files, running it in compatibility mode, messing with min/max ram settings, fullscreen, borderless, windowed. Bottomline is, I've been pulling my hair out, and the crashes seemingly do not stop. I had one good run where it ran for about 30ish minutes on kingsmouth, until i suddenly got kicked into the main menu. The intervals are random, sometimes it will run for less than 10 minutes, sometimes it runs for around 30ish, generally speaking, the only thing that is consistent is the crashing itself.

 

Launching via bat files causes the "Java has stopped responding" message, while as launching via steam gives "Project Zomboid has stopped responding" instead. 

 

It doesnt matter what I'm doing in game, it will crash whenever it feels like. I have yet to see anyone solve the issue, and I've tried everything that seemingly fixed the issue for everyone else. 

I've never had issues with Project Zomboid before, so I find it odd that it crashes, the game itself does not suffer performance wise (unless we are talking about a hundred or so zeds), it just crashes at random intervals, and ironically enough, it crashes while its running smooth as butter (an instance where the game hard chugged and lagged like hell, didnt crash the game, but having the game run optimally causes crashes). 

 

One thing I've found out is that its not time based, when having the game paused and alt-tabbed doing some work elsewhere, the game did not crash during that timeframe. It only occurs during gameplay. Unmodded and fresh install also gave error messages while right-clicking litterally anything. Im pretty sure its not a performace linked issue, something is causing the crashes. Monitoring the game using Resource monitor shows that its using less than 30% total ram and at most 40% CPU. 

 

Edit: Managed to catch a problem marked as severe in the last console file

I really hope someone can help because my teeth are practically dust at this point, and I'm almost bald. 

 

Specs:

Lenovo G710
Intel i5-4200 2.50GHz

GPU: Nvidia Geforce 820M/ Intel HD 4600 (Dxdiag Displays this one)
Ram: 8GB
DirectX 11
Win 7 64 bit

.Net Framework Version 4.6
Java 64 bit (Latest build)

 

I reinstalled this laptop about a month ago, and all drivers are up to snuff, I've double checked and they are as up to date as they possibly can be.

console.txt

Edited by MajAngelo
Upload of console information

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

All the same, it makes it harder to know on our side when there’s mods in the logs. Some are known to put additional strain on the game and lag or crash it.

 

it could be because it’s not using the nvidia gpu. Go to the install dir, right click the 64-bit exe, and select the high-performance gpu  to launch it.

Share this post


Link to post
Share on other sites
  • 0

Could you upload the console.txt file found in " C:\Users\YourUserName\Zomboid" right after the crash? You can also upload the "logs.zip" file for further information.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

I have tried both modded and unmodded, using both the steam executable as well as both the 32 and 64 bit versions of the bat launchers. Ive ran several tries with different world settings and the challenge maps as well, both using mods and with no mods what so ever, from a fresh install, and having vertified the game files each time. The crashes persist, and even "out of the box" fresh install with no subscribed workshop items, the game still crashes. What I've experienced so far is that it seems to be unrelated to any mods, as the game crashes in the exact same manner, despite having mods, or running without any mods even downloaded via the workshop. 

Edited by MajAngelo
Grammar

Share this post


Link to post
Share on other sites
  • 0

While I wasnt able to launch the game with the higher GPU, I did find that my Nvidia control center had ceased to function. Reinstalling the Control Center and forcing the pc to use the Nvidia GPU seemingly fixed the issue. Thanks again for the help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...