Jump to content

Question

Big fan of the game, but I've been having trouble with the Steam version since before launch. It gets partway through the startup (to 'Loading Characters texturepack') and then this error loops infinitely in the background:

Nov 09, 2013 9:05:47 PM zombie.GameWindow run
SEVERE: null
java.lang.ArrayIndexOutOfBoundsException

 

This happens in Compatibility Mode as well. The latest Desura version does the same thing too.
 

Things I've tried:

 - Deletion and re-download/reinstall
 - Verified integrity of Steam game cache

 - Deletion of Zomboid folder under my user folder

 - Installed latest Java (tried 32-bit & 64-bit)

My specs:

 - Windows 8.1 64-bit (my bad on that one)
 - 3 displays (2x1080p cloned, 1x1280 spanned)
 - 8GB RAM
 - i5-3570K
 - EVGA GTX660
 - 3+ mice connected
 - 2 keyboard connected
 - Xbox wireless controller receiver connected
 - Stereo HDMI audio through video card

Let me know if there's anything other info I can provide, or things I can try.

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

That worked! Thanks very much! I assumed you meant the ProjectZomboid.bat file, in with the game files.

 

I didn't see any suggestion to do this in any of the FAQ material or other posts. I wouldn't have expected it to work outside Steam either.

 

So this means it was pointing to the wrong Java install? It looks like the game contains its own 64 and 32 bit Java installs - can't it just reference those to remove the nightmarish dependency on the client PC java setup?

Share this post


Link to post
Share on other sites

I'll admit I'm not really clear on the technical side of things, but I think if you run the .bat you have to have the right Java installed for your OS; if you're not, the ones included with the game should work... so, I'm don't really know why your game wasn't working, but it should hopefully be fixed in the future :D

Share this post


Link to post
Share on other sites

Hi KING5TON,

 

Could you please post some specs? Particularly your OS version (Windows ?) and whether you have multiple screens or mice connected.

 

I'm on Windows 7 64bit (and I'm running the 64bit version of PZ)

 

Specs are

 

GIGABYTE WindForce Radeon HD 7970 OC'd to 1Ghz

i5-3570K OC to 4.2Ghz

GIGABYTE GA-Z77X-D3H Motherboard

8GB (2x4GB) G.SKILL RipjawsX 1600MHz CL9 DDR3

750W Cooler Master GX750 80PLUS Bronze PSU

1TB Seagate Barracuda SATA III Hard Drive

120GB + 240GB Samsung SSDs

K750 solar powered keyboard

G700 wireless gaming mouse

Fractal Design Define R4 Black Case

40" 1080p Toshiba TV

Turtle beach X41 Wireless 5.1 headset.

 

Only one screen currently connected and only one mouse, I have two key boards connected though

 

 

Will try running the BAT and report back

Hi

 

Running the .bat has resolved the issue and I can now play the game.

I'll put a thread on steam in case anyone else who bought it there has the same issue.

 

Cheers

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...