Jump to content
SabitaUsagi

No textures on Player or Zombie models, OSX version[Build 41]

Recommended Posts

3 hours ago, SabitaUsagi said:

I mean honestly I was planning on a GTX 1080. Mini-ITx Board with a Ryzen 3 CPU. But i'm not planning on building a Mac so the driver issue probably won't be a factor.

I feel you man. I love my Mac and game on it all the time. Couldn’t find a better computer than that for me lol. 

Share this post


Link to post
Share on other sites

Got the rather battle-worn and scared iMac with the NVidia 650M on Friday.

 

tl;dr: I was wrong about the VRAM requirement, as at least for the 330M-750M, all these nVidias are mobile chipsets. They use memory sharing to get around the 256-512MB of RAM they have available. So that shouldn't matter so long as the system has enough RAM otherwise to run the game and the OS.

 

Still not sure what the problem is, but it looks like the base color of either the shirt or character's skin (if nude) is applied to the entire character model. There's also some flickering on the model when certain shaders are enabled.  Don't necessarily think it's a compression issue, as it seemed to work correctly for floor tiles, when enabled. 

 

So we'll have a good play with the thing over the next week or so, and see where we get. :)

Share this post


Link to post
Share on other sites
4 hours ago, EnigmaGrey said:

Got the rather battle-worn and scared iMac with the NVidia 650M on Friday.

 

tl;dr: I was wrong about the VRAM requirement, as at least for the 330M-750M, all these nVidias are mobile chipsets. They use memory sharing to get around the 256-512MB of RAM they have available. So that shouldn't matter so long as the system has enough RAM otherwise to run the game and the OS.

 

Still not sure what the problem is, but it looks like the base color of either the shirt or character's skin (if nude) is applied to the entire character model. There's also some flickering on the model when certain shaders are enabled.  Don't necessarily think it's a compression issue, as it seemed to work correctly for floor tiles, when enabled. 

 

So we'll have a good play with the thing over the next week or so, and see where we get. :)

It could just be certain color textures that seem to color the whole body, or it might be the underwear? 

Share this post


Link to post
Share on other sites
On 11/11/2019 at 8:51 AM, EnigmaGrey said:

Got the rather battle-worn and scared iMac with the NVidia 650M on Friday.

 

tl;dr: I was wrong about the VRAM requirement, as at least for the 330M-750M, all these nVidias are mobile chipsets. They use memory sharing to get around the 256-512MB of RAM they have available. So that shouldn't matter so long as the system has enough RAM otherwise to run the game and the OS.

 

Still not sure what the problem is, but it looks like the base color of either the shirt or character's skin (if nude) is applied to the entire character model. There's also some flickering on the model when certain shaders are enabled.  Don't necessarily think it's a compression issue, as it seemed to work correctly for floor tiles, when enabled. 

 

So we'll have a good play with the thing over the next week or so, and see where we get. :)


Yep, skin color if nude, t-shirt color if a t-shirt is on.
Hat's show up fine, weapon models show up fine, backpacks show up, but may also be single color. 
when you wear a jacket the jacket shows up but then the player model becomes invisible except for weapon/ backpack / hat /hair. This is the same for zeds and can be a bit unnerving. Jacket seems to have texture in that it is more than one color, but honestly i'm not sure.
I wonder if it's the shader language version? Compatibility for me on that is 1.20
Might be texture buffer or texture multisample also?

Share this post


Link to post
Share on other sites
2 hours ago, waitaminit said:

Exact same problem.
 

Mojave 10.14.6
MBP 15 inch mid 2012
2.3 GHz Intel Core i7
4 GB 1600 MHz DDR RAM
Intel HD Graphics 4000 1536 MB

I also upgraded to a 500 GB SSD when this hard disk began to fail last year.
Some discussion regarding Open GL and case sensitive file systems on this reddit thread.


Certain it’s not a nVidia variant? The Intel-only ones aren’t affected by this ( I bought several used Macs to test it).

 

As far as I can tell, there’s no way to force the 2012 to use the intel 4000 instead of the included 650m.

 

We’ve no solution as yet, aside from dual booting windows or Linux so that you don’t have to rely on Apple’s driver. This might not work due to the 512 MB of GPU ram on different uses, since memory sharing could be OSX specific.

Share this post


Link to post
Share on other sites
11 hours ago, waitaminit said:

I'm certain. The Intel HD Graphics 4000 was the integrated option for the unibody in 2012. TheLonestander has the same card without the same issue. 

Yes, without  the same issue.

 

Try this to make sure it doesn’t have the optional nVidis discrete gpu:
 

About This Mac -> System Report -> Graphics/Displays

Share this post


Link to post
Share on other sites
17 minutes ago, waitaminit said:

It appears to have both the 4000 built in and the 650M on a PCIe.

 

But "about..." only reports the 4000 In the summary.

That’s normal. It only reports the currently active gpu for some reason... So, when the game runs, it uses the 650m instead.

 

These errors are fixed outside of OSX. Apple just seems to have left it this way.

 

 

Share this post


Link to post
Share on other sites
6 minutes ago, waitaminit said:

I think you're missing a link. What are the errors so that I can report them to Apple?

 

I ended up taking it out. It doesn’t include instructions to revert the change, so not sure it’s worth it:  https://dhavaldalal.wordpress.com/2018/05/29/how-to-disable-failed-discrete-gpu-nvidia-geforce-gt-650m-for-macbook-pro-101-mid-2012-on-high-sierra-10-13-4/

 

The problem is the driver Apple released is well out of date. Apple’s not going to care.😛

Share this post


Link to post
Share on other sites
32 minutes ago, waitaminit said:

Ah, well, thanks for the help. Things like this continue to push me away from the brand.

I'll avoid the disable and look into cost-free dual boot options. Does my license for PZ work across different OS? 

Yes. It’ll be tied to your Steam or GoG account, which lets you download the game for Mac, Linux, and Windows.

Share this post


Link to post
Share on other sites
9 hours ago, waitaminit said:

Thanks again for all your help. Although it is beyond my understanding, user WestFacingBucket on reddit posted this in response to a thread regarding choosing cards based on OpenGL. I'm not sure if it is news or has any meaningful use to you--particularly being as vague as it is--but I thought I'd pass it along anyway. 

Yeah, not sure. The point of using a library like LWJGL is to avoid having to get into that, but we’ll discuss it.

 

 Thanks for the heads up! I had missed that thread.

Share this post


Link to post
Share on other sites
On 1/19/2020 at 4:52 PM, EnigmaGrey said:

 

The problem is the driver Apple released is well out of date. Apple’s not going to care.😛


So since apple is never gonna update or fix these driver issues.
Is there any chance of testing if what PZ uses for open GL can be reduced?
Or if it can be tested to switch to CORE Open GL rather than supported?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...