Jump to content

Can't change resolution

Recommended Posts

So not sure when it started, but I can't change the resolution of PZ. it can only be what my desktop is set at.  if I try to change it,  the game window closes leaving only the window  that's full of text.  when I open the game again, it's set back at my desktop resolution.


Almost the same thing happens when changing from fullscreen to windowed and vice versa.  the only difference is after i reopen PZ it will open in the choice (fullscreen or bordered) I selected .


Share this post

Link to post
Share on other sites

Make sure that your graphic drivers are up to date. You can find the latest drivers on the manufacturers website (Intel, nVidia, AMD, etc..)

Share this post

Link to post
Share on other sites

Try disabling the scaling for Project Zomboid and then try changing the resolution again, Windows could be messing with it.

Quoting EnigmaGrey:
1. If you want to get the game to scale up properly (e.g. the game is set at 1080p and you want it scaled to 4k), is to either

a) set DPI scaling to 100% in Display Settings (this applies to the entire Windows desktop)

b) disable DPI scaling for only PZ

  • Go to %ProgramFiles(x86)%\Steam\steamapps\common\ProjectZomboid.
  • Right click on each of the ProjectZomboid*.exes (red and black egg)
  • Left click Properties from the menu.
  • Under the Compatibility tab, disable DPI scaling for System (enhanced).

This will work for many applications, not just PZ.

Share this post

Link to post
Share on other sites

Ok, I managed to get it working. I tried your recommendations, but still had the same problem. so I just started farting around other windows options.


I ended up going into windows display settings/advanced display options/display adapter properties. 


Then in the window that popped up I went to the monitor tab.  the screen refresh rate was at 24 hertz under monitor settings.  (don't know why it was set at that, but it didn't seem to affect anything else besides PZ) . 


I then had to re-enable high scaling DPI override (set to application-haven't tried the other ones) as  it was doing the 'ole non full-screen full-screen where it doesn't actually use the entire screen but only a portion of it.


no crashing and resolutions now change.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...