Jump to content
Sign in to follow this  
Raymond76

[40.43] Zombies Disappear When Players In Single or MultiPlayer Login / Die

Recommended Posts

Posted (edited)

Issue with zombies disappearing. On dedicated server (Spawn point inside mall) I am noticing whenever someone logs in or dies and respawns - all zombies inside the mall disappear.  No mods.  I also notice zombies not being save in Open Hours challenge which also takes place in mall.

 

 

EDIT: Through some more testing on the dedicated - I noticed that the inside zombies despawn if a user is logging inside of the mall.  If the user is logging outside the mall the inside zombies seem to be unaffected.  The outside zombies don't seem to care either way.

 

Is it possible their is some sort of spawn / log-in protection that clears a room (aka whole mall) of zombies when you spawn in?  Is this mall specific issue?

 

------------------------------------------------------------

Dedicated MP Example:

------------------------------------------------------------

Computer 1: Linux Dedicated Server

Computer 2: Win10 Client (Admin)

Computer 3: Wind10 Client

 

Steps to Reproduce:

1: /grantadmin "YOU"

2: /teleportto 13945, 5822, 0

3: Have another person log in

4: /teleport "Them" "You"

5: Have them log off

6: /createhorde 300

7: Have them log back on

 

giphy.gif

 

------------------------------------------------------------

SP Open Hours (Me saving and continue): (PT 1 & PT 2)

------------------------------------------------------------

Computer 1: Wind10 SP

 

Reproduce Steps:

1: Create open hours game

2: Let zombies in

3: Quit to main menu

4: Continue game**

 

** I have noticed that a few times the zombies don't disappear but it seems more often then not

 

giphy-downsized-large.gif

 

giphy.gif

 

------------------------------------------------------------

Enlarged Screens:

------------------------------------------------------------

 

20190410190011_1.jpg

20190410190042_1.jpg

Edited by Raymond76
Added Steps to Reproduce

Share this post


Link to post
Share on other sites

This might explain something that happened to me as well. I thought I had a game paused and when I came back to play the game was no longer open. Now I am not sure if it crashed or I closed it while working but when I started over I was in the last place I was at before but had a time warp. No longer late afternoon but night. All things I left on the ground was reset. Weirdest thing was no zombies. Went back to the safe house and slept. When I woke up I was able to clear out a bunch of houses with no interference from zombies.

Share this post


Link to post
Share on other sites

When new user logs in his game requests a huge piece of map from server. It creates a huge load on server. When already logged in users request update from server while server is under load - update takes a bit more time than usual and entities like zombies and players will disappear until requested map will be downloaded and changes recalculated.

Share this post


Link to post
Share on other sites
Posted (edited)

Enoahe, this is not the issue.  This happens on BOTH SP and MP.  On my dedicated server I can spawn a horde of 300 and while I am still standing there I have my friend join the game and the zombies on MY game disappear before my vary eyes.  Same with loading into a new SP I can see the zombies disappear even on first game creation.  It would be useful if someone could follow the steps from my first post (literally just make a challenge game) or this one for MP and verify.  I have had 3 verifications in my own circles. My dedicated is also powerful so I don't see any of these desyncs happening especially when these tests are happening with few people

Edited by Raymond76
Acidentally words

Share this post


Link to post
Share on other sites
Posted (edited)

I updated with some gifs of what I am seeing and some new notes:

 

Through some more testing on the dedicated - I noticed that the inside zombies despawn if a user is logging inside of the mall.  If the user is logging outside the mall the inside zombies seem to be unaffected.  The outside zombies don't seem to care either way.

 

Either way everytime someone logs into the mall it becomes a zombie ghost town and those zombies never appear back.

 

Is it possible their is some sort of spawn protection that clears a house (aka whole mall) of zombies when you spawn in?  Is this mall specific issue?

 

Weird.

Edited by Raymond76
More info.

Share this post


Link to post
Share on other sites
Posted (edited)

I was able to replicate this.  Seems to be an issue with your dedicated server spawn point being set inside the mall.  If you move it outside the mall the zombies no longer despawn inside...

 

Perhaps it is coded so that when players log into buildings that have spawn points in them (or in this case an servertest.ini spawnpoint) they are cleared for spawn protection.  So in your case the whole mall gets cleared anytime new players come, or old players who logged out inside the mall log back in or someone dies.

Edited by BadHorse

Share this post


Link to post
Share on other sites
30 minutes ago, BadHorse said:

I was able to replicate this.  Seems to be an issue with your dedicated server spawn point being set inside the mall.  If you move it outside the mall the zombies no longer despawn inside...

 

Perhaps it is coded so that when players log into buildings that have spawn points in them (or in this case an servertest.ini spawnpoint) they are cleared for spawn protection.  So in your case the whole mall gets cleared anytime new players come, or old players who logged out inside the mall log back in or someone dies.

This is the intent, yes. It should only be the immediate area around the (about the size of the screen) from what I remember when it was implemented for multiplayer.

Share this post


Link to post
Share on other sites
Posted (edited)

Interesting.  Are there any settings to tweak this behavior or some way to mitigate?  I noticed if you move it to the north mall entrance it looks like the entire mall is still being cleared out.

 

I wonder if moving the spawn point to a specific enclosed room instead of the mall main hall would have any effect (can't test at the moment). 

 

I can see an interesting multiplayer experience (kind of like opening hours challenge) having spawn points at different stores of the mall but this behavior would see the mall never have any zombies.

Edited by BadHorse

Share this post


Link to post
Share on other sites

Something very similar is happening to everyone on a multiplayer server.  I've even tested this out on another random server to make sure it's not just something on the server I play on.

 

While fighting zombies, they will often just pop out of existence.  You can move around like normal but if you stay in one place, you will be attacked as though they were always there.  The don't actually pop out but become invisible for a short time (5 seconds) and then reappear as though they were always there, moving towards you or attacking if you're standing still.  This happens VERY often.

 

One minute you can be swinging at a zombie then nothing there.  If you keep swinging, they just pop back in and land a hit on you because you're swinging at air.  Not sure how they get the bite on you then.  The only way to get out of this is to literally run away until they reappear.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...