car texture
2 2

9 posts in this topic

Recommended Posts

Hello everyone! I have adored what Indie Stone has made of this game and support the linux staff! and already should know this, but here goes, I have the textures of the cars all black when they are in poor condition! I know it's not the most important! the operating system is lubuntu 18.04. continuation of good work! Can you solve , please?:x:oops:

Share this post


Link to post
Share on other sites
2 hours ago, Beard said:

Do only the cars with low condition have black textures? Are models enabled in the Settings?

If i play default settings the cars are ok, if i play with the sandbox settings and put the cars start with very low stats they all are Black.

Edited by Litio

Share this post


Link to post
Share on other sites

It seems me and my wife suffer from this bug as well, although it seems to affect all the vehicles. No combinations of steam-runtime/no runtime, 3D models on/off (with off only vehicle shadows are visible) or any other graphical options/compatibility mode (I trired switching them *all* off) helps. The same happens for me on AMD RX 580 (Mesa drivers) and my wife on Nvidia GTX 960 (proprietary Nvidia drivers) and it seems stretch to older builds as well, as the same seems to happen on stale "weather" branch (which is currently at 40.8 or something like that).

Edited by Faalagorn

Share this post


Link to post
Share on other sites

FIX:

 

1. Go to game files (In Steam client, right click game and select properties, local files tab, browse local files...)

2. Delete the "Vehicles" folder from media/textures/

3. Verify integrity of game files (same menu in Steam client as before)

 

CAUSE:

 

Upper/lower case issue with texture file names, based on console output log. It seems like the vehicle files have been changed to all lower case but in my folder they were mixed case. Steam verification wouldn't detect this but it was corrected when re-downloading the files.

 

Share this post


Link to post
Share on other sites
On 22/11/2018 at 8:58 PM, sprkng said:

FIX:

 

1. Go to game files (In Steam client, right click game and select properties, local files tab, browse local files...)

2. Delete the "Vehicles" folder from media/textures/

3. Verify integrity of game files (same menu in Steam client as before)

 

CAUSE:

 

Upper/lower case issue with texture file names, based on console output log. It seems like the vehicle files have been changed to all lower case but in my folder they were mixed case. Steam verification wouldn't detect this but it was corrected when re-downloading the files.

 

I was thinking about this issue today, really nice you nailed! Seems only people who had their game installed were affected, no matter the HW configuration (guess it'd affect mac players too), and it seems that Zomboid is yet another victim of Unix file system letter case importance! Kinda wish Steam would pay attention to it and distringuish lower/uppper casing as different files and re-download them too - at worst case would result in duplicated files taking space, but at least there'd be no "missing" files after verification.

Share this post


Link to post
Share on other sites

 

7 hours ago, EnigmaGrey said:

Just want to be sure, does @sprkng's suggestion resolve this for everyone?

 

Just want to  make sure there's not a filename mismatch we missed in the past few weeks.

Worked for me and my wife. To be on the safe side, we also re-downloaded the whole game in case there's more issues with filename casing, but just doing waht @sprkng suggested was enough to fix vehicles.

Share this post


Link to post
Share on other sites
On 11/22/2018 at 7:58 PM, sprkng said:

FIX:

 

1. Go to game files (In Steam client, right click game and select properties, local files tab, browse local files...)

2. Delete the "Vehicles" folder from media/textures/

3. Verify integrity of game files (same menu in Steam client as before)

 

CAUSE:

 

Upper/lower case issue with texture file names, based on console output log. It seems like the vehicle files have been changed to all lower case but in my folder they were mixed case. Steam verification wouldn't detect this but it was corrected when re-downloading the files.

 

it work's thank you for the help!!!!! i am with nvidia gtx 970 proprietary Nvidia drivers.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
2 2