Slow motion on Multiplayer
0

9 posts in this topic

Recommended Posts

Hi guys,

So I've been having an issue since build 40 went live on a server that I host through Nitrado.

Originally I thought it was something to do with either the server, or the fact that it was modded (ORGM), however recently i'm having the exact same problem on a single player game with no mods installed.

The problem manifests itself by slowing the character down, almost matrix style, it can be like this for 30 seconds or so before returning back to normal. I can usually play for 30-60 minutes before it starts but once it's started it doesn't matter if I exit the game or restart the server it's still there.

 

I'm not 100% sure but it seems to be when the following appears in the log:

 

COMMAND QUEUE stallCount = 0 peakUsage = 22576

 

The peakUsage number seems to get larger and larger and eventually the stallCount will change from 0 to 1.

 

This is a quick Twitch clip showing how it manifests itself:

https://clips.twitch.tv/SpineyFreezingDadFreakinStinkin

 

The server is hosted through Nitrado and has 2GB of ram, there was only me playing on it, and pre release of 40 I didn't experience any problems.

It's currently running ORGM gun mod.

I've disabled the steam overlay for the game.

 

My ProjectZomboid64.bat file is modified as follows:

@setlocal enableextensions
@cd /d "%~dp0"
SET _JAVA_OPTIONS=
SET PZ_CLASSPATH=jinput.jar;lwjgl.jar;lwjgl_util.jar;sqlite-jdbc-3.8.10.1.jar;uncommons-maths-1.2.3.jar;trove-3.0.3.jar;javacord-2.0.17-shaded.jar;guava-23.0.jar;./
".\jre64\bin\java.exe" -Dzomboid.steam=1 -Dzomboid.znetlog=1 -XX:+UseConcMarkSweepGC -XX:-CreateMinidumpOnCrash -XX:-OmitStackTraceInFastThrow -Xms4096m -Xmx4096m -Djava.library.path=./ -cp %PZ_CLASSPATH% zombie.gameStates.MainScreenState
PAUSE

 

Any suggestions please?

Kind regards

Console.txt

Share this post


Link to post
Share on other sites

I've been having the same issue for a while.

 

The bottom of this page lists fixes for the slow motion:

https://pzwiki.net/wiki/Vehicles

None of those worked for me though.

 

I had success with:

Disabling MSI Afterburner in the background (more specifically RivaTuner)

Set FPS to 55 and fiddle with VSync settings in-game. No clue why the 55FPS limit works for me, my monitor is 60HZ.

 

That's the best workaround I could suggest besides the wiki which personally didn't do anything for me. These should work for both SP and MP, though I don't play much in MP.

Edited by MadDan2013

Share this post


Link to post
Share on other sites
52 minutes ago, Chugawuga said:

Thanks for the reply MadDan2013

The strange thing is that my fps isn't dropping it's remaining at 60 even when the slowdown is occurring.

Yeah, it doesn't seem to be related to FPS, mine wasn't dropping frames either, but I'd try those suggestions and see if they work. Something different might work for you if my workaround doesn't.

 

It's annoying playing at 55FPS for sure, although sometimes I'm able to bump it up to 60FPS and play without issue.

Share this post


Link to post
Share on other sites
On 04/11/2018 at 9:44 PM, EnigmaGrey said:

Disable vysnc. Getting the impression the update forced it on for a lot of people . . . However that's possible.

 

Disabling vsync seems to have done the trick, thank you.

Managed a 2.5 hour session without any of the previous "slowdown" although screen tearing is now an issue.

Thank you for your help.

Share this post


Link to post
Share on other sites
On 04/11/2018 at 3:54 PM, MadDan2013 said:

had success with:

Disabling MSI Afterburner in the background (more specifically RivaTuner)

Set FPS to 55 and fiddle with VSync settings in-game. No clue why the 55FPS limit works for me, my monitor is 60HZ.

Thanks MadDan2013

Setting my FPS to 55 allows me to play with vsync on which in turn get's rid of the screen tearing.

Share this post


Link to post
Share on other sites
2 minutes ago, Chugawuga said:

Thanks MadDan2013

Setting my FPS to 55 allows me to play with vsync on which in turn get's rid of the screen tearing.

Glad it worked! Unfortunately, I have no idea why it does work though so I don't know if it's actually possible to be fixed so we can play at 60FPS again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0