RELEASED: IWBUMS Build 40.18
12 12

233 posts in this topic

Recommended Posts

10 hours ago, axeladalidez78 said:

I'm experiencing total freezing of the game whenever it starts to rain or when I enter a specific part of a building. The game keeps playing but the visuals are completely frozen.

When this happens, the console repeats constantly this message:

 

  Reveal hidden contents

org.lwjgl.opengl.OpenGLException: Stack underflow (1284)
    at org.lwjgl.opengl.Util.checkGLError(Util.java:59)
    at zombie.core.Core.DoEndFrameStuffFx(Core.java:2753)
    at zombie.core.textures.TextureDraw.run(TextureDraw.java:426)
    at zombie.core.SpriteRenderer$RingBuffer$StateRun.render(SpriteRenderer.java:557)
    at zombie.core.SpriteRenderer$RingBuffer.render(SpriteRenderer.java:515)
    at zombie.core.SpriteRenderer$RingBuffer.add(SpriteRenderer.java:221)
    at zombie.core.SpriteRenderer.build(SpriteRenderer.java:1086)
    at zombie.core.SpriteRenderer.postRender(SpriteRenderer.java:1157)
    at zombie.core.opengl.RenderThread$1.run(RenderThread.java:96)
    at java.lang.Thread.run(Thread.java:745)

 

 

Same here.

 

Reconnecting on my server after the update (Character on 2nd floor house while it's rainning) walking for 2 sec and the graphics freeze, game console is spamming the same message from axeladalidez78.

 

Also, I get this message on the server console :

1537055768230 STACK TRACE
1537055768231 -----------------------------------------
1537055768232 function: onClimateTick -- file: ClimateMain.lua line # 13
1537055775706 -------------------------------------------------------------
1537055775707 attempted index: onClimateTick of non-table: null
1537055775708
1537055775709 -----------------------------------------
1537055775710 STACK TRACE
1537055775711 -----------------------------------------
1537055775712 function: onClimateTick -- file: ClimateMain.lua line # 13
java.lang.RuntimeException: attempted index: onClimateTick of non-table: null
        at se.krka.kahlua.vm.KahluaThread.tableget(KahluaThread.java:1654)
        at se.krka.kahlua.vm.KahluaThread.luaMainloop(KahluaThread.java:499)
        at se.krka.kahlua.vm.KahluaThread.call(KahluaThread.java:167)
        at se.krka.kahlua.vm.KahluaThread.pcall(KahluaThread.java:1922)
        at se.krka.kahlua.vm.KahluaThread.pcallvoid(KahluaThread.java:1777)
        at se.krka.kahlua.integration.LuaCaller.pcallvoid(LuaCaller.java:67)
        at se.krka.kahlua.integration.LuaCaller.protectedCallVoid(LuaCaller.java
:130)
        at zombie.Lua.Event.trigger(Event.java:37)
        at zombie.Lua.LuaEventManager.triggerEvent(LuaEventManager.java:83)
        at zombie.iso.weather.ClimateManager.update(ClimateManager.java:544)
        at zombie.iso.IsoWorld.update(IsoWorld.java:3117)
        at zombie.gameStates.IngameState.update(IngameState.java:1360)
        at zombie.network.GameServer.main(GameServer.java:783)
1537055775729
1537055775730 -----------------------------------------
1537055775731 STACK TRACE
1537055775732 -----------------------------------------

 

This seem to be an graphic error. The game still running and I see an OpenGL (running a AMD RX580 / Drivers fully updated) error in the console. Turned off 2x texture and compression on. Can manage to move a bit more. The character still move, I can hear footsteps.

 

After some tests, creating a new char resolve the problem in the game, but whenever someone is connected that "onclimatetick" error is spaming the server console.

 

Edited by samsk
Update

Share this post


Link to post
Share on other sites
14 hours ago, axeladalidez78 said:

I'm experiencing total freezing of the game whenever it starts to rain or when I enter a specific part of a building. The game keeps playing but the visuals are completely frozen.

When this happens, the console repeats constantly this message:

 

  Reveal hidden contents

org.lwjgl.opengl.OpenGLException: Stack underflow (1284)
    at org.lwjgl.opengl.Util.checkGLError(Util.java:59)
    at zombie.core.Core.DoEndFrameStuffFx(Core.java:2753)
    at zombie.core.textures.TextureDraw.run(TextureDraw.java:426)
    at zombie.core.SpriteRenderer$RingBuffer$StateRun.render(SpriteRenderer.java:557)
    at zombie.core.SpriteRenderer$RingBuffer.render(SpriteRenderer.java:515)
    at zombie.core.SpriteRenderer$RingBuffer.add(SpriteRenderer.java:221)
    at zombie.core.SpriteRenderer.build(SpriteRenderer.java:1086)
    at zombie.core.SpriteRenderer.postRender(SpriteRenderer.java:1157)
    at zombie.core.opengl.RenderThread$1.run(RenderThread.java:96)
    at java.lang.Thread.run(Thread.java:745)

 

Had this happen once in 4 games today...  game froze, could still hear sound effects.... and after about 10-15 seconds, it would un freeze for just a moment, and then freeze again.... Got the same hundreds of errors as post above states...

 

Only thing that was really different between the one game that froze and 4 or 5 that didn't, was fog....   The one time it froze, was during fog...

 

Share this post


Link to post
Share on other sites
19 hours ago, axeladalidez78 said:

I'm experiencing total freezing of the game whenever it starts to rain or when I enter a specific part of a building. The game keeps playing but the visuals are completely frozen.

When this happens, the console repeats constantly this message:

 

  Reveal hidden contents

org.lwjgl.opengl.OpenGLException: Stack underflow (1284)
    at org.lwjgl.opengl.Util.checkGLError(Util.java:59)
    at zombie.core.Core.DoEndFrameStuffFx(Core.java:2753)
    at zombie.core.textures.TextureDraw.run(TextureDraw.java:426)
    at zombie.core.SpriteRenderer$RingBuffer$StateRun.render(SpriteRenderer.java:557)
    at zombie.core.SpriteRenderer$RingBuffer.render(SpriteRenderer.java:515)
    at zombie.core.SpriteRenderer$RingBuffer.add(SpriteRenderer.java:221)
    at zombie.core.SpriteRenderer.build(SpriteRenderer.java:1086)
    at zombie.core.SpriteRenderer.postRender(SpriteRenderer.java:1157)
    at zombie.core.opengl.RenderThread$1.run(RenderThread.java:96)
    at java.lang.Thread.run(Thread.java:745)

 

+1

Share this post


Link to post
Share on other sites
43 minutes ago, Dr_Cox1911 said:

Cars are all black for me @ Ubuntu 18.04

20180916220818_1.thumb.jpg.6c32d1b3f0697a8d4957f7a058b43076.jpg

Go to the install directory of the game, then /media/. Delete the /textures/ and /scripts/ folders.

 

Then, in Steam, right click PZ -> Properties -> Local Files -> Verify ...

 

We updated/changed the filenames a while ago. Steam just sometimes ignores it.

Share this post


Link to post
Share on other sites
On 9/17/2018 at 2:36 AM, junglistjim said:

found a way to play this version - i had to turn off all 3d models.

so i can play but it looks pants and there are no cars.

if i have any 3d models it crashes. 

on plus side weather looks awesome - just started a winter game - snow is impressive.

ha, wish I had seen this sooner - I just figured it out on my own and posted it in a thread in the bugs forum.  Poster above me there pointed out if you open the weather debug menu you can disable weather and the crashing should stop as well.

 

Now on to the reason I came to this thread, I went to the far west campground and noticed there are no cars anywhere in that whole area (rest stop and houses included).

In addition to that minor issue, At the main camp ground building (see attached pics) a wall on the second floor is missing - you can walk right through where its supposed to be.  There's also no lights on that second floor for the main room or kitchen. 

 

 

Spoiler

20180917135030_1.jpg

 

Spoiler

20180917135058_1.jpg

 

Spoiler

20180917135020_1.jpg

Edited by thejoker954

Share this post


Link to post
Share on other sites

found a couple more oddities in the far west campground.

 

The building at 5010 x 8000 the door is lockable/unlockable from both sides without a key.

 

the building at 4725 x 7990 has a window in a weird location - from the bathroom to the main hall (see attached picture)

Spoiler

20180918211846_1.jpg

 

it also seems weird that the main camp road/s (to the two ranger stations?) are dirt, but I'm assuming that's a design decision to make you have to work for such a sweet setup.

 

Edited by thejoker954

Share this post


Link to post
Share on other sites

Hi! It would be so cool if you could fix some car bugs..

1) Cars don't get any visual (!) damage at all. Cars with broken parts look like new.

2) Lights problem from page 2 of this topic. Sometimes lights are working well, but usually it's weird. Let me say it again.. In some cars when headlights are off, they look bright, like it's ON. They don's illuminate the ground ofc. Or in some cars when you turn the lights on, they stay dark like it's off, but illuminate the ground in front of car.  Taillights are always off (visually).

So.. I see that problem in the main build and in the IWBUMS.. The game kinda loses its atmosphere with these bugs =( I hope you can do something with that.

Share this post


Link to post
Share on other sites

Using cars in the game, I was surprised by the turns of the road with straight angles (on the map as well). Real roads have intersections and turns with turning radii. Smooth turns of the road will allow to cross the intersections at high speed, and not fly to the roadside while striking at the trees.
Sorry for my bad english.

Share this post


Link to post
Share on other sites

I think that a heavy car hitting speed at obstacles should not only get damaged, but also destroy obstacles such as: small trees, road lighting poles, light fences (not from wooden logs).

Share this post


Link to post
Share on other sites

VERSION 40.17 IWBUMS BETA RELEASED!

 

This should also fix the problem that people with certain graphics cards were experiencing. If you were crashing out then please give this version a go and let us know if you have any problems.

 

NEW

  • Added climate and weather MP admin panels. Many climate values can be now be ticked to override what's happening on the map. Values set by admin will override any values set by climate system, weather and mods. System also shows current weather information, and gives options to stop it. 

 

  • Rain and snow now look like they hit the ground. Rain then disappears, and snow fades out.

 

BALANCE

  • Game now displays days fresh and rotten in food tooltips in debug mode.

FIX

  • Fixed an exception when a splitscreen player joins during rain.
  • Fixed a bug in SetPlayerLocation() which caused unnecessary work to be done.
  • Fixed some tile properties in newtiledefinitions.tiles. Window frames with HoppableW/HoppableN. Wooden Bench -> Sturdy Bench. White Simple Chair -> Grey Plastic Chair
  • Fixed seahorse cafe windows with invalid smashed / glass-removed offsets
  • Fixed being able to display duplicates of some admin panels.
  • Fixed gun sounds not being heard far enough away in multiplayer. (The radius is only set to 20 in FMOD.  Setting 'distanceMax' in sounds.txt overrides the value in the .bank file. Mods will need to set this value as well.)
  • Fixed barricades not being removed when a window is destroyed by a sledgehammer.
  • Fixed players with Deaf trait hearing house alarms.
  • Fixed position of speed-controls in debug mode (which forces the clock to be visilble).
  • Added Thunder and RumbleThunder GameSounds so thunderstorm volume can be changed.
  • Fixed player not facing microwave or stove when checking its settings.
  • Fixed two bugs with spawning a random zombie in a barricaded bathroom.
  • Fixed clean/disinfect crafting tooltips saying "Destroy" rather than "Use" for bandages/rags.
  • Fixed two exceptions when pressing keys while the game is loading.
  • Fixed speed controls briefly appearing in the wrong position when starting a game.
  • Fixed zombie-population files being saved to the wrong location on Linux and Mac.
  • Fixed not being able to sleep when not tired or recently slept when the server option SleepNeeded is false.
  • Fixed being able to place multi-tile furniture where walls intersect the furniture.
  • Fixed being able to place tents on squares that are blocked by vehicles.
  • Fixed failing to check for trees when building some carpentry objects.
  • Fixed sounds playing at full volume when first loading a game.
  • Fixed learning from TV/radio when asleep
  • Fixed climatemain spam in log on server
  • Fixed celsius/fahrenheit option not being saved
  • Fixed freeze issue on certain vidcards
  • Fixed precipitation not clearly visible when zoomed

Share this post


Link to post
Share on other sites

No more freeze for me too, thanks a lot...

Now there's a graphic problem with the new corpses. When I kill a Z, its corpse is in a weird square like It was killed somewhere else (different ground).

More "Twilight Zone" than Romero.

Share this post


Link to post
Share on other sites
4 hours ago, Noncuro said:

No more freeze for me too, thanks a lot...

Now there's a graphic problem with the new corpses. When I kill a Z, its corpse is in a weird square like It was killed somewhere else (different ground).

More "Twilight Zone" than Romero.

 

Same here, everything is working nice!!  I can move again in my house while it's rainning!

Share this post


Link to post
Share on other sites

looks like when some zs are killed they change the floor tile to something else thats in the view - so a roof tile or similar, sometime vegetation.

but if you pick up their corpse the tile returns to normal.

i think a picture is easier to show - 2 dead z's turned the floor tiles to show roof tiles.

8D8F1A410E7341EC636891605D3EE8C9823DB5C5

Share this post


Link to post
Share on other sites

IWBUMS beta version 40.18 released!

 

NEW


Added new Spiffo survival guide entries about weather.


FIX


Fixed the lighting color on corpses.
Fixed a bug with the screen shader.
Fixed an old SpriteRenderer bug, not sure if it hurt anything.
Fixed appearance of selected hot/cold items in the inventory/loot windows.
Fixed food temperature possibly going above/below container temperature.
Fixed some UI layout issues with jumbo fonts.
Fixed long strings overlowing comboboxes.
Fixed some minor map bugs - light switches, doubled-up TVs, a building with no wall on second floor
Fixed using string.match (string contains) instead of stringStart for the item list.
Fixed broken chat coammds
Fixed rights for chatbox command execution
Fixed commands additem, addvehicle, teleport has additional required options -c and -u for coordinates and username stuff
Fixed chatbox not remembering last command
Fixed small bugs in survival guide

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
12 12