RELEASED: IWBUMS Build 40.18
12 12

233 posts in this topic

Recommended Posts

29 minutes ago, PapayaKing said:

I am also having another server issue. When hosting a server, it goes through all the necessary loading prompts, but gets stuck at connecting. Infinitely. I loaded for 30 minutes yesterday and nothing happened, and again the same thing. Here is the link to the text in my console.txt file https://pastebin.com/qLRXJHmU if anyone decides to look at it. Was just working fine until IWBUMS build 40. Thanks in advance. 

 

Also, the raw file if anyone prefers that 

console.txt

1

Looks like your version of the RakNet.dll might be wrong.

 

  1. java.lang.NoSuchMethodError: zombie.core.raknet.UdpEngine.access$000(Lzombie/core/raknet/UdpEngine;)Z
  2.     at zombie.core.raknet.UdpEngine$1.run(UdpEngine.java:82)
I'd try reinstalling the game just to rule out Steam screwing up the update. Right click PZ -> Properties -> Local Files -> View local files -> Delete the entire ProjectZomboid directory. Then, go back to Local Files and press the Verify button to download a fresh install.

Share this post


Link to post
Share on other sites
50 minutes ago, EnigmaGrey said:

Looks like your version of the RakNet.dll might be wrong.

 

  1. java.lang.NoSuchMethodError: zombie.core.raknet.UdpEngine.access$000(Lzombie/core/raknet/UdpEngine;)Z
  2.     at zombie.core.raknet.UdpEngine$1.run(UdpEngine.java:82)
I'd try reinstalling the game just to rule out Steam screwing up the update. Right click PZ -> Properties -> Local Files -> View local files -> Delete the entire ProjectZomboid directory. Then, go back to Local Files and press the Verify button to download a fresh install.

Re-replacing these two files like I did before when EasyPickins posted them fixed it, I was able to join properly. Are those two files the same as the two that are in the current IWBUMS version? Files are in .../zombies/core/raknet

 

I'll also try what you said to make sure that works as well.

UdpEngine$1.class

UdpEngine.class

 

EDIT: deleting everything and replacing all my saves and server settings worked as well. You would know more than I what the problem could've been, but I do suspect it was tied to those two files. Thanks Enigma.

Edited by PapayaKing
Problem Fixed

Share this post


Link to post
Share on other sites

Alright so here's what I found while doing some stuff with water bottles: the water bottle gets equipped after using the context menu to fill it at a water source, bottle gets filled, remains in main hand, upon further clicking, you can then fill the bottle infinitely with no additional weight gain from the bottle. It displays an incorrect number of units (mine is .24) until you un-equip it, which then it shows the proper units (8). Not game-breaking or hindering, but definitely confusing as you can only have one source of water in your inventory at a time to fill. Having 2+ requires you to move one bottle out of main inventory, fill first bottle, then switch the bottles, having the empty one in your main inventory and the fresh one somewhere out of the way. 

 

The car headlights are broken for me as well. As others have said, turning them on increases the cone for field of vision, but no light actually emits from the headlights.

 

Also, daylight goes on for way too long. Even in places with daylight savings, like where I live, the longest it stays BRIGHT outside is 17-18:00 (5-6PM). By 20:30 (8:30PM) it's barely light outside, and by 20:45-21:00, it's dark. That needs some adjusting as well.   

 

Here is a gif showing the issue. 

pzlight.gif

Share this post


Link to post
Share on other sites
5 hours ago, PapayaKing said:

I am also having another server issue. When hosting a server, it goes through all the necessary loading prompts, but gets stuck at connecting. Infinitely. I loaded for 30 minutes yesterday and nothing happened, and again the same thing. Here is the link to the text in my console.txt file https://pastebin.com/qLRXJHmU if anyone decides to look at it. Was just working fine until IWBUMS build 40. Thanks in advance. 

 

Also, the raw file if anyone prefers that 

console.txt

 

Did you replace those two files, from the _last_ version of IWBUMS? The steam update doesn't properly overwrite them, so you need to verify files in steam. I had this issue also.

Share this post


Link to post
Share on other sites
1 minute ago, Bejasc said:

 

Did you replace those two files, from the _last_ version of IWBUMS? The steam update doesn't properly overwrite them, so you need to verify files in steam. I had this issue also.

I did, after EnigmaGrey pointed out that my raknet version wasn't the latest version. It didn't even cross my mind to re-replace them before that, but I did also verify through steam, and both methods worked. Now it's just the stuff that was in my other posts that people were reporting earlier. 

Share this post


Link to post
Share on other sites
31 minutes ago, PapayaKing said:

I did, after EnigmaGrey pointed out that my raknet version wasn't the latest version. It didn't even cross my mind to re-replace them before that, but I did also verify through steam, and both methods worked. Now it's just the stuff that was in my other posts that people were reporting earlier. 

 

Oh wow, sorry about that. It seems I missed there being a third page!

Share this post


Link to post
Share on other sites
13 hours ago, PapayaKing said:

Alright so here's what I found while doing some stuff with water bottles: the water bottle gets equipped after using the context menu to fill it at a water source, bottle gets filled, remains in main hand, upon further clicking, you can then fill the bottle infinitely with no additional weight gain from the bottle. It displays an incorrect number of units (mine is .24) until you un-equip it, which then it shows the proper units (8). Not game-breaking or hindering, but definitely confusing as you can only have one source of water in your inventory at a time to fill. Having 2+ requires you to move one bottle out of main inventory, fill first bottle, then switch the bottles, having the empty one in your main inventory and the fresh one somewhere out of the way. 

 

The car headlights are broken for me as well. As others have said, turning them on increases the cone for field of vision, but no light actually emits from the headlights.

 

Also, daylight goes on for way too long. Even in places with daylight savings, like where I live, the longest it stays BRIGHT outside is 17-18:00 (5-6PM). By 20:30 (8:30PM) it's barely light outside, and by 20:45-21:00, it's dark. That needs some adjusting as well.   

 

 

 

The water bottle issue is a known thing and the team is working on fixing that. 

 

Regarding daylight, it'll be different for people from different countries. Where I come from summer evenings (mid-May to beginning of August) are nice and light well into evening - 9-10 pm.

Share this post


Link to post
Share on other sites

okay.. I've found more bugs with cars. Back to illumination problem I've described on page 2.. On this screen you can see broken cars but their lights have illumination textures like they are working now. And all cars visually have no damage at all.

20180901151910_1.jpg

Share this post


Link to post
Share on other sites
3 hours ago, Vincent_Ruth said:

Since new weather added to iwbums i am having delayed sound effects. Walking, hitting, opening doors. There is like half a second delay with sound. I reinstalled my sound driver. Java is up to date. Anyone got an idea why that might be?

It's been like that since I tried it, I think it's just a bug with the way sound is handled. Not sure if it's known as a bug or not already by the devs though.

Share this post


Link to post
Share on other sites
4 hours ago, icexenom said:

okay.. I've found more bugs with cars. Back to illumination problem I've described on page 2.. On this screen you can see broken cars but their lights have illumination textures like they are working now. And all cars visually have no damage at all.

20180901151910_1.jpg

damn good work brochacho

5 hours ago, Pandorea said:

 

The water bottle issue is a known thing and the team is working on fixing that. 

 

Regarding daylight, it'll be different for people from different countries. Where I come from summer evenings (mid-May to beginning of August) are nice and light well into evening - 9-10 pm.

I am well aware of daylight in other countries, which is a good point, however the game is set in rural Kentucky in the USA, where daylight doesn't go on for that long. I feel the days need to reflect that accurately.

Share this post


Link to post
Share on other sites
3 hours ago, Vincent_Ruth said:

Since new weather added to iwbums i am having delayed sound effects. Walking, hitting, opening doors. There is like half a second delay with sound. I reinstalled my sound driver. Java is up to date. Anyone got an idea why that might be?

I posted about this as well. It's most prominent when walking on wooden floors. 

Share this post


Link to post
Share on other sites

Had the same issue as PapayaKing with the server not loading. Easy way to fix the problem in Steam is to right click on the game, go to properties. Click on Local Files and hit verify integrity of game files. It will take a minute to check and tell you that one of the files is the wrong one and automatically fix it.

Edited by Cyllyn

Share this post


Link to post
Share on other sites

IWBUMS version 40.14 released

 

NEW

 

  • Optimized Items List Viewer rendering (by not drawing items that aren't visible).
  • Vehicle dashboard now displays headlight icon in red if headlights are switched on but aren't working.
  • Added tooltip for Light Fire when Notched Plank is in inventory but not the other item required for lighting a fire.

 

BALANCE

 

  • Added Packaged=TRUE to Remoulade so nutrition info is visible.
  • Renamed Disinfect Bandage recipes to Disinfect Rag for Ripped Sheets.
  • Increased the distance zombies become visible spawn in newly-seen rooms when the player is in the same building. This is to fix zombies seeming to spawn right in front of (or sometimes around) the player in the large open rooms in the Mall.

 

FIXES

  • Fixed sound delays and volume issues by rebuilding .bank files. Changed short sounds from Streaming to Compressed and longer sounds to Streaming.
  • Fixed climate net error
  • Fixed thunder sounds not triggering on client and some vars not being set properly.
  • Fixed missing raindrops
  • Fixed missing weather translation
  • Fixed Yuri's force-field on cars blocking player path to fuel cap
  • Fixed the game is freeze if the game has stopped in debugger
  • Fixed headlights providing a cone of lights even if they're off / broken.
  • Fixed empty wine bottles not being refillable with water.
  • Fixed Server Toolbox appearing underneath the top-left icons.
  • Fixed resetting fatigue, endurance, and body temperature to default unless in God Mode.
  • Fixed custom volumes for some sounds that were .bank files so they're now part of the sounds.txt file.
  • Fixed connect-to-server ui not resetting the game to singleplayer in case of error.
  • Fixed connect-to-server and xp-bonus arrows animating at high speeds at different framerates.
  • Fixed obsolete items showing in the Items List Viewer.
  • Fixed nutrition info in Food tooltips in debug mode showing when the Tooltip.Info debug option is checked.
  • Fixed potentially having more water than was available at the start when cancelling the pour-on-ground action.
  • Fixed water bottles not filling to capacity when less than 1 unit could be added.
  • Fixed vehicle brake-light texture indicating working brake lights when the battery is dead/uninstalled.
  • Fixed vehicle radial menu allowing headlights to be switched on/off when the battery is dead or missing.
  • Fixed the game unpausing after hiding the changelog UI.
  • Fixed missing vehicles_pickupvanlightsburnt.png
  • Fixed issues with vehicle horn, lights, alarm and siren when the battery is dead or uninstalled.
  • Fixed "ERROR: model texture "f_hair_White" wasn't found" on Linux and Mac.
  • Fixed NullPointerException in IsoWindow.handleAlarm().
  • Fixed player equipping an already-equipped water bottle when filling it.
  • Fixed Stone hammer not being usable when upgrading wooden walls.
  • Fixed sheet rope typo.
  • Fixed garbage-creating debug code in ZombieUpdatePacker.
  • Fixed player not being able to see nearby zombies when very tired and/or panicked.
  • Fixed frozen food spawning in freezers long after the power goes out.
  • Fixed Invisible checkbox in Admin Powers ui not setting GhostMode on the server and several other places set GhostMode=invisible.
  • Fixed gc with WorldSoundManager.getBiggestSoundZomb()
  • Fixed zombies hearing players from far away.

Share this post


Link to post
Share on other sites
5 hours ago, Batsphinx said:
  • Increased the distance zombies become visible in newly-seen rooms when the player is in the same building. This is to fix zombies seeming to spawn right in front of (or sometimes around) the player in the large open rooms in the Mall.

 

 

*Re-creates all his buildings into one room design with (tile-mode) walls instead of (iso-mode) rooms so zombies appear correctly*

 

hmm.... in retrospect, increasing the distance zombies become visible would have made more sense....  :-D

 

Share this post


Link to post
Share on other sites
5 minutes ago, Arsenal26 said:

 

*Re-creates all his buildings into one room design with (tile-mode) walls instead of (iso-mode) rooms so zombies appear correctly*

 

hmm.... in retrospect, increasing the distance zombies become visible would have made more sense....  :-D

 

This should have been "Increased the distance zombies spawn" not "Increased the distance zombies become visible".  Zombies would only spawn when the player was within 10 squares of a room, now that distance is 50 when the player is in the same building.

Share this post


Link to post
Share on other sites
1 minute ago, EasyPickins said:

This should have been "Increased the distance zombies spawn" not "Increased the distance zombies become visible".  Zombies would only spawn when the player was within 10 squares of a room, now that distance is 50 when the player is in the same building.

 

10-4...  Seemed to me that sometimes while moving thru a home, etc... even with narrow hallways, a zombie would not spawn until you entered the same room as them.... even if the room was very small like a closet/bathroom... and you were basically 1 square away (in the narrow hallway).   Anyrate, sounds like this is the fix for that (i hope)

 

Checkin it out now.... lets see if we get jumped by any phantom zombies!!!

 

Share this post


Link to post
Share on other sites

Sounds good! Definitely going to give the new beta update a try. I'd also appreciate if you guys fixed the propane torch/propane tank glitch where you can't fill empty propane torches with propane if they're empty (they need to have at least a little propane left in them). Me and my friends want to play and do some metalworking around our base. Please look into the propane thing and fix it!

Share this post


Link to post
Share on other sites
On 22.8.2018 at 4:02 PM, Batsphinx said:
  • New Chatbox. Primary features include separate chat streams (safehouse, local, global, etc), customizable chat and more intuitive usage and commands. It's hopefully a lot more convenient now.

Would you mind giving more Info on this one? How to use, customize, etc? Especially the "ChatStreams" Option in server.ini

Thanks!

Share this post


Link to post
Share on other sites

hi

build a level one wall and door.

i upgraded the doorframe to level2 and the walls to level 2. cant get through door now.

checked with a few other level 1 doors -when doorframe is upgraded to level 2 you cant get through.

think we need door upgrades as well. would look much nicer.

Share this post


Link to post
Share on other sites

Hello devs from IndieStone!

My current character survived one month already, and most of the time I've spent on gathering supplies, farming, finding a nice car and exploring the new Riverside area which I've never visited before.  Great experience,  no noticeable bugs during the playthrough, especially no cars related issues.
But, after a month I finally decided to build my base using carpentery and here I've encountered two bugs.
1) Before building my own furniture, I've decided to take some from the neighbouring houses.  The bug occured two times when I tried to move a two-tiled cabinet and a two-tiled single person bed. I remember that previously such objects were shown in the invetory in two parts of one certain object(with "1/2" and "2/2" prefix).  I had a 60% of success, and after I successeded, I only got "1/2" part, and never "2/2"(it was also not lying on the ground near by).  Not only that, but I also wasnt able to drop "1/2" part on the floor, so In order to get rid of it I needed to find a suitable container that would fit that 20 weight object. That was the only way to move it out of my inventory.
2) I've decided to build wooden walls around my house, and I was level 4 at carpentery when I've finished to build a frame perimiter. The only thing left was to make "level 2" wooden walls out the frames. Before starting doing it, I've read a "Carpentery book 3". in order to get more xp.  And aftet that, while building walls I've noticed a bug that making one "level 2 wall" out of the frame gave me around 150 XP!(I noticed that because of too frequent leveling up sound"). So I could easily get a new level with building 3 walls and using only 6 planks, which in my opinion is a balancing issue. And dont know if it matters, but I have a fast learner trait.
3) Last one, dont know if it is a bug but rain seemed to be a very rare thing during summer, and it was never heavy. During a month of in-game time it only happened two times.

Hopes this info is enough for the investigation. Good luck!

Update: (forgot to mention)
Also during a month of in-game time I havent found two items which usally apperead a bit more often:
1) Farming magazine(looked at school and book store in Riverside as well as in many postboxes)
2) Box of jars( a lot kitchens and stores, and also factory and big storage near Riverside, no luck)

Edited by maxter23323

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
12 12