GLIBCXX_3.4.21 not found - Debian 8 Server
1 1

7 posts in this topic

Recommended Posts

Currently getting a GLIBCXX_3.4.21 not found error when trying to launch the server, this is on a pretty standard debian 8.2 jessie install but after searching the net and reading all the server install guides I am not having much luck, any suggestions?

Share this post


Link to post
Share on other sites

Time for some updates...jessie 8.2 is woefully out of date (8.10 was the last jessie release)

jessie 8.10 uses libstdc++.so.6.0.20, which only has GLIBCXX_3.4.20

Updating to debian stretch will fix the issue.

Share this post


Link to post
Share on other sites
18 hours ago, Fenris_Wolf said:

Time for some updates...jessie 8.2 is woefully out of date (8.10 was the last jessie release)

jessie 8.10 uses libstdc++.so.6.0.20, which only has GLIBCXX_3.4.20

Updating to debian stretch will fix the issue.

 

Windows 7 is woefully out of date but that doesnt mean its not supported.

 

I can host ARK servers, 7D2D servers, MC servers, ECO servers which all support Debian 8, but PZ requires a complete OS update, hard to see the justification of potentially messing up my existing server network just for 1 game, its a shame too looks like PZ could really do with more servers.

 

Thanks anyways. 

Share this post


Link to post
Share on other sites

Seems little different than refusing to install the necessary updates on Windows to support MSVC++ (which does happen, from time to time). There's not much we can do in that situation, as the game has its min. dependencies and it is not feasible to rebuild them and redistribute for multiple versions of Linux. For future reference, we aim for support on Ubuntu's LTS 16.04, the same as SteamOS. 

Share this post


Link to post
Share on other sites

This does really suck as it cuts out Ubuntu 14.04 as well, which is still LTS. 

 

One workaround is to launch a docker instance running a later OS. 

Share this post


Link to post
Share on other sites

I'm having this same problem.  I guess this means CentOS 7 cannot run PZ server?

 

So if I want to setup a PZ server now and not have problems like this for awhile, I should be running Ubuntu's LTS 16.04 ?

Edited by zombo

Share this post


Link to post
Share on other sites

I have just created another server and used Debian 7 Wheezy this time. That means the OS is soooo old with no chances... or is it? =)

 

I pushed libc6 2.13-38+deb7u12 => 2.19-18+deb8u10 (you won't need it most likely, for me that was to elude dependency hell).

Then I got the freshest Jessie's libstdc++6 (4.9.2-10+deb8u1), and was stuck with the same issue: latest included is GLIBCXX_3.4.20.

But don't worry: all you have to do is to download a fresher libstdc++6 package! In my case I took one from Stretch, version 6.3.0-18+deb9u1, unpacked libstdc++.so.6.0.22, renamed it to libstdc++.so.6 and... where do I put it? In start-server.sh we have something like this:

if "${INSTDIR}/jre64/bin/java" -version > /dev/null 2>&1; then
	echo "64-bit java detected"
	export PATH="${INSTDIR}/jre64/bin:$PATH"
	export LD_LIBRARY_PATH="${INSTDIR}/linux64:${INSTDIR}/natives:${INSTDIR}:${INSTDIR}/jre64/lib/amd64:${LD_LIBRARY_PATH}"

So put the renamed sharedlib to ${INSTDIR}/linux64 (that's under dedicated server location), and it will work. At least for now. Until devs upgrade to GLIBCXX_3.4.23+.

But the leap from early 2016 to 2019 is still awesome, and old OS'es have a chance as long as you know your workarounds. Use it or don't (because that's you at fault if that goes south), it probably won't break anything because you don't install the lib, you just keep it close to your PZ server.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1 1