Vehicle IWBUMS
2 2

11 posts in this topic

Recommended Posts

vehicles-iwbums-712x462.jpg

Hey everyone – today we’re retiring our Steam vehicles beta branch and moving it into our traditional ‘I Will Back Up My Save’ beta slot as Build 39.

If you’ve been holding off from trying out our trucks, vans and cars as you were waiting for them to feel stable and (almost/increasingly) non-buggy then we’d politely ask you to consider entering the fray today.

We need an extra burst of community testers for the final patches before launch. We need to know:

  • What’s unclear about the way we’ve implemented Vehicles and the Mechanics skill
  • How the game runs on your machine. [And if there are any issues we will 100% need to know what sort of computer it is, alongside your tech specs]
  • How vehicles are changing the way you play – both in the early and late game. And, of course, whether or not you’re having fun.
  • Any bugs and weirdness that stick out like a sore thumb.

Please post feedback in the Build 39 in the new thread on our forums.

You can find the IWBUMS beta branch in your Project Zomboid – right click on Project Zomboid in the Steam games list, left click on properties and navigate to the Betas tab.

(Please note that, due to the extent of engine and gameplay changes in Build 39, existing savegames will not be compatible – a Steam beta branch of the pre-vehicles Build 38.30 will be available at the time of launch should people wish to finish off their existing games before moving onto vehicles.)

Clearly the team’s main focus is currently on getting Build 39 polished and out of the door – yesterday releasing Vehicles Build 41 that addressed issues impacting on community translations, missing car spawn zones, lots of player-crafter gate related bugs, split-screen niggles and lots of other fixes.

In the background, meanwhile, Bitbaboon Mark continues his animations work for when the team crosses over to them, Stas is polishing his new MP chat system to drop into Build 40 and Turbo is working on ‘type of sky’ game colours (the shade of the screen when its sunny, normal, cloudy etc) and should have some time-lapse vids to show next week.

image.png

This week’s ignored rest stop from Wei. A general list of stuff added to PZ, and vids of features being worked on, is kept here – so you don’t have to plough through endless dev blogs for info. The Centralized Block of Italicised Text would like to direct your attention to the PZ Wiki should you feel like editing or amending something, and the PZ Mailing List that can send blogs like this and patch notes direct to your mailbox. We also live on Twitter right hereOur Discord is open for chat and hijinks too

Share this post


Link to post
Share on other sites

Really need to separate engine works from body/wheel jobs.

It's strange that I should open the hood for changing wheels.

Just hide engine parts when we don't stand nearby the open hood.

Good job, finally it hits the IWBUMS!

Otherwise, everything works pretty good, all things that I want are planned in the future and considered by the devs.

Share this post


Link to post
Share on other sites

As I've said in previous topics, The vehicle build really adds a lot to the game :D My only suggestion now would be make it so the generator can at least hook up items right next to it (in the open, without a building or wall), allowing me to have a fridge on the go with my Franklin lol (That and let us put a generator in a seat of a car or the trunk :P), Also that and more wilderness trails  :D So much fun :) lol, All I can really say is I love it all and I can't wait for what's next :P You guys and gals are the best :)

Share this post


Link to post
Share on other sites

Edit: A wipe of the server did the trick. For those who play multiplayer, the new server config files aren't compatible and it gets stuck loading them from disk and never completely finishes. Just wipe the server presets and delete your character to be safe. It's a pain, I know, but it's the only thing that allowed me to join.

 

I've been waiting for the vehicles beta for a while. Now that it's moved to IWUBMs, I've been able to (with a worrisome-free conscience) test it out for myself, and let me say that I love it. I makes traversal much easier and adds an element of protection when being overrun. The only problem I'm having is that I cannot launch a multiplayer server through Steam for my friend to connect to. It's stuck on the "Loading World" screen for an indefinite amount of time. I had it up for about 30 minutes before I ended it the first time, and 10 minutes the second time. Also, the game doesn't close properly after having tried to launch a server, and I'm forced to close Steam and restart it. I have a feeling this could be a system-specific bug, but I would like to see if anyone is able to reproduce this. I haven't looked anywhere else for this bug, by the way, I've only posted it here. Thanks in advance.

Edited by PapayaKing
Problem fixed

Share this post


Link to post
Share on other sites

There's an issue when I try to cook food in condition of 'All fresh food in fridge, using craft menu'. When I use craft menu to cook, it automatically takes fresh ingredient out of refrigerator and immediately rot them. So eventually I cook food with rotten food.  Is this an intention to make users pre-take fresh food out of refrigerator and cook or a bug? Plz check. Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
2 2