RELEASED: IWBUMS Build 39.67.3
21 21

501 posts in this topic

Recommended Posts

IWBUMS 39.67.2


[NEW]

  • Show Dig Graves in context menu when clicking on appropriate ground tiles only.
  • Dirty Rags may be used as tinder or fuel in campfires.
  • Vehicle key is returned to the keyring it came from when removing it from the ignition.


[BALANCE]

  • Lowered default UI Render FPS to 20.                                       
  • Increased the time it takes to recharge a battery.


[BUG FIX]

  • Fixed small car's plate number being stretched.
  • Fixed flat building roofs being hidden when the player was obscured by player-built floors.
  • Fixed roof on lot_house_small_36.tbx.
  • Fixed a missing wall in a house near 13814,4682.
  • Fixed trunk capacity not always updating when it should on the client.
  • Fixed wrong end of a vehicle taking damage after a collision in multiplayer sometimes.
  • Fixed DropOffWhiteListAfterDeath only working for accesslevel that isn't "none" (reverse of what was intented)
  • Fixed being able to use car battery charger outside while there is electricity (you need to be a in a building now).

Share this post


Link to post
Share on other sites
6 hours ago, Vaileasys said:

ESC definitely works. Whether it be in a vehicle, out of a vehicle, reading, transferring items, with the engine on, with the engine off. 
E or any other key isn't suppose to cancel the action. The "Cancel Action" key can be changed in Options > Key Bindings > Player Control > Cancel Action.

I think it might be an idea to add either E, W or SPACEBAR to cancel an action as well, as I'm aware pressing ESC in a frantic situation may not be the first key you think of.

 

Sorry, I'll try again tonight.. like you said, I was frantic at the time because I had turned my view away from the screen and next thing I knew a zombie was there scratching me. 

Share this post


Link to post
Share on other sites
Posted (edited)

It's very nice to have a way to recharge batteries now even though it would have been even better if we could've done it with another car but it's okay like that.

 

There is a bug (not a new one) with how batteries decharge themselves, it has been 6 months IG (not talking about 6 months challenge) and the new cars I discover (where I didn't go before) have dead batteries (0% charged) all of them, but the ones I discovered the first day are 60% charged or at worse 50%, so the new cars I find should be at 50-60% too not 0% or all cars I didn't use since the first day should be at 0%

Edited by Axezombie

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Axezombie said:

 

There is a bug (not a new one) with how batteries decharge themselves, it has been 6 months IG (not talking about 6 months challenge) and the new cars I discover (where I didn't go before) have dead batteries (0% charged) all of them, but the ones I discovered the first day are 60% charged or at worse 50%, so the new cars I find should be at 50-60% too not 0% or all cars I didn't use since the first day should be at 0%


Pretty sure that's not a bug, it's probably intended to be like that. Just like real life, if you don't use a (car) battery it'll degrade/discharge over time and eventually go flat on its own (although 6 months is very quick for your standard alkaline battery, but it's a game).  (see EnigmaGrey's post below)

Mentioning that, I'm wondering if making gasoline degrade over time should be added or not.
 

2 hours ago, Axezombie said:

It's very nice to have a way to recharge batteries now even though it would have been even better if we could've done it with another car but it's okay like that.

 

This is probably still planned. I think I remember RJ talking about it in discord the day vehicles were released. It might be more of a 'proof of concept' sort of thing for now.

Edited by Vaileasys
Strikethrough false statements

Share this post


Link to post
Share on other sites
2 hours ago, Vaileasys said:


Pretty sure that's not a bug, it's probably intended to be like that. Just like real life, if you don't use a (car) battery it'll degrade/discharge over time and eventually go flat on its own (although 6 months is very quick for your standard alkaline battery, but it's a game). 

Mentioning that, I'm wondering if making gasoline degrade over time should be added or not.
 

 

This is probably still planned. I think I remember RJ talking about it in discord the day vehicles were released. It might be more of a 'proof of concept' sort of thing for now.

Edit:

 

Nevermind, it seems to be have been added back in IWBUMS . . . 

 

Back to the "This isn't realistic, as most car batteries can hold a charge for 12+ months. It's also rather annoying, given how few cars are in six months later."

 

We also need to re-balance generator fuel if this is going to remain a "thing." They should last around 12 hours on a single tank, not the current six.  And, tbh, with the finite nature of fuel at the pumps, that should probably be increased to a day. They're fairly tedious to use.

Share this post


Link to post
Share on other sites
Quote

Pretty sure that's not a bug, it's probably intended to be like that. Just like real life, if you don't use a (car) battery it'll degrade/discharge over time and eventually go flat on its own (although 6 months is very quick for your standard alkaline battery, but it's a game). 

I think you didn't understand what I mean, let's take an example :

day 1 I find a car in Riverside with a battery 100% charged, I let it like that I don't start the engine, I don't use the lights... Let's say there is another identical car's battery in Muldraugh but I've never went there. 6 months later I go back to the car in Riverside and its battery is 60% charged, ok normal, in 6 months car's battrey lost 40%. Now I go to Muldraugh for the first time and I see the car I mentionned before, this car's battery should be at the same level as the one in Riverside, right? Well no, it's 0% charged because I never went there before and it's the same thing for ALL CARS not being discovered since day 1

 

Quote

@Axezombiecould you try deleting your /zombie/ and /media/lua folders in %ProgramFiles(x86)%\Steam\steamapps\common\ProjectZomboid and re-validating the game in Steam? To re-validate, right cilck PZ in the Steam games list, go to Properties, and then Local Files. Press the Verify button.

 Ah sorry I thought it has been fixed but I wasn't sure, I'm going to try that and tell you how it went.

Share this post


Link to post
Share on other sites
1 minute ago, Axezombie said:

I think you didn't understand what I mean, let's take an example :

day 1 I find a car in Riverside with a battery 100% charged, I let it like that I don't start the engine, I don't use the lights... Let's say there is another identical car's battery in Muldraugh but I've never went there. 6 months later I go back to the car in Riverside and its battery is 60% charged, ok normal, in 6 months car's battrey lost 40%. Now I go to Muldraugh for the first time and I see the car I mentionned before, this car's battery should be at the same level as the one in Riverside, right? Well no, it's 0% charged because I never went there before and it's the same thing for ALL CARS not being discovered since day 1

 

 Ah sorry I thought it has been fixed but I wasn't sure, I'm going to try that and tell you how it went.

Edited it above. tl;dr: it seems to have been added back with this build.

Share this post


Link to post
Share on other sites
36 minutes ago, EnigmaGrey said:

Back to the "This isn't realistic, as most car batteries can hold a charge for 12+ months. It's also rather annoying, given how few cars are in six months later."


I get ya. I can't say I'm on either side of whether batteries and gas should be degradable or not, I understand that it's a game and balance and enjoyment are more important than 'realism'. I just figured that might be the case with car batteries based on my interpretation of what Axezombie had said.

Cheers for letting me know that about batteries anyway. At least that won't be added into the Wiki. ^_^

Share this post


Link to post
Share on other sites

@EnigmaGrey, I tried and it didn't work, new cars discovered have dead batteries but maybe it's supposed to be like that and the ones I found day 1 should be dead too

Share this post


Link to post
Share on other sites

Linux 64bit dedicated server won't work for me.

The error I get upon trying to start the server:

OpenJDK 64-Bit Server VM warning: You have loaded library /home/.../serverfiles/natives/libPZBullet64.so which might have disabled stack guard. The VM wil$
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/.../serverfiles/natives/libPZBullet64.so: /home/.../serverfiles/natives/libPZBullet64.$
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1965)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1890)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1880)
        at java.lang.Runtime.loadLibrary0(Runtime.java:849)
        at java.lang.System.loadLibrary(System.java:1088)
        at zombie.core.physics.Bullet.init(Bullet.java:38)
        at zombie.network.GameServer.main(GameServer.java:309)

Tried to validate and a complete reinstall. The normal vehicle build in the stable branch works fine for me, but IWBUMS not.

Share this post


Link to post
Share on other sites
44 minutes ago, Dr_Cox1911 said:

Linux 64bit dedicated server won't work for me.

The error I get upon trying to start the server:


OpenJDK 64-Bit Server VM warning: You have loaded library /home/.../serverfiles/natives/libPZBullet64.so which might have disabled stack guard. The VM wil$
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/.../serverfiles/natives/libPZBullet64.so: /home/.../serverfiles/natives/libPZBullet64.$
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1965)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1890)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1880)
        at java.lang.Runtime.loadLibrary0(Runtime.java:849)
        at java.lang.System.loadLibrary(System.java:1088)
        at zombie.core.physics.Bullet.init(Bullet.java:38)
        at zombie.network.GameServer.main(GameServer.java:309)

Tried to validate and a complete reinstall. The normal vehicle build in the stable branch works fine for me, but IWBUMS not.

Rename natives/libPZBullet64.so/libPZBulletNoOpenGL64.so to natives/libPZBullet64.so.

Share this post


Link to post
Share on other sites
13 minutes ago, EasyPickins said:

Rename natives/libPZBullet64.so/libPZBulletNoOpenGL64.so to natives/libPZBullet64.so.

Works now! Thanks (clyde)

 

Is this something that went wrong on my end?

Share this post


Link to post
Share on other sites
1 minute ago, Dr_Cox1911 said:

Works now! Thanks (clyde)

 

Is this something that went wrong on my end?

No, the Steam upload script put the file into a folder called libPZBullet64.so instead of renaming it.

Share this post


Link to post
Share on other sites

IWBUMS 39.67.3

 

NEW

  • Added better support for large fonts.
  • Replaced the placeholder car battery charger.
  • Added missing mechanic profession icon.


BALANCE

  • Decreased the consumption of fuel by generator.
  • Lowered the impact of timeSinceApo sandbox & world hour age on spawning car battery.
  • Increased a tad the number of cars spawning on Low sandbox setting.
  • Increased the spawn rate of remote control.
  • Increased the odds to find an animal with trapping.


FIXES

  • Fixed client not updating vehicle stats when part condition changes.
  • Fixed Linux server failure with libPZBulletNoOpenGL*.so
  • Fixed text such as "The door is blocked." being visible above other player's heads in splitscreen.
  • Fixed translation for "You failed to produce any usable materials" not being used.
  • Fixed words not appearing above the player's head when trying to open barricaded or blocked doors.
  • Fixed C/F/R keys activating if identical to the "Toggle Crafting UI" key when displaying the crafting ui.
  • Fixed crafting UI appearing in the main menu if the assigned key is pressed.
  • Fixed VehicleManager error when more than 64 players are connected.
  • Fixed error compiling ProjectZomboid.exe with UNICODE defined.
  • Fixed both halves of a grave not being destroyed when using a sledgehammer.
  • Fixed pathfinding (and other) data not being updated when remote clients added objects to the map.
  • Fixed not being able to climb through carpentry window frames above ground level by holding the E key for half a second.
  • Fixed not being able to hop over fences using the controller B button above ground level.
  • Fixed not being able to climb down sheetropes when tapping the 'E' key.
  • Fixed remote players juddering up and down while climbing sheetropes.
  • Fixed display not updating when climbing sheetropes.
  • Fixed player not facing fence/window when adding/removing sheetropes.
  • Fixed controller context menu missing commands to climb over and add/remove sheetropes to fences.
  • Fixed double-tile carpentry objects (like Bed) not consuming materials.

Share this post


Link to post
Share on other sites
On 08/06/2018 at 4:22 PM, Axezombie said:

@EnigmaGrey, I tried and it didn't work, new cars discovered have dead batteries but maybe it's supposed to be like that and the ones I found day 1 should be dead too

@Axezombie: I think I have read somewhere that batteries should be dead after 6 month, just can't remember where, so, I suppose that there is a "degradable" variable (function, thing, don't know ^^) that does not match the "6 month=dead batterie variable" but more longer (I think)

As if you find a car after the 6 month, a variable tell the batterie to be dead on that find car, but if you find one before the 6 month, the "degradable variable" turn on and prevent the other variable ("6 month=dead batterie variable") to start on that car, resulting of batteries during more longer and do not being magically dead after 6 month (like if you have 50% batterie on 5 month 30 day and the day after, 6 month, batteries is dead because of a variable overwrite the other)

So, I personnally like the idea of keeping the batterie on the car I use the more time I can, even if after 6 month all other car have dead batteries (I use mine, so it must work more longer, dynamo-reloading keep my batterie alive ^^) but I understand that you want your neighbor's car have a dead batterie 'cause he has never start his car in 6 month (and you don't too)

So, maybe creating a new line (variable, function,..., something) that applied the "6 month=dead batterie variable" on never start car (even if we find that one the first day of gameplay) 

Or maybe look into the degradable time of batteries to match the 6 month (but I think it's harder, 'cause of car start, usage, have lights on,...etc... or not)

and sorry for poor english, I try to being understand ;P

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/7/2018 at 3:24 AM, EnigmaGrey said:

You press ESC, as far as I know.

Ow, I feel stupid - yep, ESC definitely stops your reading activity...

 

Thanks EG, appreciate you pointing this out!

 

Shin

Edited by Shinjitsu noDeshi

Share this post


Link to post
Share on other sites

About the batteries in 6 months after the apo:

 

What's taking in calcul is the time since apocalypse sandbox option + the world age hour, what I first did was close to the reality, I had to change the battery on my car 2 times 'cause i didn't used, it last approx 5-6months if I don't start it, so that's what I did in PZ.

 

Now thing being: even if i have an old car, there's much more electronics in it than back then, so battery should be drained faster (imo... i'm far from being an expert on car.. Heck i had my driving licence at 30 :D) but also it wasn't that fun (even tho, i think 6 months after apo should be tough, not giving the player cars easily in this mode, it's meant to be hard...).

 

After 39.67.3, you should approx have 50% chance of finding a working battery on a car, even if the car is trash, you could always take off the battery and put it on another car.

If people find this too easy i'll lower it again (before it was like 5% chance of finding a working battery in 6 months after the apocalypse :D), remember you have a car battery charger now :)

 

I'll add possibility to start the car via jump cable in the future (tough to decide what to do if you drive the car with cable attached etc... Not a high prio for now I think)

Share this post


Link to post
Share on other sites

Jumper cables don't need to be a physical thing that attaches both cars together. They can just be an object in the player's inventory.


Park your car in front of the car needing a jump, facing it.

Leave the car running

Stand between the two cars with jumper cables in inventory.

Press the V key

Click the "Jump Start" action

The car with the dead battery starts and runs.

Battery charges over time.

 

Not overly realistic, but I don't think we need to be in this case.

Share this post


Link to post
Share on other sites

will cars burn/explode at some point? 

found a flame trap - chucked it at car - but it didnt burn  (unlike the house next to it which went up like a match)

 

Share this post


Link to post
Share on other sites

IWBUMS 39.67.5

 

NEW

  • Added better support for large fonts.
  • Replaced the placeholder car battery charger.

BALANCE

  • Decreased the consumption of fuel by generator.
  • Lowered the impact of timeSinceApo sandbox & world hour age on spawning car battery.
  • Increased a tad the number of cars spawning on Low sandbox setting.
  • Increased the spawn rate of remote control.
  • Increased the odds to find an animal with trapping.

FIXES

  • Fixed client not updating vehicle stats when part condition changes.
  • Fixed Linux server failure with libPZBulletNoOpenGL*.so
  • Fixed text such as "The door is blocked." being visible above other player's heads in splitscreen.
  • Fixed translation for "You failed to produce any usable materials" not being used.
  • Fixed words not appearing above the player's head when trying to open barricaded or blocked doors.
  • Fixed C/F/R keys activating if identical to the "Toggle Crafting UI" key when displaying the crafting ui.
  • Fixed crafting UI appearing in the main menu if the assigned key is pressed.
  • Fixed VehicleManager error when more than 64 players are connected.
  • Fixed error compiling ProjectZomboid.exe with UNICODE defined.
  • Fixed both halves of a grave not being destroyed when using a sledgehammer.
  • Fixed pathfinding (and other) data not being updated when remote clients added objects to the map.
  • Fixed not being able to climb through carpentry window frames above ground level by holding the E key for half a second.
  • Fixed not being able to hop over fences using the controller B button above ground level.
  • Fixed not being able to climb down sheetropes when tapping the 'E' key.
  • Fixed remote players juddering up and down while climbing sheetropes.
  • Fixed display not updating when climbing sheetropes.
  • Fixed player not facing fence/window when adding/removing sheetropes.
  • Fixed controller context menu missing commands to climb over and add/remove sheetropes to fences.
  • Fixed double-tile carpentry objects (like Bed) not consuming materials.
  • Fixed scrollbars not working in the options ui when a controller was active.
  • Fixed using the controller A-button on a vehicle hood not opening the mechanics ui.
  • Fixed aspects of many UIs to handle different font sizes.
  • Fixed font-rendering bug from last January.
  • Fixed ui not updating when an error occurs setting vsync.

Share this post


Link to post
Share on other sites

Performance is great, but when i drive nearby zeds (more than 10) game became really laggy

Do you think about more zeds optimization?

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, B33ware said:

Performance is great, but when i drive nearby zeds (more than 10) game became really laggy

Do you think about more zeds optimization?

 

Yep seeing that too.

 

There is some weird stuff too, like hitting some invisible on the road thing and it launches your car up in the air, even lands on it's side. Looking later at damage on car, it's not even significant.

 

Zombies also disappear, like all of them on the screen (thought this was fixed)

 

I have also found, when driving with a friend (2 cars going down the road), sometimes the other car disappears or crashes into a tree. You sit waiting for the person to recover and next thing, that car comes back from the direction you were going, as if him hitting tree never happened (when I ask, did you hit tree, they say no)
 

It would be nice too if the car volume setting including a car horn volume. When you are playing at 2am and you use the horn you can wake everyone up. LOL! Sure I can wear headphones but then that eliminates using my 5.1 digital speakers. And headphones it can be deafening as well.

Edited by Flukey

Share this post


Link to post
Share on other sites
9 hours ago, RobertJohnson said:

Decreased the consumption of fuel by generator.

what is the maximum and minimum parameter for GeneratorFuelConsumption

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
21 21