RELEASED - Build 38.28
5 5

46 posts in this topic

Recommended Posts

This is the long awaited final release of build 38, a huge amount of bug fixes to increase the stability and quality of the game, which suffered due to our issues maintaining two public test versions - barring any serious issues, we will be moving on to the vehicle build completely.  This will be the end of having multiple public test branches, we thank everyone for their patience for this difficult build, and we're now onto greater things! 

 

WARNING: Due to necessary fixes to the server, it may not be compatible with previous versions. You can get it working by deleting map_meta.bin and map_zone.bin.

 

GOG version has been uploaded and should be released soon as soon as they are approved.

 

For full 38 feature changelist including what was already released, see here

 

[FEATURE] Bandages created from bloody clothing taken from Zombies, now have a small chance of causing player to become infected, if it has not been properly cleaned before being applied.
[FEATURE] Reimplemented flies buzzing near corpses.  Added flies volume Audio option.

[BALANCE] Clothes are now more likely to be bloody when coming from a zombie.
[BALANCE] Increased places where Hunting Knife can spawn.

[FIX] Removed lowest lighting option due to no performance difference between Low and Lowest.
[FIX] Converted server option WorldItemRemovalExlusionList to WorldItemRemovalList effectively changig it from a whitelist to a blacklist.
[FIX] Added obsolete tag to certain items.
[FIX] Fixed lua error picking up furniture affecting players at random. (Issues 516, 1209, 1219)
[FIX] Fixed VOIP memory usage merge glitch.
[FIX] Fixed eat sound playing when drinking HotDrink item. (Issue 1220)
[FIX] Disabled corpse sickness challenges 1/2/4/5.
[FIX] Fixed Cooking Pot with Water not heating up. (Issue 1160)
[FIX] Fixed bugs when displayName was different than username.
[FIX] Fixed teleporting splitscreen players.
[FIX] Fixed ISTextBox controller focus bug when clicking a button with the mouse.
[FIX] Fixed displayName being "Bob" for new players.
[FIX] If player is over max capcity, planks will be dropped on floor when unbarricading.
[FIX] Fixed Ctrl+A over collapsed inventory window prevents movement. (Issue 1164)
[FIX] Fixed "User Panel" "Admin Panel" etc button alignment
[FIX] Fixed IsoGridSquare.discard() not resetting haveElectricity / haveSheetRope.
[FIX] Fixed microwave looping sound not stopping sometimes in multiplayer.
[FIX] Fixed microwave timer sync in multiplayer.
[FIX] Fixed microwave sound not playing after loading a savegame if the microwave was already on.
[FIX] load() isn't called on the main thread so it shouldn't be trying to play audio.
[FIX] Typo Highlited -> Highlighted
[FIX] Fixed ZombieUpdatePacker exception. Seen when client was disconnecting.
[FIX] Fixed generators not marking squares as having electricty sometimes. When chunks near generators were loaded after the generator, squares on those chunks weren't getting the haveElectricty flag set.
[FIX] Fixed /card and /roll client command bugs with accessLevel.
[FIX] Fixed lua exception after disconnecting from server with accessLevel != none.
[FIX] Use equals() instead of startsWith() when checking server command names. (Issue 1168). Also changed handleClientCommand() to use the same argument-parsing code as handleServerCommand() (so quotes are optional in /changepwd).
[FIX] Fixed incorrect assert in ServerMap.init()
[FIX] Fixed server NullPointerException with ThunderStorm and zombified player.
[FIX] Fixed lua error after removing all entries from the server list. (Issue 1171)
[FIX] Fixed door locking/unlocking with keys in multiplayer. (Issue 1154)
[FIX] syncIsoObjectSend() was getting called before this.lockedByKey was changed.
[FIX] Fixed "NullPointer in BodyDamage breaks save"
[FIX] Corpses not being removed in mp
[FIX] lua error when selecting "spawn next to player X"
[FIX] Fixed sterilize bandages all only sterilizing one bandage
[FIX] Fixed no spawnpoint screen, new game loads current savefile.
[FIX] Fixed GameClient.ServerSpawnRegions not being cleared after disconnecting.
[FIX] Added WorldSelect UI to choose from multiple disjoint groups of maps.
[FIX] The new "SELECT WORLD" UI is displayed when there are enabled map mods whose maps don't join the game's (i.e., stand-alone maps).
[FIX] The new MapGroups class is responsible for putting each disjoint set of maps into a MapGroup.  It also has methods for reporting map-overlap conflicts.
[FIX] ModOrderUI now only displays maps with conflicts to reduce confusion to the user.  It is still possible for the number of conflicts listed to extend off the bottom of the ui, it needs fixing.
[FIX] Removed references to obsolete WorldScreen (now it's LoadGameScreen).
[FIX] Removed obsolete LastStandChallengeSelect.lua
[FIX] Removed West Point from the "Add an available map" combobox in the server-settings editor.
[FIX] Fixed default server spawnregions not including Riverside and Rosewood.
[FIX] ServerSettingsScreen do-nothing Lua fix.
[FIX] UI tweaks in MapSpawnSelect
[FIX] Fixed adding incorrect map coordinates in the Server Settings spawnpoint file editor.
[FIX] Fixed lua errors when adding mods and maps by name in the Server Settings editor.
[FIX] Fixed custom spawn regions not displaying in the Select Spawn Location screen
[FIX] The name of a spawn region was being treated as a map folder name, which isn't always the case, it's simply a human-readable label.
[FIX] Fixed setaccesslevel from server console/rcon not updating database.
[FIX] TYPO: Changed instances of "god mod" to "god mode"
[FIX] Fixed broken weapons sometimes not being marked broken after combat. (Issue 1206) This could happen with 2 hits in the same swing.
[FIX] Fixed allowing stacked crates to exceed wall height with 2x. (Issue 1208)
[FIX] Fixed IsoStove constructor adding to IsoCell.ProcessIsoObjects.
[FIX] GrabItemAction calls InventoryItem:setWorldItem(nil)
[FIX] Fixed some AlarmClock and rain-collecting-item issues.
[FIX] Fixed stopping an AlarmClock not being synced in mp.
[FIX] Fixed AlarmClock settings not changing on the server, only the clients.
[FIX] Fixed fridge/freezer works when moved outside a room before hydro shuts off. (Issue 1204)
[FIX] Dismantling a radio/walkie-talkie returns the battery and headphones. (Issue 1202)
[FIX] Fixed stash system modifying buildings after they had been visited.
[FIX] Fixed stash system not being reset after exiting a game and starting another.
[FIX] Fixed stash system exception exiting mp game after playing a sp game.
[FIX] Fixed non-working light in MP for other players after moving indoor or outdoor lamp.
[FIX] Fixed LightingJNI exception during startup before ChunkMap was created.
[FIX] Fixed IsoMetaChunk.removeZone() not removing reference to the removed zone.
[FIX] Fixed errors with Pasta created from a spice.
[FIX] Don't display savefile name in spawn-point ui in splitscreen.
[FIX] Pasta/Rice recipes not allowing any more items when creating the initial item from a spice.
[FIX] Fixed "Gode Mode" typo
[FIX] Use translated names when radio broadcasts increase a skill. (Issue 1118)
[FIX] Made perk columns as wide as needed in the Player Stats admin panel. (Issue 1147)
[FIX] Fixed spawn-with-player spawnpoints not working in splitscreen.
[FIX] Fixed ISTextBox bug with controller that broken splitscreen. (Issue 1106)
[FIX] Fixed lua error using the mousewheel to scroll through containers when the current container isn't in the list.
[FIX] Fixed position of two tickboxes in the options screen at 1280x720.
[FIX] Fixed corpses sometimes stay highlighted (again).
[FIX] Optimized rendering the inventory windows to reduce garbage creation.
[FIX] The load-game screen displays an indicator next to dead-player savefiles.
[FIX] Fixed "Continue" button showing the new-game screen for dead-player savefiles.
[FIX] Fixed not being able to enter a savefile name when there is only one spawn region.
[FIX] Fixed map screen not showing up when map is in the Loot Window.
[FIX] Fixed infinite icecream bug

[MODDING] OnZombieUpdate now triggers serverside, as well as clientside.

Share this post


Link to post
Share on other sites

We updated our server and now literally no one can connect. BIG ISSUE. We even tried deleting map_meta.bin and map_zone.bin with no luck. 

 

 

Console looks normal enough

 

1510847867202 znet: Connection closed: reason=1 port=1
1510847867202 znet: Disconnecting client #0 SteamID********

 

Edited out steam ID and what not. 

 

 

 

 

Client Console.... where it stops...

 

java.nio.BufferUnderflowException
    at java.nio.Buffer.nextGetIndex(Buffer.java:506)
    at java.nio.HeapByteBuffer.getInt(HeapByteBuffer.java:361)
    at zombie.iso.IsoMetaGrid.load(IsoMetaGrid.java:655)
    at zombie.iso.IsoWorld.init(IsoWorld.java:1618)
    at zombie.gameStates.GameLoadingState$1.runInner(GameLoadingState.java:248)
    at zombie.gameStates.GameLoadingState$1.run(GameLoadingState.java:223)
    at java.lang.Thread.run(Thread.java:745)

 

 

 

Edited by FinestHops

Share this post


Link to post
Share on other sites
22 minutes ago, FinestHops said:

We updated our server and now literally no one can connect. BIG ISSUE. We even tried deleting map_meta.bin and map_zone.bin with no luck. 

 

 

Console looks normal enough

 

1510847867202 znet: Connection closed: reason=1 port=1
1510847867202 znet: Disconnecting client #0 SteamID********

 

Edited out steam ID and what not. 

 

 

 

 

Client Console.... where it stops...

 

java.nio.BufferUnderflowException
    at java.nio.Buffer.nextGetIndex(Buffer.java:506)
    at java.nio.HeapByteBuffer.getInt(HeapByteBuffer.java:361)
    at zombie.iso.IsoMetaGrid.load(IsoMetaGrid.java:655)
    at zombie.iso.IsoWorld.init(IsoWorld.java:1618)
    at zombie.gameStates.GameLoadingState$1.runInner(GameLoadingState.java:248)
    at zombie.gameStates.GameLoadingState$1.run(GameLoadingState.java:223)
    at java.lang.Thread.run(Thread.java:745)

 

 

 

You're sure you deleted the files in the right folder?

Share this post


Link to post
Share on other sites

Positive. 

 

C:\Users\Project Zomboid\Zomboid\Saves\Multiplayer\NewDawn

 

 

Those files are only located in a certain location on the server.  Unless he means deleting those files locally aslo/instead. 

Share this post


Link to post
Share on other sites
2 minutes ago, FinestHops said:

Positive. 

 

C:\Users\Project Zomboid\Zomboid\Saves\Multiplayer\NewDawn

 

 

Those files are only located in a certain location on the server.  Unless he means deleting those files locally aslo/instead. 

Shouldn't be necessary, but can't hurt.

Share this post


Link to post
Share on other sites

Server log is showing a server overflow when i am disconnected as well...

 

java.nio.BufferOverflowException
    at java.nio.Buffer.nextPutIndex(Buffer.java:527)
    at java.nio.HeapByteBuffer.putInt(HeapByteBuffer.java:372)
    at zombie.iso.IsoMetaGrid.savePart(IsoMetaGrid.java:546)
    at zombie.network.GameServer.receiveRequestData(GameServer.java:6239)
    at zombie.network.GameServer.mainLoopDealWithNetData(GameServer.java:2323)
    at zombie.network.GameServer.main(GameServer.java:749)
1510850679834 znet: Connection closed: reason=1 port=1
1510850679834 znet: Disconnecting client #0 SteamID=76561198004696255
1510850679834 [VOICE MANAGER] VoiceConnectClose uuid=1004306522815004367
1510850679834 znet: Java_zombie_core_raknet_RakVoice_CloseVoiceChannel
1510850682883 znet: Finally disconnected client 76561198004696255
 

Share this post


Link to post
Share on other sites
2 minutes ago, FinestHops said:

 

yes

I don't really have any other solution, unfortunately. For me, it was simply deleting those two files with the server shut down. It then let me connect fine.

 

Can you check if the update altered your startup script, pointing it to a different save? 

Share this post


Link to post
Share on other sites

I checked and out start server bat has not been altered. I manually copy over the dedicated server files and that is the one I do not copy over. 

 

I dont have anything to suggest its a mod causing an issue either. Looking through the console and I do not see anything really different or causing a cause for concern either. 

 

going to uninstall the dedicated server files from steam and reinstall them and copy them over.... see if that helps anything i suppose

 

Share this post


Link to post
Share on other sites

Just to be sure, there are two files: map_zone and map_meta. You don't want either of them.

 

If it still doesn't work, grab the server_console.txt from the Zomboid dir and attach it to your reply (or DM me with it).

Share this post


Link to post
Share on other sites

Yup.... i uninstalled and reinstalled the dedicated server files... copied them over again and now I get a game version mis-match.... so progress. 

 

Re-installing my game...

 

Updating mods since a bunch just updated...

 

initializing map....

 

same message. Unexpected error. I also just verified that even after a restart, there is no map_meta.bin or map_zone.bin in the save folder of the server.... this is getting a bit frustrating... 

Share this post


Link to post
Share on other sites

local console log.....

 

Could the removal of the file have caused this maybe?

 

1510852240667 ERROR: invalid room ID #40 in cell 45,15 while reading map_meta.bin
1510852240669 ERROR: invalid room ID #1466979188 in cell 45,15 while reading map_meta.bin
1510852240670 ERROR: invalid room ID #1749901680 in cell 45,15 while reading map_meta.bin
1510852240671 ERROR: invalid room ID #2983424 in cell 45,15 while reading map_meta.bin
1510852240672 ERROR: invalid room ID #-1627384510 in cell 45,15 while reading map_meta.bin
1510852240672 ERROR: invalid room ID #1818848867 in cell 45,15 while reading map_meta.bin
1510852240672 ERROR: invalid room ID #1818848851 in cell 45,15 while reading map_meta.bin
java.nio.BufferUnderflowException
    at java.nio.Buffer.nextGetIndex(Buffer.java:506)
    at java.nio.HeapByteBuffer.getInt(HeapByteBuffer.java:361)
    at zombie.iso.IsoMetaGrid.load(IsoMetaGrid.java:655)
    at zombie.iso.IsoWorld.init(IsoWorld.java:1618)
    at zombie.gameStates.GameLoadingState$1.runInner(GameLoadingState.java:248)
    at zombie.gameStates.GameLoadingState$1.run(GameLoadingState.java:223)
    at java.lang.Thread.run(Thread.java:745)
1510852244823 waiting for UdpEngine thread termination
1510852244834 znet: Java_zombie_core_raknet_RakNetPeerInterface_Shutdown
1510852244926 znet: Java_zombie_core_znet_SteamUtils_n_1Shutdown
 

 

I have seen this before but its usually when i remove that file to turn the power back on... but at the same time, it doesnt seem to be populating the files again

 

Share this post


Link to post
Share on other sites
23 minutes ago, FinestHops said:

local console log.....

 

Could the removal of the file have caused this maybe?

 

1510852240667 ERROR: invalid room ID #40 in cell 45,15 while reading map_meta.bin
1510852240669 ERROR: invalid room ID #1466979188 in cell 45,15 while reading map_meta.bin
1510852240670 ERROR: invalid room ID #1749901680 in cell 45,15 while reading map_meta.bin
1510852240671 ERROR: invalid room ID #2983424 in cell 45,15 while reading map_meta.bin
1510852240672 ERROR: invalid room ID #-1627384510 in cell 45,15 while reading map_meta.bin
1510852240672 ERROR: invalid room ID #1818848867 in cell 45,15 while reading map_meta.bin
1510852240672 ERROR: invalid room ID #1818848851 in cell 45,15 while reading map_meta.bin
java.nio.BufferUnderflowException
    at java.nio.Buffer.nextGetIndex(Buffer.java:506)
    at java.nio.HeapByteBuffer.getInt(HeapByteBuffer.java:361)
    at zombie.iso.IsoMetaGrid.load(IsoMetaGrid.java:655)
    at zombie.iso.IsoWorld.init(IsoWorld.java:1618)
    at zombie.gameStates.GameLoadingState$1.runInner(GameLoadingState.java:248)
    at zombie.gameStates.GameLoadingState$1.run(GameLoadingState.java:223)
    at java.lang.Thread.run(Thread.java:745)
1510852244823 waiting for UdpEngine thread termination
1510852244834 znet: Java_zombie_core_raknet_RakNetPeerInterface_Shutdown
1510852244926 znet: Java_zombie_core_znet_SteamUtils_n_1Shutdown
 

 

I have seen this before but its usually when i remove that file to turn the power back on... but at the same time, it doesnt seem to be populating the files again

 

 

Can you send me the server_console.txt, please?

Share this post


Link to post
Share on other sites
2 hours ago, FinestHops said:

local console log.....

 

Could the removal of the file have caused this maybe?

 

1510852240667 ERROR: invalid room ID #40 in cell 45,15 while reading map_meta.bin
1510852240669 ERROR: invalid room ID #1466979188 in cell 45,15 while reading map_meta.bin
1510852240670 ERROR: invalid room ID #1749901680 in cell 45,15 while reading map_meta.bin
1510852240671 ERROR: invalid room ID #2983424 in cell 45,15 while reading map_meta.bin
1510852240672 ERROR: invalid room ID #-1627384510 in cell 45,15 while reading map_meta.bin
1510852240672 ERROR: invalid room ID #1818848867 in cell 45,15 while reading map_meta.bin
1510852240672 ERROR: invalid room ID #1818848851 in cell 45,15 while reading map_meta.bin
java.nio.BufferUnderflowException
    at java.nio.Buffer.nextGetIndex(Buffer.java:506)
    at java.nio.HeapByteBuffer.getInt(HeapByteBuffer.java:361)
    at zombie.iso.IsoMetaGrid.load(IsoMetaGrid.java:655)
    at zombie.iso.IsoWorld.init(IsoWorld.java:1618)
    at zombie.gameStates.GameLoadingState$1.runInner(GameLoadingState.java:248)
    at zombie.gameStates.GameLoadingState$1.run(GameLoadingState.java:223)
    at java.lang.Thread.run(Thread.java:745)
1510852244823 waiting for UdpEngine thread termination
1510852244834 znet: Java_zombie_core_raknet_RakNetPeerInterface_Shutdown
1510852244926 znet: Java_zombie_core_znet_SteamUtils_n_1Shutdown
 

 

I have seen this before but its usually when i remove that file to turn the power back on... but at the same time, it doesnt seem to be populating the files again

 

Oh. It does look you have a map mod after all. AIZ does quite a bit of hacky things that aren't compatible with the recent version of the game, so perhaps it's destroying the Objects.lua file and making a malformed map_meta.bin file. Shouldn't happen, and the error still looks like the file already exists on startup, but that's the best I can offer.

 

Try removing this: https://steamcommunity.com/sharedfiles/filedetails/?id=1158053757&searchtext=amhghk2 Any pre-generated areas won't be lost. You'll just lose the spawnpoints.

Share this post


Link to post
Share on other sites

There is only a single spawn point and thats manually defined in the configs so that shouldn't be an issue at least.

 

You mentioned your server. Which is your server out of curiosity?

Share this post


Link to post
Share on other sites
15 minutes ago, FinestHops said:

There is only a single spawn point and thats manually defined in the configs so that shouldn't be an issue at least.

 

You mentioned your server. Which is your server out of curiosity?

I still help out Redboid with their setup, when needed. I also ran the IWBUMS MegaTest server this week.


Shut down the server, remove the mod, and delete the map_meta.bin file. Start it up again.

If it still fails, I'll need server_console.txt file from  %UserProfile%\Zomboid to help further. You can DM it to me.

Share this post


Link to post
Share on other sites

I am remoted into my home computer loading the game because one of the admins here has connected but it tells me the server didnt respond. I am also at work using a VPN behind a firewall so... the ability to connect comes and goes depending on the exact server my VPN connects to. 

 

It seems I am able to load in now from home. Unfortunately I cant get past click start because teamviewer just freezes, but thats normal. Everything appears to be working better now. 

 

Any chance I can get you added on Discord to possibly message you for help when needed? It would be great to have someone knowledgeable more so than myself on this for the times I cant seem to figure something out. I am not bad by any means on these kinds of things, but at the same time it would be really good to build up a network of people who know about these things since the community is rather small already so finding knowledgeable people is already a challenge. 

 

My name is Legion#1790 on discord. 

Share this post


Link to post
Share on other sites

And Generators still turn off on Multiplayer when you log off.

 

RIP ever saving food. I was hoping that one would be fixed. It used to stay on all the time even if you logged off till it ran out of gas. Now it STILL autoshuts off after you log off

Share this post


Link to post
Share on other sites
2 minutes ago, BumWhipper said:

And Generators still turn off on Multiplayer when you log off.

 

RIP ever saving food. I was hoping that one would be fixed. It used to stay on all the time even if you logged off till it ran out of gas. Now it STILL autoshuts off after you log off

It's only fixed in the car build to avoid merge issues.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
5 5