RELEASED: Vehicle Test 41
35 35

1546 posts in this topic

Recommended Posts

Posted (edited)

Recently I've tried playing with the newest vehicles build "40.6", I started up a sandbox with "survival" mode with the following changes made only to the zombie lore:

-Peak Day set to 28

-Initial Zombie Pop. Multiplier set to 0.001

-Peak Zombie Pop. Multiplier set to 4.0

-Respawning is set to 0 (off)

I tried out playing like this because a youtuber (ambiguous amphibian) is playing with this settings and with "Super Survivors" and he has had no problems what so ever.

 

After 5-10 mins of playing, the game started stuttering every 2 seconds (which was ridicoulous). I did have mods on but it turned out that none of them are the issue. These are the 5 mods I had on:

-Super Survivors

-Souls Cooking Time

-Souls Farming Time

-Zombie Cure Cocktail

-I can Shoot and Use Generators

 

It turned out that those mods had nothing to do with the game/s worlds problems. Which then I tried messing with the graphics settings and game modes and nothing helped. Just to make sure, I even verified game file integrity but that didn't fix it either.

 

I then proceeded to only play on game mode presets like "Initial Infection" up to "six months later" and not sandbox. This solved the issue but that means that there might be an issue within the game acting weird when using sandbox changes. I get no error boxes either or game crashes.

 

I have a good PC and have never had issues with stuttering up until this build. My general PC specs are:

CPU-Intel i5 7400 3GHz

GPU-AMD RX 580 4GB

RAM-8 GB

 

At this point I will not touch sandbox at all, considering that's whats been causing problems. 

Edited by Capt.Motty

Share this post


Link to post
Share on other sites

Ever since this update the vehicle UI has made it too challenging to access the mechanics UI page to try and remove any car parts. I cannot access the mechanics Ui when i'm inside the vehicle.  Even trying to remove a car wheel on the rear is difficult due to survivor can only access the mechanics Ui from the front of the vehicle even to remove and install  car parts that is not under the hood at all.  The last problem that there was with the mechanics UI difficulty to access is due to the front of the car touching the wall or fence making it impossible to take car parts unless I have the keys or to hotwire.   

Share this post


Link to post
Share on other sites
1 hour ago, Tails said:

Ever since this update the vehicle UI has made it too challenging to access the mechanics UI page to try and remove any car parts. I cannot access the mechanics Ui when i'm inside the vehicle.  Even trying to remove a car wheel on the rear is difficult due to survivor can only access the mechanics Ui from the front of the vehicle even to remove and install  car parts that is not under the hood at all.  The last problem that there was with the mechanics UI difficulty to access is due to the front of the car touching the wall or fence making it impossible to take car parts unless I have the keys or to hotwire.   

I like the hood feature but you are right about removing tires on front end accidents.

Share this post


Link to post
Share on other sites

I'am sure that the mechanic menu access who people talk and retalk is a balance in progress and known issue.
aside that, the time to diagnostic is interresting, but to add/remove a battery or check simple element is annoying, thinking to me that this time could be implemented more like this : 
Mechanic window open directly, but parts appear one by one according to the difficulty of part. (as an hourglass on each line who progressivily display lines). And not accessible parts don't get a hourglass but a unseen logo... (incar, outcar, underhood parts).

  • Auto close hood : if i go away (with mechanic window opened), hood auto close, but i'am at 5/6 tiles from it. Sometimes hood don't close automatically...
  • window still don't close if I close hood ("use" key).
  • It seems to me that was already said : I don't see on car removed parts

 

detail : title topic hasn't be modifed according to version number.

Share this post


Link to post
Share on other sites
Posted (edited)

Error Error Error until I close out the tutorial to the right about cars in multiplayer. Also something that needs to be added ASAP, we need a way to charge the siren from the UI or keyboard, I want to play different sirens in my ambulance but it is difficult having to have that big UI in my face!

Edited by Zomboid

Share this post


Link to post
Share on other sites
On 29/03/2018 at 11:49 PM, MaxD12 said:


First bug that I found in this build- I can not acess the vehicle mechanic menu when I choose it in radial menu or press "U" button in car. But press "E" at hood always give me it as before.If I already checked mechanic menu around hood,I still can't acess it  in the car radial menu or "U" button. And another bug - corpse of dead survivor not visible nearby random wrecked car in Muldraugh:

 

 

 

Not a bug. Line 4 of the Vehicle Build 40 Release Notes: 

  • Player now walks to engine hood/bonnet and opens it before starting Mechanic skill tasks. It will close it automatically when you're done.

Character cannot access the Mechanics menu from inside of a vehicle :)

Share this post


Link to post
Share on other sites
2 hours ago, Pandorea said:

 

Not a bug. Line 4 of the Vehicle Build 40 Release Notes: 

  • Player now walks to engine hood/bonnet and opens it before starting Mechanic skill tasks. It will close it automatically when you're done.

Character cannot access the Mechanics menu from inside of a vehicle :)

Thanks, I didn't read full changelist attentively, but understand this feature later. It looks really realistic and adds more difficulty in the game, but now "vehicle mechanic" option in radial menu seems to be useless.
Just now I survived 28 days in survival mode and didn't find any serious bugs or issues. Still can't find any meat in ovens,but now meat are really common in game, so this is not especially important to me. I'll tell if find any bugs in  next build 
 

Share this post


Link to post
Share on other sites

So I've held off trying Vehicles because well....... Toaster PC with integrated Intel Card.

If you have one, don't try. It will not work.

 

Freezes at the main menu. If you can click beyond the main menu like Solo/Options - It will then hang/freeze or just exit itself.

 

I guess I'm glad I backed up the last stable version because it sounds like it will be this computers last playable version.

Share this post


Link to post
Share on other sites
Posted (edited)
21 minutes ago, Capt_Paradox said:

Freezes at the main menu. If you can click beyond the main menu like Solo/Options - It will then hang/freeze or just exit itself.

 

I guess I'm glad I backed up the last stable version because it sounds like it will be this computers last playable version.

I actually play with a man who his main computer function is "toasting bread" (or check emails), And he can play quite smoothly.
Freezing at main menu , as there is no game launched, so neither graphical heavy process, or game mechancis process couldn't be related to the heavy of vehicule add, then to a low spec PC !!
 

may ask for people if there is a reason that you issue this problem before give your conclusion.

21 minutes ago, Capt_Paradox said:

If you have one, don't try. It will not work.

I think you would more say :
is it normal that on low spec PC game freeze at menu ?
Then you will get many "No" as answers
then You will not have to give such bad advice.

So, aside , what is your spec ?
Did you install beta vehicle from steam by choosing "beta vehicle" and no "previous vehicles" ?
Get you red box while launching ( red box with numbers in the bottom right corner) ?
did you tro to make a fresh install ?

Edited by arkahys

Share this post


Link to post
Share on other sites

Vehicle Beta Build 41


[New]

  • Added new foraging/parking zones - specifically close to Rosewood.
  • Added Moveables.txt translation file (for moveable-object names).
  • Added MultiStageBuild.txt translation file (for creating/upgrading walls).
  • UI now displays multi-stage build options even if a required recipe is unknown.
  • Solid objects, trees and vehicles prevent double-doors from opening and closing.
  • Added cheat Get Key / Repair Vehicle to context menu when clicking outside any part.


[Balance]

  • Changed SafetyCooldownTimer and SafetyToggleTimer server options to seconds.
  • Force player to exit vehicle when using Mechanics UI.


[Bug Fix]

  • Fixed overly-long physics box on the Dash Rancher.
  • Fixed burned vehicles sometimes floating off the ground.
  • Fixed UI confusion by renaming "Generator" to "Generator Maintenance", "Herbalist" to "Herbal Remedies"
  • Fixed crafting UI rendering parts of itself when collapsed.
  • Fixed gunshots/screams/dog-bark events happening when MetaEvent sandbox options is set to 'Never'
  • Fixed move-furniture tooltip texture position.
  • Fixed some untranslated controller prompts.
  • Fixed translations not being used for "Basic Mechanics" etc in mechanics UI.
  • Fixed car battery being simply called "Battery" and causing confusion.
  • Fixed engine-volume calculation for splitscreen.
  • Fixed action progressbar not rendering for split-screen player.
  • Fixed vehicles not working for split-screen players in multiplayer.
  • Fixed old double-door code being present.
  • Fixed physics not updating on the server when double-doors were closed.
  • Fixed there not being a check for null sprite in IsoThumpable.syncIsoObjectSend()
  • Fixed sprite properties: railings, street-crack grass, double-door lighting.
  • Fixed syncIsoObject() sometimes sending truncated packets to the server.
  • Fixed issues with double doors.
  • Fixed lighting not updating when player is walking a path.
  • Fixed lighting not updating after a character wakes up.
  • Fixed RadialMenu sometimes staying transparent at certain framerates.
  • Call UITransition.UpdateAll() in render() instead of update()
  • Fixed player avatar animating slowly in character-creation ui.
  • Fixed RPM in MP to improve fluctuating gears and ear-splitting audio.
  • Fixed hood being closed when closing mechanics UI when the player was out of range.
  • Fixed player exiting a vehicle without opening/closing the door sometimes.
  • Fixed TutorialPanel.prerender() error.
  • Fixed VehicleManager.clientReceiveUpdate() exception.
  • Fixed random two vehicle wrecks sometimes putting a vehicle on the wrong chunk.

Share this post


Link to post
Share on other sites
1 minute ago, arkahys said:

ouah ! I love unexpected release !
thanks for this gift !

 

If this build seems okay (as in: no major horror shows) then we'll be killing the vehicles beta branches tomorrow, and shifting it all back into the traditional IWBUMS beta.  

Share this post


Link to post
Share on other sites
2 minutes ago, Batsphinx said:

If this build seems okay (as in: no major horror shows)

I think (and hope :?) I do already bests with sinks and closed gates :-(.

4 minutes ago, Batsphinx said:

shifting it all back into the traditional IWBUMS beta

It will be very good for players understanding of all this differents beta version (and stable)

Share this post


Link to post
Share on other sites
On 2018-04-02 at 3:23 PM, TheLeonBM said:

There's an issue with double doors in SP (at least the wooden one, didn't test the others), it seems to be happen randomly too: every now and then, when I try to open it to go through it, it doesn't open, but my char goes through it anyway and everything turns black, and suddenly it is just me walking on eternal blackness but faster, like when I'm on admin mode. When I exit and reload the game, the door is not there anymore and whatever alterations I did at the space surrounding the door is reset to its original state. (eg. there was a wall and some crates against it where I put the double door, reloading the save after the bug restores the original wall and crates and gets rid of whatever user modifications that where done in that general area). I hope I explained it correctly, it is a pretty weird one.

There was a null pointer involving a property for double doors. I'd be interested to hear if it's fixed.


If not, since an area of the map was reset, I'd assume it was something breaking on save or load, goo to %UserProfile%\Zomboid\saves\ and find the save folder for your game. In it, there should be a \blam\ folder with text files containing an error. 

Share this post


Link to post
Share on other sites
On 03/04/2018 at 1:27 AM, Dreacon78 said:

So I am not sure if this has been mentioned before, but I am in the school and tearing down some of the interior walls to make room and I noticed that the lighting acts like the wall I just removed is still there.  Is this a known issue or something new?  Also I haven't tested it in other buildings, but it may be something to look into (if it isn't already being worked on).

 

Hi there! Dreacon78, could you send an image of this? 

Share this post


Link to post
Share on other sites
  • All new padlock are named "Key 72345343" (at least in french version. don't note the real number display)
  • car jack and lug wrench are very difficult to find as they are mostly include with all cars ! (With spare wheel)
    (With lucky trait watched all garages of West westpoint, to finally find (only) one in the garageShop of center.
    IG, as that serve only wheel maintenance, i don't think make them common could alter gameplay.
  • in GarageShop (I visit West Point) it seems that  there is a weird balance spawn :
    • No glasses and windshield
    • But sooo seats
    • No muffler
    • But soooo gaz tank
    • No engine parts (but this one don't really annoying me)
    • no (or very few) hoods
    • barbed wire ?

 

@Batsphinx on the hood /mechanic menu subject, I think there are many people as me who want some clarification, and enlighten with what TIS plan or not for this could prevent many question/answer.
As :

  • we have to go to hood to act ( and just know damages !) of bodywork, tires, incars parts,  etc..
  • radio is removed by hood, not incar.
  • can't see seats, radio state when in car (so indoor parts), and inverse : we can see indoors parts in hood.
  • have to open hood to know the bodywork damage.

There is some changes planned as kind idea i talk about :

23 hours ago, arkahys said:

Mechanic window open directly, but parts appear one by one according to the difficulty of part. (as an hourglass on each line who progressivily display lines). And not accessible parts don't get a hourglass but a unseen logo... (incar, outcar, underhood parts).

?

Share this post


Link to post
Share on other sites
38 minutes ago, EnigmaGrey said:

There was a null pointer involving a property for double doors. I'd be interested to hear if it's fixed.


If not, since an area of the map was reset, I'd assume it was something breaking on save or load, goo to %UserProfile%\Zomboid\saves\ and find the save folder for your game. In it, there should be a \blam\ folder with text files containing an error. 

 

Great! I'll test it later today.

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, Batsphinx said:

 

If this build seems okay (as in: no major horror shows) then we'll be killing the vehicles beta branches tomorrow, and shifting it all back into the traditional IWBUMS beta.  

Wait, so does that mean that if everything goes fine with the current vehicles build, and is moved to IWBUMS, is it a step closer to releasing it to the actual stable game version? Or did I read and interpret something wrong? Just curious.

Edited by Capt.Motty

Share this post


Link to post
Share on other sites

Happy to see that the visual bugs with the railing sprites are fixed. Here are my longstanding issues, unsure if these are horror shows:

 

Vehicles:

-Key is still required to take engine parts. Only workaround is hotwiring the car.

-Decided to remove the truck from our server that kept switching textures after it was patched, as an identical one we found did not have this issue. Hoping that is the case.

 

General Issues:

-Zombies respawning on some roofs in a world where respawn is turned off entirely. This is after a player went to that roof and killed them as well, so the roof in question as been 'seen' from the level as well.

-In our non-steam multiplayer server, TVs still do not reward XP when nature shows are watched, neither do they reduce boredom. Tested in a server with 4 players to learn that it is not an isolated issue.

Share this post


Link to post
Share on other sites
5 hours ago, Batsphinx said:

If this build seems okay (as in: no major horror shows) then we'll be killing the vehicles beta branches tomorrow, and shifting it all back into the traditional IWBUMS beta.  

 

So if nothing goes wrong in this version of today tomorrow we finally get IWBUMS? 

God i hope so, IWBUMS has been around the corner for like 2 months now.

Share this post


Link to post
Share on other sites
4 hours ago, Pandorea said:

 

Hi there! Dreacon78, could you send an image of this? 

 

I would but I died about 1 day later in game and deleted the save before I figured out you could start a new person in that save.  :?

If this issue repeats in this play through I will make sure I get a screenshot.

Share this post


Link to post
Share on other sites
On 4/2/2018 at 6:27 PM, Dreacon78 said:

So I am not sure if this has been mentioned before, but I am in the school and tearing down some of the interior walls to make room and I noticed that the lighting acts like the wall I just removed is still there.  Is this a known issue or something new?  Also I haven't tested it in other buildings, but it may be something to look into (if it isn't already being worked on).

 

6 hours ago, Pandorea said:

 

Hi there! Dreacon78, could you send an image of this? 

Based off of seeing posts like these in the past I was under the impression this wasn't really a bug in the normal sense and more of a side product of how the game renders the map's lighting: https://steamcommunity.com/app/108600/discussions/0/142260718943906831/

 

"Trouble is, to improve performance, lighting is baked into the map itself when it's exported. I'm not totally sure how this can be addressed, as the lighting will need to be re-calculated after the building is removed.

I'm sure one of the devs will come up with a clever solution at some point, though. :D"

Share this post


Link to post
Share on other sites
3 hours ago, Kuren said:

 

 

Based off of seeing posts like these in the past I was under the impression this wasn't really a bug in the normal sense and more of a side product of how the game renders the map's lighting: https://steamcommunity.com/app/108600/discussions/0/142260718943906831/

 

"Trouble is, to improve performance, lighting is baked into the map itself when it's exported. I'm not totally sure how this can be addressed, as the lighting will need to be re-calculated after the building is removed.

I'm sure one of the devs will come up with a clever solution at some point, though. :D"

 

Ahh ok.  Well that explains a lot.  The game is still being developed so I am sure there will be some sort of change made in the future...well one can hope anyways.

Maybe make the map lighting update when you load up your save or something like that.  Then it might only cause a minor lag in the initial save loading up and then not effect anything during actual game play.  Not really sure how they coded it or how it works so just throwing out an idea..

Share this post


Link to post
Share on other sites
10 hours ago, Blasted_Taco said:

 

So if nothing goes wrong in this version of today tomorrow we finally get IWBUMS? 

God i hope so, IWBUMS has been around the corner for like 2 months now.

Server's still up with people playing on it, sipping RAM, and I don't see any big complaints on the three sites to worry me, so.

 

Maybe we'll have a good day today.

Share this post


Link to post
Share on other sites

I forget when i last heared flies over corpses on vehicle built. Playing over than 1 ingame month, but still, no flies. Sound is enabled.

( Might be important to note, but im also playing with setting "influence of corpses on character health" with setted to "slow", or whatever it's called in settings, i do not remember. Is it because of that? )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
35 35