RELEASED: Vehicle Test 41
36 36

1544 posts in this topic

Recommended Posts

3 minutes ago, RobertJohnson said:

Hotfix will be up in 1 minute :)

And something is wrong with containers: they dissappear for few moments too, when i come close to them ( happens not everytime )

Share this post


Link to post
Share on other sites

Not on the most recent build but didn't see it in the patch notes:

 

Repairing the trunk of the station wagon did not increase it's trunk size to stock. Not tested on other vehicles.

 

Edit: This Fossoil and parking lot are missing parking zones

 

http://map.projectzomboid.com/?#0.31244983604592974,0.3027855265617588,162.60628901194954

Edited by Kim Jong Un

Share this post


Link to post
Share on other sites
25 minutes ago, RobertJohnson said:

Released 33.3

 

  • Bring Chris Wood fixes on world visibility.

Vehicle are back, but only in new world. 

R.I.P 50 lbs of food, we'll miss you.

Edited by RealHumanBeing

Share this post


Link to post
Share on other sites

Something of concern,

 

(Again, not the most recent build but worth mentioning)

 

Desync bug: Driving fast with a passenger and some lag. On the passenger's screen I hit multiple things that I did not on my screen. Friend informs me that I've near totaled the car and gives me what his mechanics view states. Mine still states 100% in most categories, same as it was before.

 

I leave friend in the car, run very far away and come back, and sure enough his version of the car has loaded on to my screen with the damage.

 

Thank you for your hard work!

Edited by Kim Jong Un

Share this post


Link to post
Share on other sites

For some reason i can't gain EXP from doing car-upgrading stuff 

Car hud ( this stuff under the middle ) is disappear sometimes.

If somebody ignites the car engine and off it, the sound will still stay.

Many desinc. issues ( if my friend drops a loot it isn't shows uno momento, grass texture ins't updating after removing it and etc )

Edited by RealHumanBeing

Share this post


Link to post
Share on other sites

- Bookshelves and some shelves don't refresh their list when you take an item out. You can only take an item out once. BUT if you transfer an item from the bugged container to yourself and also drag it into another container, it dupes.

- Some graphic flickering when interacting with shelves.

Share this post


Link to post
Share on other sites
On 1/17/2018 at 8:04 AM, RobertJohnson said:

Build Vehicle 33:

 

[New]

  • Trees can now be destroyed by car.
  • Added -CreateMinidumpOnCrash and -OmitStackTraceInFastThrow arguments on server start script.

 

[Balance]

  • Now always give mechanics exp, will see how it goes in term of grinding.
  • Tuned down flies sound radius.
  • Reduced horn sound radius.
  • Small trees won't collide with cars.

 

[Bug Fix]

  • Fixed opening trunk not always being synced in MP.
  • Fixed being able to access the trunk from anywhere when it was open.
  • Fixed fire near a car could cause a crash.
  • Removed some wrong server console messages.
  • Fixed saying no in the sleep dialog when in car still make you sleep.
  • Fixed Exception Access Violation in PZBullet64.dll+0x380.
  • Fixed Moving a large number of items into a trunk, including the key, produces a malformed packet 164.

It took about 1 and a half ingame days to get from lvl 0 to 1 by taking the parts from 4 cars and mix matching them together. Tge 

Share this post


Link to post
Share on other sites
1 hour ago, JayM said:

Hi. How do i hotwire a car? I'm lvl 3 mechanic.

You need level 1 electrical also, go around houses picking up any TV's and radio's you see and dismantle them, you should get to level 1 before sundown.

Share this post


Link to post
Share on other sites

Having a weird bug with the freezer I placed. Constant flickering - cannot remove my 57 cm perch from it, but one ends up in my inventory while one somehow remains in the container. This doesn't happen with small items with fast transfer times, so it's duping heavy items.

Share this post


Link to post
Share on other sites

The supplementary explanation about this video.

Spoiler

 

 

 

 "Big trees" and "Small trees" were swapped.

On 2018/1/17 at 11:04 PM, RobertJohnson said:

Build Vehicle 33:

[Balance]

  • Small trees won't collide with cars.

 

 

 

Share this post


Link to post
Share on other sites

Build Vehicle 33.4:

 

[New]

Changed loot respawning to work at regular intervals.
.
Starting at 7AM on the first day, loot respawns according to the LootRespawn
sandbox option (in singleplayer) or the HoursForLootRespawn server option.
So if loot is set to respawn every 24 hours, it will respawn at 7AM every day.
.
There is a new sandbox option SeenHoursPreventLootRespawn. When > 0, loot
will not respawn at the next loot-respawn time in zones that have been seen
within that many hours.

 

[Balance]
Reverse the previous exp gain change because of a MP exp give sync bug I fixed.
Changed how CarGeneralCondition works on part condition: now it's a random % and not a fixed number per value (will avoid having lots of parts at 70% condition in MP).
Removed the "Ignition status" in the mechanic UI, was here to help people but it seems it confuse it. Friendly reminder if your car doesn't start: check battery charge & fuel from the mechanic UI.

 

[Bug Fix]
Fixed a bug making not gaining mechanics exp in MP.
Fixed Player-built floor rendering bug - attempt to hide player structures better.
Fixed vehicle can out-pace the map at or above 120 MPH, causing you to strike the Void.

Share this post


Link to post
Share on other sites
2 hours ago, RobertJohnson said:

Build Vehicle 33.4:

 

[New]

Changed loot respawning to work at regular intervals.
.
Starting at 7AM on the first day, loot respawns according to the LootRespawn
sandbox option (in singleplayer) or the HoursForLootRespawn server option.
So if loot is set to respawn every 24 hours, it will respawn at 7AM every day.
.
There is a new sandbox option SeenHoursPreventLootRespawn. When > 0, loot
will not respawn at the next loot-respawn time in zones that have been seen
within that many hours.

 

[Balance]
Reverse the previous exp gain change because of a MP exp give sync bug I fixed.
Changed how CarGeneralCondition works on part condition: now it's a random % and not a fixed number per value (will avoid having lots of parts at 70% condition in MP).
Removed the "Ignition status" in the mechanic UI, was here to help people but it seems it confuse it. Friendly reminder if your car doesn't start: check battery charge & fuel from the mechanic UI.

 

[Bug Fix]
Fixed a bug making not gaining mechanics exp in MP.
Fixed Player-built floor rendering bug - attempt to hide player structures better.
Fixed vehicle can out-pace the map at or above 120 MPH, causing you to strike the Void.




Dedicated server won't start. Its need to be fixed.
Pls fix linux dedicatedservers  with cars. Exception in thread "main" java.lang.NoClassDefFoundError: Lgnu/trove/map/hash/TIntObjectHashMap;
This bug starts from long ago.


And sometimes when i play in singleplayer i have freeze then gamecrash and then when i reboot game my car despawn and i can't find it, but all other cars on their places.

Edited by CherryBanana

Share this post


Link to post
Share on other sites

This constant flickering/refresh in our freezer containers is really starting to mess things up. We can no longer move the freezers as there are items in there that we can't remove and duplicate in the process of removing. 

 

It's also an infinite source of Big Perch (55 cm) and other big catches.

Share this post


Link to post
Share on other sites

Started a new two-player MP game.

 

  • In addition to the issue of taking items out of shelves, certain containers now disappear completely when you walk next to them. You cannot see them, you cannot interact with them. Sometimes they reappear at certain angles but you still can't access them. So far this has affected certain bookshelves and kitchen counters. Our fridge also disappeared.
  • After restarting the server due to aforementioned containers being invisible, every container in the world reset and deleted all our items. Cars etc were still in the same spots, but all other items had been deleted. 850+ errors for both players upon rejoining the server.
  • Ground slots still don't work in multiplayer, as in - you can't see items someone else drops on the floor (just mentioning again because i can't remember if it was attempted fixed or not).
  • You can inflate car tires with no tools (not sure if intentional)
  • Vehicle speeds on grass should maybe be reconsidered, personally i feel they are tweaked way too low.
  • Can confirm trunks now work in MP.
  • Performance has improved, no major issues anymore.
Edited by iwawa

Share this post


Link to post
Share on other sites
2 hours ago, Kim Jong Un said:

This constant flickering/refresh in our freezer containers is really starting to mess things up. We can no longer move the freezers as there are items in there that we can't remove and duplicate in the process of removing. 

 

It's also an infinite source of Big Perch (55 cm) and other big catches.

Would you be able to get a short video fo this, Kim? 

 

33 minutes ago, iwawa said:

Started a new two-player MP game.

 

  • In addition to the issue of taking items out of shelves, certain containers now disappear completely when you walk next to them. You cannot see them, you cannot interact with them. Sometimes they reappear at certain angles but you still can't access them. So far this has affected certain bookshelves and kitchen counters. Our fridge also disappeared.
  • After restarting the server due to aforementioned containers being invisible, every container in the world reset and deleted all our items. Cars etc were still in the same spots, but all other items had been deleted. 850+ errors for both players upon rejoining the server.
  • Ground slots still don't work in multiplayer, as in - you can't see items someone else drops on the floor (just mentioning again because i can't remember if it was attempted fixed or not).
  • You can inflate car tires with no tools (not sure if intentional)
  • Vehicle speeds on grass should maybe be reconsidered, personally i feel they are tweaked way too low.
  • Can confirm trunks now work in MP.
  • Performance has improved, no major issues anymore.

Is this in split screen or a server created with the Hosts button from the main menu of the game?

 

How far is your friend from you?

 

Do you have any mods installed?

Share this post


Link to post
Share on other sites
On 18.1.2018 at 4:34 PM, RobertJohnson said:

Build Vehicle 33.1:

 

[Bug Fix]

  • Fixed missing trove lib in Linux server classpath.

Erm, not exactly, sorry...
In ProjectZomboid32.json you did add it to classpath (but the jar still resides in ./projectzomboid instead of ./java - mv it, please), in ProjectZomboid64.json you didn't, though.

9 hours ago, CherryBanana said:




Dedicated server won't start. Its need to be fixed.
Pls fix linux dedicatedservers  with cars. Exception in thread "main" java.lang.NoClassDefFoundError: Lgnu/trove/map/hash/TIntObjectHashMap;
This bug starts from long ago.

Well, the fix is not that difficult... if you'd have followed the thread you'd have known how to do it already. You didn't? Well then, fix is just some lines above ;)

Share this post


Link to post
Share on other sites
14 hours ago, Kim Jong Un said:

@EnigmaGrey Here you go.

 

 

 

Also, new bug, can't zoom in or out

 

 

So, the zoom thing is one of those 1/1000 bugs. It should work if you go into Options and toggle Zoom off, press Accept, then toggle Zoom on, pressing accept again.

 

When this does break you should see something in the console about an OOM or something. It should happen when loading the game. If it does happen again, and you're able to get the console.txt, that could be really helpful.

Share this post


Link to post
Share on other sites
16 hours ago, EnigmaGrey said:

Would you be able to get a short video fo this, Kim? 

 

Is this in split screen or a server created with the Hosts button from the main menu of the game?

 

How far is your friend from you?

 

Do you have any mods installed?

Hosted through the in-game host button. We live in different countries, where we ping about 40 to each other. No mods installed.

 

Also, the video Kim linked is the same thing we're experiencing, only we eventually also experienced those containers disappearing after they started flickering. Happens to most types of fridges/freezers, lockers and shelves (seems a bit random).

Share this post


Link to post
Share on other sites
6 minutes ago, iwawa said:

Hosted through the in-game host button. We live in different countries, where we ping about 40 to each other. No mods installed.

 

Also, the video Kim linked is the same thing we're experiencing, only we eventually also experienced those containers disappearing after they started flickering. Happens to most types of fridges/freezers, lockers and shelves (seems a bit random).

Next time the containers vanish, grab the console.txt, coop_server.txt, and server_console.txt file from %UserProfile%\Zomboid.  You can just attach it to your reply with the "Drag files here to attach" bar at the bottom.

 

Should be an interesting log. :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
36 36