RELEASED: Vehicle Test 41
35 35

1546 posts in this topic

Recommended Posts

Been awhile since I've come around to test myself, and I'm pretty impressed with the performance increase so far! Overall, the game seems much more smooth and well... actually playable now. My FPS tends to want to stay around the 55-60 mark while on foot and not fully zoomed out all the way, where about a little over half and less zoom seems to run.. relatively smooth with full zoom being about 52-47. Which.. that being said, the "micro stutter" issue seems to exist still ever so slightly where even despite my FPS still running solid 55-60 (according to steam anyway) it will hit patches of "molasses movement" where it FEELS like a FPS lag but there is no numerical drop in FPS according to steams counter.  While driving a car it is noticeably lower and bounces between 50-38 depending on whats going on  at a little over half zoom.

 

A couple other things I'd also noticed! Checking out the default survival settings the "locked frequency" of cars is set to "never" by default, not sure if this was intended? Also... even more strange is that "car alarms frequency" is set to "never" by default, however while in game I was still quite often getting alarms on cars despite this being set to never.

 

Tested on:

 

Windows 10

ASUS Sabertooth 990fx R2.0

AMD FX 9590 @4.7GHZ

EVGA GTX 980 SC ACX 2.0 @ Stock (Clocks vary depending on necessary draw)

16GB Crucial Ballistix Sport low profile DDR3-1600

 

*Game set to high priority in task manager, just for good measure ;-)

 

 

1 minute ago, Anishka said:

I don't know, does anybody else have the same problem? If doesn't, so it would be my personal problem and I'll have no reclamations. But if somebody else has the same bug, it should be fixed I mean

 

I haven't tried to see if this was an issue for me, however... as this build is designed and purposed as a TEST build, and not intended for long term play... this would come as a low priority issue as this feature is intended for long term play and really offers no feedback to the testing of overall game play, and vehicles. Obviously, it is eventually going to be fixed because it IS a necessary part of the game, however is not necessary to the test since it's not meant to be played in long term.

Share this post


Link to post
Share on other sites

yea this build is better in fps when driving around towns( mostly westpoint) but theres still micro stuttering present. And it gets worse the more zombies you drive past until it start to freezing for a second. When i leave the city its still present but not so strong. Only thing that helps is reloading save. It seems when theres a specific number of zombies on screen the game starts lagging a bit, but as KinaUndead said fps stays the same or drops for just a small amount. Havent tried with no zombies yet. Oh and i had to disable 3d models on corpses and zombies or the stuttering is even worse and is the same as before the optimization fixes. And yea the bonfires also dont work for me too.

Share this post


Link to post
Share on other sites
4 hours ago, Anishka said:

I don't know, does anybody else have the same problem? If doesn't, so it would be my personal problem and I'll have no reclamations. But if somebody else has the same bug, it should be fixed I mean

I don't think many people use campfires honestly, hence why no one else has complained about it. You can just pick up ovens and antique ovens and put them wherever you want. Maybe this is a good time to explore new ways to survive? :D

 

Either way, RJ has obviously already added it to his to-do list. Posting about it 8 times does not help you.

Share this post


Link to post
Share on other sites
4 hours ago, Anishka said:

I don't know, does anybody else have the same problem? If doesn't, so it would be my personal problem and I'll have no reclamations. But if somebody else has the same bug, it should be fixed I mean

I started the game again, so I didn't reach bonfires yet, but when I loaded my save from previous build then yes, there is a bug with bonfires, I can confirm. On newly created bonfires and at old ones.

 

And about FPS, hard to say, but for me is playable when I'm driving car fast through town (I'm having i7 cpu), even with these microlags, I prefer when game slowing down than losing frames. So because of that is acceptable for me, but I didn't notice much difference compared to previous build. But as I said - hard to notice.

Share this post


Link to post
Share on other sites
1 hour ago, iwawa said:

I don't think many people use campfires honestly, hence why no one else has complained about it. ...

Either way, RJ has obviously already added it to his to-do list. Posting about it 8 times does not help you.

Not to get off topic, but both I and another two members I am acquainted with were going to post about it if Anishka hadn't already. Campfires don't overbear you to carry around, after all.

 

Regardless, it is good to know that it's on the to-do list.

 

--

 

I'm planning on re-opening my server to my playgroup and test out the issues we had with car containers once our group is done with exams. Will post feedback as soon as possible. It's great to hear you guys are going ahead with advancing the mechanic system.

Share this post


Link to post
Share on other sites
6 hours ago, Anishka said:

I don't know, does anybody else have the same problem? If doesn't, so it would be my personal problem and I'll have no reclamations. But if somebody else has the same bug, it should be fixed I mean

 

Why do you keep calling them bonfires? That's more annoying than the bug itself, because bonfires would actually be a cool feature to add in, and you got my hopes up thinking they had added them when really you're just talking about campfires. 

Share this post


Link to post
Share on other sites

Car sounds are just too loud and annoying for me to bear playing it now.

And they are too slow and lose so much speed while trying to drive over zombies.

Edited by Pvt. Hudson

Share this post


Link to post
Share on other sites
13 hours ago, DeegoFund said:

I agree! make a garage door opener out of premium technology/electronic scrap, remote, batteries, glue, and screwdriver maybe? and have a receiver inside the garage to open and close. although the noise of the garage door should be loud.

Yep, and electricity/generator.

For buildable ones... Probably log/plank/metal gates, nails, hinges (ropes), optional lock. Maybe not a most pressing matter, but indeed needed.

Share this post


Link to post
Share on other sites
6 hours ago, Brex said:

 

Why do you keep calling them bonfires? That's more annoying than the bug itself, because bonfires would actually be a cool feature to add in, and you got my hopes up thinking they had added them when really you're just talking about campfires. 

Damn, campfires! Yes, u r right! I just forgot the word, sorry:-(

Share this post


Link to post
Share on other sites
8 hours ago, iwawa said:

I don't think many people use campfires honestly, hence why no one else has complained about it. You can just pick up ovens and antique ovens and put them wherever you want. Maybe this is a good time to explore new ways to survive? :D

 

Either way, RJ has obviously already added it to his to-do list. Posting about it 8 times does not help you.

Only 3 times) campfires are the part of my strategy of killing the large horde, that's why I'm so concerned about this issue. Ovens will not help in this case

Share this post


Link to post
Share on other sites

AS for FPS,  It increased from 1-5 when driving through the large crowd of zeds to 15-19. Huge progress! Of course, once or twice it fell to 5, but generally  the game ran faster and driving became much smoother

Share this post


Link to post
Share on other sites
12 hours ago, TheLeonBM said:

Can zeds trip alarms now? I've been having random alarms go off (at different times) in west point. If not don't fix it, It's a nice feature :-D

seriously yep this is so much wilder. I love the ideas of car/house alarms being insane in the early days. I've abandoned three homes on the first night.

 

 

I AM having a couple weird problems though. Gas canisters started filling funny.  Something goes "off" and then you mostly get 0% gas cans. Sometimes picking a different pump can help. I closed to main menu and reloaded, same behavior. I closed the game and it crashed. I restarted and reloaded the game and it ran really choppy. 

Share this post


Link to post
Share on other sites

Good optimization I get 60 fps stable witch slumps to 50 55.

 

Models 3D: 8

Ilumination: High

double size textures: Yes

Resolution: Max

vertical synchronization:off

 

Intel pentium g4560

8gb RAM ddr4

GTX650

Edited by jhonSs

Share this post


Link to post
Share on other sites
1 hour ago, Blake81 said:

Does disabling V-Sync make any real difference? I've done it once or twice, but never seen any changes.

V-sync on was giving me frequent stuttering, the game runs smoother with it off. Don't know if that's the case for everyone else though.

Edited by TheLeonBM

Share this post


Link to post
Share on other sites

Thought I was about to die and I didn't want to risk losing my car key if I did and became a zombie, so I put it in my trunk in a hurry only to be unable to open it again after that. I didn't think it would lock automatically, and even after hotwiring my car I haven't found any way to get it out. Is there no way to access my trunk again now to get my keys back? I thought toggling the door lock might let me in it after hotwiring but it didn't do anything.

Share this post


Link to post
Share on other sites
16 minutes ago, NorthRoad said:

Thought I was about to die and I didn't want to risk losing my car key if I did and became a zombie, so I put it in my trunk in a hurry only to be unable to open it again after that. I didn't think it would lock automatically, and even after hotwiring my car I haven't found any way to get it out. Is there no way to access my trunk again now to get my keys back? I thought toggling the door lock might let me in it after hotwiring but it didn't do anything.

Eh . . . I mean, I've had family do it before.  . . . Thank god for spare keys.

 

It'd be better for the game to just give an option to "pop the trunk" if you have access to the interior of the car. While I don't think every care had a release mechanism in the cabin back then, it's one of those details that'd be better ignored.

Share this post


Link to post
Share on other sites
11 minutes ago, EnigmaGrey said:

Eh . . . I mean, I've had family do it before.  . . . Thank god for spare keys.

 

It'd be better for the game to just give an option to "pop the trunk" if you have access to the interior of the car. While I don't think every care had a release mechanism in the cabin back then, it's one of those details that'd be better ignored.

Yeah, it really feels like a drag. I spent hours fixing up this car and it's in perfect condition, and I'm in MP so inflating the tires was tedious and took forever without the ability to fast forward. But now I lost my keys and can't even use the trunk. I was looking through the lua trying to find if there's some way to disable the lock on it, or anything like that just as a temporary fix, but I can't manage to find any way to get them out.

 

I also tried backing up the trunk into my house to break it so that the keys would fall out, but it got really buggy. First I got my trunk to about 20% damage, then the keys wouldn't drop just from bad luck, so I quit (shutting down the server) and came back in 10 mins. Reloaded, trunk was at 50% for some reason, so I cheated in some duct tape to test if I could even repair it properly if I did get the keys out this way. Repaired to about 80%, quit and reloaded, trunk was at 50% again. Then I broke it some more to see if I could get the keys out anyway, and they eventually did fall, so I picked them up and got access to my trunk again. But the keys still showed as in it even though they were in my inventory as well, so I looted the keys from the trunk and then both spontaneously disappeared out of existence. Drove around some more to make sure they didn't somehow go back into my trunk that I couldn't access, but after a while nothing dropped, so they were just gone.

 

It's a beta so I don't mind and expect this sort of thing, but still a little frustrating. Wish I could just get my keys out for now somehow, trunk repair bugs aside!

 

Another bug I found: I got a van and was repairing it to full, a 6-seater Franklin Valuline. So I removed one of the rear windows to replace it with one from another vehicle at 100%, and then it wouldn't let me install it, saying a rear door has to be installed, but it was.  It had a weird name--IGUI_VehiclePartDoorMiddleLeft (and then there was the right equivalent too). I temporarily got around this by editing the template_window and vehicle_van luas to remove that requirement.

Share this post


Link to post
Share on other sites

Just tried the latest version with a few mates, noticed the following bug: When  building walls (lvl2/3, dident try with lvl1) it doesn't sync with server/clients. So only the one who built it could see it. The rest of us only saw the door-frame. This enabled us to jump/see through it. 

Used the in-game host option.

Share this post


Link to post
Share on other sites
3 hours ago, GodAmongMen said:

Just tried the latest version with a few mates, noticed the following bug: When  building walls (lvl2/3, dident try with lvl1) it doesn't sync with server/clients. So only the one who built it could see it. The rest of us only saw the door-frame. This enabled us to jump/see through it. 

Used the in-game host option.

Sounds similar to how sheets and barricades weren't showing up a couple versions ago, but least if they fixed that, it should be simple enough to solve that too. I'll have to test that out as well.

 

I managed to solve the car keys problem temporarily after messing around with the lua, got the trunk not to require keys. I think you should be able to keep it either unlocked or open (like how you keep it up loading a car IRL), since it was a pain loading it up looting with friends, as we had to share the key back and forth. Not good when running from zombies. SUV trunk should really be accessible from inside of the car too, it's a bit inconvenient to take stuff from, but you can access it if you have to in an SUV IRL.

 

Another thing I think could be tweaked is some of the offroad vehicle speeds. I tried the van and it was slower than walking on a dirt road, which isn't how it would be in real life. Hats off to the values so far though! For the most part they are pretty smooth, and I tried messing with vehicle speeds, suspension, etc myself and found it way too complicated for my skill level.

 

Found another minor bug: typing the key for the car alarm in chat sets it off. Seems not to work with other features like headlights. Works for passengers too, so this resulted in me and my friends in our SUV hilariously setting the alarm on and off over and over as we typed before we got the genius idea to rebind it from H. The zombies must've thought we were insane.

 

edit: just realised some of this should probably go under the Bug Reports forum, so my bad if I posted in the wrong area. I'll be sure to next time.

Edited by NorthRoad

Share this post


Link to post
Share on other sites
5 hours ago, NorthRoad said:

Thought I was about to die and I didn't want to risk losing my car key if I did and became a zombie, so I put it in my trunk in a hurry only to be unable to open it again after that. I didn't think it would lock automatically, and even after hotwiring my car I haven't found any way to get it out. Is there no way to access my trunk again now to get my keys back? I thought toggling the door lock might let me in it after hotwiring but it didn't do anything.

Just turn off the engine and leave the car key in the car ignition panel. I discovered that after I was keep leaving car key next to the car.

Share this post


Link to post
Share on other sites

Since most of the cars in the game are based off of vehicles that could realistically have trunk/hatch access from inside the cabin to begin with (folding benches, the rear portion of the interior of the vehicle in some cases), I am in full support of adding in an open/closed state to trunks, whether cabin controlled or not. When the build began, I too put keys in the trunk of a station wagon thinking the space would be accessible. My mistake.

 

The existence of the feature is the key distinction between two very relevant situations.

 

You and your party are loading the back of a hatchback outside of a grocery store. One by one, the key is passed around (slowly but surely) so everybody can line up and put their loot in the trunk.

 

VS

 

You and your party are loading up your car. Somebody opens the trunk. Everybody puts what they want in, and then the trunk is closed after the last guy.

 

And if you really wanted to spice it up, punish players who leave the trunk open by having it all fall out of the car.

Share this post


Link to post
Share on other sites

I'm all for pop up the trunk from inside the car, but thing is we won't have the model texture update to show it's open, so i'm afraid people will leave it open lot of the time...

I'll try to maybe put it in plain black when it's open, while i see how we could implement the opened trunk.

 

Campfire should be fixed for next version, next time just post a tracker, keep this thread clean for vehicles-related stuff if possible.

Share this post


Link to post
Share on other sites
1 hour ago, RobertJohnson said:

I'm all for pop up the trunk from inside the car, but thing is we won't have the model texture update to show it's open, so i'm afraid people will leave it open lot of the time...

I'll try to maybe put it in plain black when it's open, while i see how we could implement the opened trunk.

 

Campfire should be fixed for next version, next time just post a tracker, keep this thread clean for vehicles-related stuff if possible.

Suppose we could lean on those over-head icons a bit more, until that's possible, or add something to the dash?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
35 35