RELEASED: Vehicle Test 41
36 36

1544 posts in this topic

Recommended Posts

32 minutes ago, Mallo said:

Just had a very weird bug while driving a car.
 

I was in Westpoint and decided to drive out the mall, so I followed the map, drove over the river, through the country roads, and got close to the mall, when - all of a sudden, while driving at medium speed - the screen went black. The screen then came back, but in a difference place, and with my car on top of (or inside) another car (in (I think) the mall car park). I couldn't get out of the car, and there were loads of zombies attracted to the noise and walking towards me. When I stopped the engine it would restart again by itself. Even stranger, all the zombies then seemed to occupy the same space on the floor. They went from a huge crowd, to just a few zeds. And then a massive crowd of zombies came after that, and repeated the same thing. Even more bizarre: when I then tried to turn the engine off, all the zeds stood on the same spot suddenly expanded out in a huge wave!

I'm still sat here watching this, stuck in my car. It's like watching Jeff Minter's Psychedlia, but with zombies.

I think that game is dead. Oh well, at least that was different! :-)


I had the same thing happen to me a couple times when approaching different places. One time traveling out of Riverside headed west ( about the same place the game used to crash when approaching the car junk yard - here: https://map.projectzomboid.com/#0.5309529885875125,0.08151948093429734,187.00646439876877 ) and another time headed into West Point going east down the main road through town ( around here: https://map.projectzomboid.com/#0.7221164908117963,0.25398512502888904,75.15370386395993 ). There was a shadow of where the car I joined with was in a parking spot so I tried reloading the game the last time it happened. My car as well as the one I spawned on top of had moved to that shadow spot but were still stuck together. Then oddly after reloading it a few times to see what would happen my character would switch from one car to the other each time I would load it up again.

Share this post


Link to post
Share on other sites

 

13 minutes ago, Kuren said:

Then oddly after reloading it a few times to see what would happen my character would switch from one car to the other each time I would load it up again.

I just restarted and, like you said, it spawned me in a lower vehicle near my old car. I *could* get out of this one, though. Which was a mistake, because I've just been bitten to f**k. :-D 

20171111201259_1.jpg

Edited by Mallo
Fix mistake.

Share this post


Link to post
Share on other sites
1 minute ago, Mallo said:

I just restarted and, like you said, it spawned me in a lower vehicle near my old car. I *could* get out of this one, though. Which was a mistake, because I've just been bitten to f**k. :-D 


Oh crazy! I just meant that it moved both the two original cars that were stuck together to the spot with the shadow there and my character would switch between those two stuck together cars each load. Wish I could have gotten out like you lol, was luckily teleported to a less busy area :P

Share this post


Link to post
Share on other sites
20 minutes ago, Kuren said:


Oh crazy! I just meant that it moved both the two original cars that were stuck together to the spot with the shadow there and my character would switch between those two stuck together cars each load. Wish I could have gotten out like you lol, was luckily teleported to a less busy area :P

Even more strange: I restarted a couple of times and it put me back in my old car, over the top of the last vehicle I respawned in. Then - I've got no idea why - all the zombies suddenly turned around and walked AWAY from the car in big groups! The frame rate then nosedived, the game froze, then crashed. My bite injuries seemed to have disappeared too! Weird. :-) I'm still wondering if I can rescue this game or not...

Share this post


Link to post
Share on other sites
13 hours ago, Shinjitsu noDeshi said:

Too funny.

 

I just had this exact thing happen to me. Shepherding a horde of zombies down Muldraugh's main drag in a nice van, and suddenly I'm teleported away, ending up on top of another vehicle in the Diner's parking lot.

 

Shin

 

I same the same problem, the game crashed when I get out the car.

 

 

hs_err_pid11608.log

Share this post


Link to post
Share on other sites

Same problem here, my car hit something and was rooted. When i reload the game a big van spawned at top of my car and i can do anything (well i can leave my car) Also pillar with flashlight dont work (no light).

Share this post


Link to post
Share on other sites
4 hours ago, RobertJohnson said:

Really weird...

 

If you have anything that can help me reproduce it, that'd be awesome, i'll investigate tomorrow

I'm able to consistently reproduce this. How can I get you a copy of my save game folder - it's 8MB as a zip.

 

I'm playing Insane hordes on a First Week Sandbox mode. I think the only other change is I've turned off zombie respawns.

 

Stepwise, in my save I take my vehicle from Cortman Medical up to the Pizza Whirl.

Take a left onto the Muldraugh Main Street.

Drive towards the Diner & gas station (don't even worry about shepherding zombies)

About the point of the restaurant before the Diner, the vehicle you are driving teleports somewhere else. I've ended up in a different place each time I've tried this.

 

Shin

Edited by Shinjitsu noDeshi

Share this post


Link to post
Share on other sites
4 hours ago, Shinjitsu noDeshi said:

I'm able to consistently reproduce this. How can I get you a copy of my save game folder - it's 8MB as a zip.

 

I'm playing Insane hordes on a First Week Sandbox mode. I think the only other change is I've turned off zombie respawns.

 

Stepwise, in my save I take my vehicle from Cortman Medical up to the Pizza Whirl.

Take a left onto the Muldraugh Main Street.

Drive towards the Diner & gas station (don't even worry about shepherding zombies)

About the point of the restaurant before the Diner, the vehicle you are driving teleports somewhere else. I've ended up in a different place each time I've tried this.

 

Shin

 

You mean it happend at the same place everytime? Could be handy to debug!

Share this post


Link to post
Share on other sites

Lag has even increased since the latest patch.
FPS are dropping (down to 5-10) like crazy and my character is freezing in place every few seconds for 2-3 seconds.
Currently the game is literally unplayable for me, meaning its even impossible for me to find any bugs in this build until i get control over my characters movement again.

Please stop adding more and more gimmicks to the game and put some resources into making it testable at least. 

My specs:

Win7, 64bit
980GTX
32GB RAM
I7 4770k




 

Share this post


Link to post
Share on other sites
57 minutes ago, Watermel0wned said:

Lag has even increased since the latest patch.
FPS are dropping (down to 5-10) like crazy and my character is freezing in place every few seconds for 2-3 seconds.
Currently the game is literally unplayable for me, meaning its even impossible for me to find any bugs in this build until i get control over my characters movement again.

Please stop adding more and more gimmicks to the game and put some resources into making it testable at least. 

My specs:

Win7, 64bit
980GTX
32GB RAM
I7 4770k




 

They had that fixed for a bit, but then it came back. I'm sure RJ is doing his best to figure out what's causing it. Remember that this isn't even IWBUMS though...things like this are going to happen. I'm happy they let us peak at this feature so early in it's development.

Share this post


Link to post
Share on other sites

There's two main things that we reckon have caused the recent degradation in performance - one's a fairly easy fix, and the other needs Yuri to do a chunk of work to update the way we do item synchronisation.

 

So hopefully there'll be some improvement this week from the easy fix, with more to follow.

 

In the background we've also got Bitbaboon Steve hunting down performance fixes and improvements (he found quite a promising thread to follow with map streaming on Friday), plus we've got ChrisW's work on improving FPS around buildings/towns in the can and in an internal test build.

 

So: all in all there's plenty going on to get performance back onto the straight and narrow.

Share this post


Link to post
Share on other sites

hello,

so i was at this location in my car

Coords: 5932x5242

Cell: 19x17

Rel: 232x142

 

as soon as the car park rendered (a few paces north of that spot) the screen went blank then my car re-appeared in the car park just a few paces north of that spot.

there was also an invisible car in that car park that i had to walk round.

 

i hope that helps find that bug

 

Share this post


Link to post
Share on other sites
4 hours ago, RobertJohnson said:

You guys can reproduce it everytime? Tried 3 times in a new game, still nothing :(

On a whim I made a copy of the folder for the game I was playing, and then discovered the issue. 5/5 times so far, I've been able to reproduce it using this copy as a restore point.

 

If you want a copy of the save folder, let me know the best way to get it to you.

 

Shin

Share this post


Link to post
Share on other sites

For some of you who can reproduce it easily, can anyone contact me? (here or discord) I have big trouble reproducing this (happend 1 time in 1h of testing :/) but I may have an idea why it does that, could use a tester :) Thanks!

Share this post


Link to post
Share on other sites
22 hours ago, DramaSetter said:

Sometimes, vehicle can spawn like this because of long cars ( normalcar for example )

 

  Reveal hidden contents

 

When you see this, could you try to give me a pzmap link to the area so I can fix zones? Thanks :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
36 36