RELEASED: Vehicle Test 41
36 36

1544 posts in this topic

Recommended Posts

1 hour ago, PriMan said:

Yes, this is also a solution, but after a year it will be difficult to find at least one charged battery in the car. 

They could make it possible to use a generator to jumpstart the battery, like Walter and Jesse did in Breaking Bad when the RV battery died.

Share this post


Link to post
Share on other sites

So I'm not sure if this has been addressed before or not, but I've been noticing that my game will start lagging (that same stuttering every 2-3 seconds) when I've filled a backpack all the way up and have a full mail inventory. if i close the menu out, it stops lagging, when I open it back up the lag starts again especially while trying to transfer items around. what I have to do to get it to stop is to close out the game and restart it completely. I'm not sure if its a memory leak or what but its a big game-play killer :\. anyone experiencing this issue? I've tested this with and without hydrocraft cause I was thinking maybe HC was causing the issue, but its not.

Share this post


Link to post
Share on other sites
6 hours ago, RobertJohnson said:

So far no way to recharge a battery, but you can find new battery in mechanics, fossoil etc...

 You.... sure of that, man? When I found my car, the battery was at 21%, and by the time I drove from Mul to WP, it was already %30, so I presume turning the car on recharges it, but you need a minimum of charge to do so.

Share this post


Link to post
Share on other sites
3 hours ago, Man_In_The_Purple_Hat said:

So I'm not sure if this has been addressed before or not, but I've been noticing that my game will start lagging (that same stuttering every 2-3 seconds) when I've filled a backpack all the way up and have a full mail inventory. if i close the menu out, it stops lagging, when I open it back up the lag starts again especially while trying to transfer items around. what I have to do to get it to stop is to close out the game and restart it completely. I'm not sure if its a memory leak or what but its a big game-play killer :\. anyone experiencing this issue? I've tested this with and without hydrocraft cause I was thinking maybe HC was causing the issue, but its not.

It's a problem in the base game, but large bags that Hydrocraft adds makes the problem much more obvious. This is why there's a max weight, as everything has a performance penalty, but mods typically subvert this.

Share this post


Link to post
Share on other sites
2 hours ago, EG Bot said:

It's a problem in the base game, but large bags that Hydrocraft adds makes the problem much more obvious. This is why there's a max weight, as everything has a performance penalty, but mods typically subvert this.

 

Is it only containers you can carry, or does it also apply to crates/cupboards/etc?

 

I'm a packrat...

 

Shin

 

 

Share this post


Link to post
Share on other sites

So, after playing heavily and extensively on the Vehicle Build for over a week now, I've come up with more than a few ideas that could (IMHO) improve the whole vehicle experience quite a bit. I'll split them by type....

 

 

-Game Mechanics

 

1- Reducing Noise Radius Reach/Max Zombie Noise Draw Limit

 

Perhaps the biggest game-mechanic issue with cars right now is the amount of Zed they attract, and from how far away. Whenever I drive to somewhere that's not in the middle of nowhere (read: heavily within non-urban area), my car seems to draw Zed from at least 2 miles across. Sure, I don't mind having to fight a few dozens of Zed upon arrival, but finding 20-30 of them encircling my car when I leave the building, loot-laden, and with roughly the same amount showing up while I kill these can be quite a problem. And this is, of course, with me always turning off my car as soon as I get there; if you don't, expect that number to rise to 50-70, fully surrounding your car, perfectly recreating that one scene from Dead Rising.

 

In fact, I've found out that, if I ever need to have the Zed in an area move to another, all I gotta do is grab a Gas Can, find a car in the area I wanna move the Zeds to, fill it with gas (if it didn't had some already), hotwire it to start and sneak out; the Zeds will flock to the car as if the sounds of the engine were singing ''FREE BRAINS HERE!'' on a megaphone. This can be quite easily exploited.

 

So, to solve this issue, I propose two possible solutions. One, reduce the radius reach of the engine noise; if I park my car in the middle of an interception, it should not bring zeds from further away than 2 blocks on each side. Or Two, to set a limit of ''Car noise can only draw X amount of Zed for the next Y real time minutes.''; for instance, only 20 Zeds will be drawn to your car for the next 3 minutes after you turned your car off and either no more will come or the upcoming amount will be greatly reduced, but if you start/attempt to start your car, that timer resets.

 

 

2- Constant Key Duplicates

 

The vehicular cousin of the Padlock Duplicating Key Bug. Every time you turn your car on (or fail to do so) you end up with an extra key in your inventory, and this repeats ad infinitum. There was a time I found myself holding 152 Car keys, despite me only using 2 cars at the time. And while this has no real hurdle with the gameplay (as keys have no weight), it's extremely annoying. I dunno if the Padlock Key bug has been dealt with yet, but just like its cousin, this one can be quite a bother.

 

 

3- More Ways to Open your Trunk

 

A few days ago, my char's corpse got burn after a horde trampled over his fireplace, but of all the things I lost, the biggest one was my oldest car's keys. Getting back into the car was no issue, and neither was it hot-wiring it. However, I could no longer access the car's trunk (which was where I kept most of my Gas). In the end, my only choice was fully wrecking the trunk and driving in circles for quite a while until all the stuff fell out of it.

 

So, my first thought was ''We have a crowbar, we have a propane torch, we have a fire axe.... Why can't we use any of them to force the trunk open?'' or even better, why don't any of these cars have one of these:

 

trunk.jpg

(I asked a few car mechanic I know, and yes, these existed at the early 90s, so it fits the time period of PZ)

 

Sure, I can understand that cars with ''backdoors'' (Van, Stepvan, SUV) may not have it, but most sedans and sport cars really should have it. And while we're still on the topic of keys....

 

 

4- Make the Keys more Identifiable

 

Right now, keys are spread all over parking lots and random containers in buildings, but unless there's only one vehicle parked on the drive way, figuring out which key goes where beyond trying to open each vehicle is a bit of an issue, specially if you are trying to flee from a rampaging horde.

 

Car keys should start spawning either with brand-referential names or some kind of specific shape and/or logo for us to tell them apart. I mean, if I walk into a parking lot and I find this key on the ground:

 

Toyota-Key-Replacement.jpg

 

And I have to figure out what car is it from, you can be pretty sure I'm not gonna be trying it on any Ford or Honda....

 

Car keys in PZ need a bit more of identity for them to be more easy to tell apart. We're already starting to implement names and brands for each car, so why not something like that for their keys as well?

 

 

-Added Car Functions/Submodel Ideas

 

1- Refrigerated Stepvan

 

Name says it all; a Stepvan whose trunk serves as a freezer/refrigerator.  They would come with their own function to enable/disable the refrigeration of the trunk (just like the patrol car sirens). While the engine's on, it would consume a bit of extra Gas to keep it cold, and with the engine off, it would eat up battery charge instead. This could provide an interesting refrigeration alternative once power fails as well.

 

As for their design, they could bear the GIGA Mart's logo, Food Market, or maybe even be an Ice Cream Truck. 

 

 

2- Emergency Vehicle Radios should be Two Way.

 

Again, pretty self-explanatory; police cars, fire dept trucks, ambulances, they should all have a two way radio like they do in real life.

 

 

This should be all for now; I'll add more ideas as I think of them.

Share this post


Link to post
Share on other sites
16 hours ago, Shinjitsu noDeshi said:

 

Is it only containers you can carry, or does it also apply to crates/cupboards/etc?

 

I'm a packrat...

 

Shin

 

 

Any container you're currently looking in from the inventory screen.

 

Lots of items in near-by containers will also cause lag after a certain point, though. This is especially true in MP, where so many items can be placed in one area that the game has to download an 8 MB file just to load it. Nothing's free in programming.

Share this post


Link to post
Share on other sites
26 minutes ago, EG Bot said:

 

So, after playing heavily and extensively on the Vehicle Build for over a week now, I've come up with more than a few ideas that could (IMHO) improve the whole vehicle experience quite a bit. I'll split them by type....

 

Great suggestions! Realy like your ideas and would like to see them all in game:-)

Share this post


Link to post
Share on other sites
On 10/25/2017 at 9:58 AM, EG Bot said:

It's a problem in the base game, but large bags that Hydrocraft adds makes the problem much more obvious. This is why there's a max weight, as everything has a performance penalty, but mods typically subvert this.

Thanks for clarification on that. I wonder if down the road of development if they'll be able to fix it. But I guess I'll stick to using the base game bags to avoid any issues. Although it also happens with player inventory as well since you can (slowly) carry up to 50 which I need to at times with logs lol. But hopefully one day they'll be able to fix it up a bit.

 

-edit: I did want to add that this lag is happening with only one bag being full that has a capacity of 39 and having maybe 25 in my main inventory, I remembered that I did get lag long ago while using a bag that went up to 13000 lol and it would lag like this when I got to like 900 hah, but I just wanted to clear up that the lag happens at a much lower capacity since I only have one full Alice pack and a few things extra in my inventory, so I'm not sure this is like the regular lag you mentioned. I tested in stable 38 and had no issues filling two big hiking bags on me and my main inventory to 30, did the same on the vehicles build and after two loot runs (using the same base game big hiking bags) and it started the lag.

Edited by Man_In_The_Purple_Hat

Share this post


Link to post
Share on other sites

Tried the vehicle build for multiplayer:

 

-Terrible desync issues regarding TVs, loot

-Glove boxes run on their own container per player

-Keys that spawn on the ground were only seen by one player

 

-All of the containers that were tied to the visual component of shelves were empty, 100% of them. Potential de-sync as the other player was able to find loot in the same containers.

 

Gameplay:

 

Trunks absolutely need to be able to opened from inside of the vehicle. A player decided to temporarily keep the keys in the trunk through sorting, and all of a sudden the key was gone forever as the key to open the trunk was within the trunk. Thankfully he was able to hotwire the vehicle. [Edit: This was in the station wagon which makes this just as much hilarious as ridiculous :P ]

 

Other bugs:

 

Terrible visual issue where railings and posts fall behind walls layer on different tiles.

Same applies to falling zombies, once they drop they go behind the wall. (Seen by all players in the server)

 

Many map bugs, including the country club. Trees spawn in front of doors, etc

 

This restaurant doesn't spawn restaurant loot but could have something to do with the desync issue above.

http://map.projectzomboid.com/?#0.45248766594782497,0.185621247106945,491.02132435465785

Edited by Kim Jong Un

Share this post


Link to post
Share on other sites

Before build 24, I think I got the black screen error that some people are reporting 1 or 2 times. But now I get it after only a few minutes of driving, constantly. Out of nowhere, btw, I didn't test if it also happens when hitting something (apart from zombies), but for me is randomly, just driving and bam. Black screen. UI still there, sounds still there, but everything else is black. Can only get back to normal after exiting the game and reloading the save, and the car always disappears (but only the one that I was driving, other cars nearby stay in their positions)

 

Specs:

Intel i3-6100U 2.30 GHz
Intel HD Graphics 520 2GB
4GB DDR3 RAM
Windows 10

Share this post


Link to post
Share on other sites
4 hours ago, Deimos Eilhart said:

Before build 24, I think I got the black screen error that some people are reporting 1 or 2 times. But now I get it after only a few minutes of driving, constantly. Out of nowhere, btw, I didn't test if it also happens when hitting something (apart from zombies), but for me is randomly, just driving and bam. Black screen. UI still there, sounds still there, but everything else is black. Can only get back to normal after exiting the game and reloading the save, and the car always disappears (but only the one that I was driving, other cars nearby stay in their positions)

 

Specs:

Intel i3-6100U 2.30 GHz
Intel HD Graphics 520 2GB
4GB DDR3 RAM
Windows 10

Next time it happens, grab the console.txt from %UserProfile%\Zomboid You can drag and drop it over the "drag files here to attach ..." bar at the bottom of your reply.

Share this post


Link to post
Share on other sites
On 29/10/2017 at 3:17 AM, Kim Jong Un said:

Terrible visual issue where railings and posts fall behind walls layer on different tiles.

Same applies to falling zombies, once they drop they go behind the wall. (Seen by all players in the server)

 

 

Cheers for the MP notes - have added in some Yuri tasks.

 

I know the above is a longstanding issue, but do you/anyone have any images of this posted already? It wasn't in our newfangled task tracker thing for some reason, and it'd be handy to have an example.

Share this post


Link to post
Share on other sites
1 hour ago, Batsphinx said:

 

Cheers for the MP notes - have added in some Yuri tasks.

 

I know the above is a longstanding issue, but do you/anyone have any images of this posted already? It wasn't in our newfangled task tracker thing for some reason, and it'd be handy to have an example.

Spoiler

 

A4192ECAB6435A84489F34E59DEC62EDDF29AFB5

C35F8F0F8BF421041FB69201C7B42F541902654C

65587E7736F3B705BD84AA8F561C3917F4EED2E0

D62512D2639E8946846708901EDE59E18B27F280

 

 

This is the same with every railing, not just these specific locations.


Not sure if this is a related bug, but in this case the roof is actually clipping inside of the building, and this used to not happen at this location (Firestation):

Spoiler

 

773E0C67DA3F998B5D564AE70F762927141BECD9

 

 

Edited by Kim Jong Un

Share this post


Link to post
Share on other sites

I've seen only one SUV (Offroader is it called?), it was in the Junkyard, so I am am to assume it does spawn. I also saw the second sedan on WP (Premiere? Primarch? Something like that).

 

Btw, does anyone knows where do Park Ranger cars spawn? Or has seen any?

Share this post


Link to post
Share on other sites

About "FPS loss"

 

  • Vehicle test build 24: in the case of  Expelimental Vehicle turn on.
Spoiler

a.thumb.png.eb50fa7ede57e852c65df0b5607655a6.png

 

  • Vehicle test build 24: "Expelimental Vehicle" turn off.
Spoiler

a.thumb.png.eb50fa7ede57e852c65df0b5607655a6.png

Spoiler

20171101144909_1.thumb.jpg.85f27995e3ee19c3a645ad67ac4b1d46.jpg

 

  • in the case of Build 38.22.  CPU use rate: 72%

 

Based on these factors,  FPS loss may not be because of a Vehicle.

Edited by halkaze

Share this post


Link to post
Share on other sites
13 hours ago, Blake81 said:

I've seen only one SUV (Offroader is it called?), it was in the Junkyard, so I am am to assume it does spawn. I also saw the second sedan on WP (Premiere? Primarch? Something like that).

 

Btw, does anyone knows where do Park Ranger cars spawn? Or has seen any?

The SUV used to spawn in parking lots, it does not anymore. 

 

I haven't been able to find any ranger vehicles outside of the firestation parking lot. I also haven't been able to find livery vans/stepvans.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
36 36