RELEASED: Vehicle Test 33
27 27

909 posts in this topic

Recommended Posts

Have found a bug: if you create new character on  your save where you died, car's will despawn. They won't dissappear at all, just respawn. Also, vehicles in "car wrecks" sometimes can be clipping ( related to the "new character on old save" bug i guess )

Edited by DramaSetter

Share this post


Link to post
Share on other sites
16 hours ago, RobertJohnson said:

For some of you who can reproduce it easily, can anyone contact me? (here or discord) I have big trouble reproducing this (happend 1 time in 1h of testing :/) but I may have an idea why it does that, could use a tester :) Thanks!

I tried reaching out to you on Discord earlier in the day, but you didn't respond.

 

Shin

Share this post


Link to post
Share on other sites

Build Vehicle 26:

 

[New]

  • New Vehicle Dashboard - final version from artist mash. Now has indicators to tell you if there's a problem with your vehicle, giving all the information a driver in the 'real world' would have to hand.
  • You can now lock/unlock all doors from a vehicle's radial menu.
  • You can now access pickup's open trunk without a key.

 

[Balance]

  • Did some performances improvement on Bullet calcul. (Please let us know if this has an impact on your game.)
  • Improved the random car crash spawning method.
  • Reduced the number of car keys spawning on the ground.

 

[Bug Fix]

  • Hopefully fixed vehicles being teleported randomly.
  • The car will not try to start if battery is at 0.
  • Fixed some exterior tiles acting as if they were offroad.
  • Fixed some vehicle spawning errors.
  • Fixed some bugs in the scripts.
  • Fixed keys being removed from ignition before the engine stalls.
  • Removed collision from some inappropriate objects.

Share this post


Link to post
Share on other sites

Build 25_2 save loaded fine.

 

Outside of troublesome 2+ story buildings, FPS seems to be improved. There's still that sensation of heaving as you speed up or walk around that isn't well reflected in the FPS meter, but it's much more playable. When driving, this makes turning more difficult -- it's like it doesn't respond right away, then over-steers.

 

Same problem as Thegeorgegman re: zombies.

 

Engine idle sound plays in the pause menu.

Share this post


Link to post
Share on other sites

1) Looks like the main stuttering is gone now! The vehicles slowing down each second is still there, but way way less noticeable than it was last build. Also, when driving into the center of towns, fps drops from 60 to about 15-20 and there is some minor stuttering, but nothing compared to before. Can't tell if this was an fps improvement or not seeing as previous builds were unplayable for me, but compared to build 38 it is still pretty sluggish (to be expected). But overall, huge improvement!

2) I love the new dashboard, way more convenient to have the various buttons handy.

3) As mentioned above, cars simply push zombies out of the way, they don't get hit anymore even at full speed.

 

Gonna run a proper game now and see how performance works out in a longer testing session, will update later.

Share this post


Link to post
Share on other sites

Not sure if this is new, a bug, or something I missed- But it seems some vehicles don't need keys to operate? Not able to test much due to the mac problem, but I've found a black van and yellow taxi unlocked, without a key in the glove box, and they started just fine without keys. Is that supposed to happen?

 

Macs still have a problem, as stated in the relevant bug thread.

Share this post


Link to post
Share on other sites
1 hour ago, trombonaught said:

Not sure if this is new, a bug, or something I missed- But it seems some vehicles don't need keys to operate? Not able to test much due to the mac problem, but I've found a black van and yellow taxi unlocked, without a key in the glove box, and they started just fine without keys. Is that supposed to happen?

 

Macs still have a problem, as stated in the relevant bug thread.

 

Keys can spawn directly in ignition now, when entering the car if you see on the dashboard that the key icon is green, it means keys are on the ignition :)

Share this post


Link to post
Share on other sites
3 minutes ago, Legoland99 said:

Good to know, I HAD to test each car apart and see which had keys and which had not. P.S. , found this beauty while driving, not sure if this is a new place or not, but I've never driven there. Three years and I still find new stuff in PZ... 

20171116183541_1.jpg

 

Did you check the back of the van? It might have some food in it...

 

Shin

Share this post


Link to post
Share on other sites

Started a new multiplayer game with two people. Performance wise it started out well, but after about an hour it became a laggy mess. :(

 

Here is a quick example of the lag we'd experience "driving full speed" in the center of West Point. I did not experience these extreme freezes as my friend who recorded this did, but instead got these freezes in the form of the vehicle slowing down over and over. The lag was no different while on foot, nor with only 1 person in the car. 

 

 

 

(SOUND WARNING)
A small bug that we noticed while attempting to record the first video, was the car horn getting stuck when a passenger types a word with the letter H into chat. The horn didn't stop until I stopped the car.

 

 

Other issues:
- An issue as we had with multiplayer back in May 2017, was that containers appear empty for players that were not in the area when the container was loaded for the first time or items were added/removed by another player while they were not around. This bug is still there, where for example any houses one of us had previously gone past but not looted were completely empty for the other person. Containers edited in our base when one was out looting appeared empty or unchanged for them when they returned. 

 

- The nerf to off-road speed feels pretty extreme. Yes, you should drive slower off-road, but not at snail speed. Just makes it feel really tedious. 

 

- In order to access the trunk of a car, you need to be holding the car keys for that car. Meaning if you are more than one player, other players can't even see the trunk, making it pretty tedious having to move keys back and forth between you just to offload loot. More of an inconvenience than a bug, where it would make more sense if you could unlock it for others. Or is there some way of doing this already that I'm unaware of?

 

- When taking items out of a car trunk, those items get deleted. It goes into your inventory then disappears after a couple of seconds. Found a temporary workaround by dropping items from the trunk onto the floor, then from the floor into your inventory.

 

System 1 (recorded videos on):
i7 4770K
32 GB RAM
Geforce GTX 980
64 bit Windows 7

 

System 2:
i7 3770K
16 GB RAM
Radeon R9 390
64-bit Windows 10

Edited by iwawa

Share this post


Link to post
Share on other sites

Is it possible to do the manual shifting of the gearbox in the car?
How do I turn on the radio in the car?
The battery weighs 1 kg ... but they are really heavy.
When the heater is turned on in the car, it does not get hot and the battery is not consumed, just as when the light is switched on without a running motor, it does not put the battery in the car.

Share this post


Link to post
Share on other sites

Bugs: 

1. Zombies can't hit you throught the doors if you sleeping ( only broke the window ).

2.You can dupe car keys, if you put one of them in key-ring. Start car > get new "car key", but the old still in key-ring. Also, name get's back to the "car key" even if it was changed, that's kinda annoying. And one suggestion about seats: sitting on bad condition should cause unhappiness, and maybe a weak pain ( if they such bad, 10% ) instead of reducing capacity.

Edited by DramaSetter

Share this post


Link to post
Share on other sites

the speed the car parts degrade at seem very fast to me, what about putting in a sandbox setting to adjust this?

 

also, every other time (or so) that i quit a save, return to the main menu, and then load a save, the whole game freezes up on me and i have to close it out and restart it, not sure if anyone else is having this problem

Edited by Zeantra

Share this post


Link to post
Share on other sites
On 11/16/2017 at 6:05 PM, RobertJohnson said:

Released vehicle hotfix 26.1:

 

[Bug Fix]

  • Fixed zombies not being hit by car.
  • Fixed some debug print line still there.

Hey RJ there is something weird going on now...

 

I tested the 26.0 build yesterday and everything seemed fine in singleplayer, as lag seemed to be gone (to some extent). I decided to go back today and check since my friend was having such major lag issues last night, and it seems like 26.1 has the lag issues while 26.0 didn't. Maybe my testing session on 26.0 was a one off, but this seems very strange. Is it possible to get 26.0 back for testing it again?

 

Here is what it looks like for me in 26.1 with the vehicles slowing down each second (not as bad as it was in 25 but still noticeable):

 

 

Edited by iwawa

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
27 27