• 0

Games being lame and won't start
2 2

Question

Game won't start, being lame, crashes on startup, this is the console

:

fig file: C:\Program Files (x86)\Steam\steamapps\common\ProjectZomboid/ProjectZomboid64.json
pzexe: mainClass: zombie/gameStates/MainScreenState
pzexe: classpath: -Djava.class.path=.;jinput.jar;lwjgl.jar;lwjgl_util.jar;sqlite-jdbc-3.8.10.1.jar;uncommons-maths-1.2.3.jar
pzexe: vmArg (json) 1: -Xms1024m
pzexe: vmArg (json) 2: -Xmx1024m
pzexe: vmArg (json) 3: -Dzomboid.steam=1
pzexe: vmArg (json) 4: -Dzomboid.znetlog=1
pzexe: vmArg (json) 5: -Djava.library.path=natives/;.
pzexe: Steam is running
Setting breakpad minidump AppID = 108600
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198131769722 [API loaded no]
16-05-2017 00:10:57
cachedir is "C:\Users\badge\Zomboid"
-- listing properties --
java.runtime.name=Java(TM) SE Runtime Environment
sun.boot.library.path=C:\Program Files (x86)\Steam\steamapp...
java.vm.version=25.121-b13
java.vm.vendor=Oracle Corporation
java.vendor.url=http://java.oracle.com/
path.separator=;
java.vm.name=Java HotSpot(TM) 64-Bit Server VM
file.encoding.pkg=sun.io
user.script=
user.country=US
sun.os.patch.level=
java.vm.specification.name=Java Virtual Machine Specification
user.dir=C:\Program Files (x86)\Steam\steamapp...
java.runtime.version=1.8.0_121-b13
java.awt.graphicsenv=sun.awt.Win32GraphicsEnvironment
java.endorsed.dirs=C:\Program Files (x86)\Steam\steamapp...
os.arch=amd64
java.io.tmpdir=C:\Users\badge\AppData\Local\Temp\
line.separator=
java.vm.specification.vendor=Oracle Corporation
user.variant=
os.name=Windows 10
sun.jnu.encoding=Cp1252
zomboid.steam=1
java.library.path=natives/;.
java.specification.name=Java Platform API Specification
java.class.version=52.0
sun.management.compiler=HotSpot 64-Bit Tiered Compilers
zomboid.znetlog=1
os.version=10.0
user.home=C:\Users\badge
user.timezone=America/Chicago
java.awt.printerjob=sun.awt.windows.WPrinterJob
file.encoding=Cp1252
java.specification.version=1.8
user.name=badge
java.class.path=.;jinput.jar;lwjgl.jar;lwjgl_util.jar...
java.vm.specification.version=1.8
sun.arch.data.model=64
java.home=C:\Program Files (x86)\Steam\steamapp...
java.specification.vendor=Oracle Corporation
user.language=en
awt.toolkit=sun.awt.windows.WToolkit
java.vm.info=mixed mode
java.version=1.8.0_121
java.ext.dirs=C:\Program Files (x86)\Steam\steamapp...
sun.boot.class.path=C:\Program Files (x86)\Steam\steamapp...
sun.stderr.encoding=cp437
java.vendor=Oracle Corporation
file.separator=\
java.vendor.url.bug=http://bugreport.sun.com/bugreport/
sun.cpu.endian=little
sun.io.unicode.encoding=UnicodeLittle
sun.stdout.encoding=cp437
sun.desktop=windows
sun.cpu.isalist=amd64
-----
SVN REVISION 964
versionNumber=37.14 demo=false
1494911457967 [javafmodJNI] Init: Start
1494911457967 [javafmodJNI] Init: WIN 64
Failed to load fmodintegration library
java.lang.UnsatisfiedLinkError: C:\Program Files (x86)\Steam\steamapps\common\ProjectZomboid\fmodintegration64.dll: %1 is not a valid Win32 application
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1857)
        at java.lang.Runtime.loadLibrary0(Runtime.java:870)
        at java.lang.System.loadLibrary(System.java:1122)
        at fmod.javafmodJNI.init(javafmodJNI.java:30)
        at fmod.fmod.FMODManager.init(FMODManager.java:127)
        at zombie.GameWindow.maina(GameWindow.java:867)
        at zombie.gameStates.MainScreenState.main(MainScreenState.java:180)
Exception in thread "main" java.lang.UnsatisfiedLinkError: Can't load native libraries
        at fmod.javafmodJNI.init(javafmodJNI.java:48)
        at fmod.fmod.FMODManager.init(FMODManager.java:127)
        at zombie.GameWindow.maina(GameWindow.java:867)
        at zombie.gameStates.MainScreenState.main(MainScreenState.java:180)
 
Then it stops

Share this post


Link to post
Share on other sites

9 answers to this question

  • 0

Install the various VCRedist files in the game's installation directory. You're missing one of the 64-bit versions.

C:\Program Files (x86)\Steam\steamapps\common\ProjectZomboid\_CommonRedist\vcredist

BayCon likes this

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

Thanks where can I find this VCRedist file? already tried reinstalling.

Edited by Queen Glory

Share this post


Link to post
Share on other sites
  • 0

This when trying to play the car build, Queen Glory? My guess is the requirement for VCRedist 2015 accidentally snuck back in.

Share this post


Link to post
Share on other sites
  • 0

Oh no this is the base game, but I think it's something else entirely, every time it open it it says setup sucand nothing else changes, i'm currently reinstalling all of my VCRedist and i'm going to reinstall them, I feel like this is the same problem behind MOWAS 2 crashing.

Share this post


Link to post
Share on other sites
  • 0
Just now, Queen Glory said:

Oh no this is the base game, but I think it's something else entirely, every time it open it it says setup sucand nothing else changes, i'm currently reinstalling all of my VCRedist and i'm going to reinstall them, I feel like this is the same problem behind MOWAS 2 crashing.

PZ now auto-detects if your system is 32-bit or 64-bit and launches the correct version. Here, it's not finding the dependcies for 64-bit, so it tries to load the 32-bit version of VCRedist instead. It fails to launch.

If you just want to play, you can probably get around it in the meantime by just launching the ProjectZomboid32.exe from the install dir. 

Queen Glory likes this

Share this post


Link to post
Share on other sites
  • 0
Just now, EnigmaGrey said:

PZ now auto-detects if your system is 32-bit or 64-bit and launches the correct version. Here, it's not finding the dependcies for 64-bit, so it tries to load the 32-bit version of VCRedist instead. It fails to launch.

If you just want to play, you can probably get around it in the meantime by just launching the ProjectZomboid32.exe from the install dir. 

Yeah launching it from the exe works, though I think my VCRedist is screwed up somehow, I've had problems with it in the past.

Share this post


Link to post
Share on other sites
  • 0

Yeah, they're tied to Windows Updates, so it can be a real bastard getting them to install properly if one messes up.

 

That's why TIS ultimately downgraded from VCRedist 2015 back to VCRedist 2013. Had a lot of people that just couldn't get a key Windows Update installed for it to work. It'd even report sometimes that it successfully installed, but was still broken. Sometimes only the 32-bit version would install.

 

No doubt this affects other games that depends on newer versions, too.

Queen Glory likes this

Share this post


Link to post
Share on other sites
  • 0
On 5/16/2017 at 0:31 AM, EnigmaGrey said:

Yeah, they're tied to Windows Updates, so it can be a real bastard getting them to install properly if one messes up.

 

That's why TIS ultimately downgraded from VCRedist 2015 back to VCRedist 2013. Had a lot of people that just couldn't get a key Windows Update installed for it to work. It'd even report sometimes that it successfully installed, but was still broken. Sometimes only the 32-bit version would install.

 

No doubt this affects other games that depends on newer versions, too.

Yeah mines the one where it says it "Installs successfully" and doesn't work, pretty annoying tbh.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
2 2