Jump to content
Batsphinx

Released: Vehicle Tech Test build

Recommended Posts

3 minutes ago, Lexx2k said:

About being unable to place furniture: You likely broke a part or two when disassembling the object. Took me a while to figure out as well. Look for object names- they end with (1/2), (2/2), etc... if you're missing one of them, you can't place the object. It's again one of those mechanics that aren't very obvious to grasp.

 

It would help a lot if the player could see the name of the missing part in the object placement screen, or at least a red "Object incomplete" text.


I think it would be better if disassembling/picking up resulted in either getting both parts or nothing at all. I have a bunch of 1/2 of things laying around being useless.

Share this post


Link to post
Share on other sites

I've found quite a lot of issues while playing co-op with my friend. First of all, the loot seems to be broken, for instance, when I go to the hardware store, I see all the loot but when I grab it, it magically disappears, I see the containers full, but when my friend checks it out, the containers are empty for him. The next issue I've found is the houses are broken, I can't interact with light switches, and the houses seem to be missing roofs, even though you are on the first floor, even on second floor it rains indoors. And the last one that I would like to be fixed is the cars containers resetting. I once put a lot of good loot in my car, when I went far enough from the car and came back, the containers seemed to have nothing in them, this might be a mp bug though. Playing on FX6300 AMD, GTX 750ti, 8 GB RAM.

Share this post


Link to post
Share on other sites
Quote

 

Okay so aside from the more general 'deep engine' stuff like FPS degradation and pop-up...

 

What are the TOP THREE bugs and irritations that people would like to see remedied sooner rather than later, so that playing the cars build is a more pleasurable experience? [Please note - this  can include bugs that have cropped up in features other than cars - rain through rooftops, light switches etc. Whatever's making your life most difficult in this build basically]

 

 

Sorry, nothing related to vehicule test branch, but mostly in the array of bugs introduced with the relased 37.x official version. It's a stepdown from 36.X previous one... So, yes, if you can "cure" that...

 

1) Light problems (problem with light after electricity shutdown...) ; introduced in actual public release...

2) Reccurent problem with "pour into" command ; introduced extensively in actual public release...

3) LoS problem with structures and wall ; introduced (or more blatant) in actual public release.

 

Share this post


Link to post
Share on other sites
On 24/05/2017 at 8:35 PM, BayCon said:

 

1. the messed up loot spawning (loot appearing in inappropriate locations and not appearing in the appropriate locations) makes supply runs not worth the effort.

 

 

This, plus I've noticed lots of houses with nothing in their containers at all. I know there are a couple of houses that are For Sale so are usually empty, but its happening every 4th or 5th house I enter.

 

Also, the electricity has shut down within 24 to 36 hours in almost every game I've played in the vehicle build. Could just be a coincidence.

Share this post


Link to post
Share on other sites
35 minutes ago, OffitMan said:

Also, the electricity has shut down within 24 to 36 hours in almost every game I've played in the vehicle build. Could just be a coincidence.


Happened to me too a few times and it doesn't feel like one. I also had power go off on reloading a save a few times, at least partially because not only did some lights kept working, some fridges did too everywhere but where I was when the game reloaded.

35 minutes ago, OffitMan said:

This, plus I've noticed lots of houses with nothing in their containers at all.

 

With this I wonder if it's a expansion of the feature that adds boarded up and burned out houses with Randomly looted houses? Most if not all that I came across of this type had a broken window with no zombies in sight. But literally everything being gone is... not very believable.

Edited by Svarog

Share this post


Link to post
Share on other sites
54 minutes ago, Svarog said:


With this I wonder if it's a expansion of the feature that adds boarded up and burned out houses with Randomly looted houses?

 

This was my thought initially. I didn't notice if all the houses had broken windows but will make an effort to check now.

 

If this is part of the feature, I'm glad TIS are adding new ways to make houses more random, but something needs be in there. Even if its just a couple of empty tin/pop cans or dirty rags.

Share this post


Link to post
Share on other sites
5 hours ago, Svarog said:


Happened to me too a few times and it doesn't feel like one. I also had power go off on reloading a save a few times, at least partially because not only did some lights kept working, some fridges did too everywhere but where I was when the game reloaded.

 

It's very much related to reloading the game. Easy to test, too: Start a new game, flip some light switches. Exit the game, reload the save, try to flip the light switches: Doesn't work anymore. I haven't tested further, but I am pretty sure this is when loot containers are breaking as well.

 

Game is now hardcore mode-- get everything important (pans, etc) before saving the game, because after that you'll never get these items ever again. :P  Now I wonder if fixing this bug will result in these items appearing again in places I haven't visited yet... if so then I'd stop playing now and wait for a fix.

Edited by Lexx2k

Share this post


Link to post
Share on other sites
14 hours ago, Lexx2k said:

About being unable to place furniture: You likely broke a part or two when disassembling the object. Took me a while to figure out as well. Look for object names- they end with (1/2), (2/2), etc... if you're missing one of them, you can't place the object. It's again one of those mechanics that aren't very obvious to grasp at first.

 

It would help a lot if the player could see the name of the missing part in the object placement screen, or at least a red "Object incomplete" text.

Oh ok, I was wondering what was the use of those numbers, it's true that it's not really obvious, thanks. I think to that a "object incomplete" would help people understand

 

7 hours ago, OffitMan said:

his, plus I've noticed lots of houses with nothing in their containers at all.

Quote

 

 

With this I wonder if it's a expansion of the feature that adds boarded up and burned out houses with Randomly looted houses? Most if not all that I came across of this type had a broken window with no zombies in sight. But literally everything being gone is... not very believable.

 

 

 I have encountered several houses empty me too I was wondering if that was a bug or if that was people who looted it. I have also seen the broken window with no z's inside

Edited by The White Wolf

Share this post


Link to post
Share on other sites
4 hours ago, Lexx2k said:

 

It's very much related to reloading the game. Easy to test, too: Start a new game, flip some light switches. Exit the game, reload the save, try to flip the light switches: Doesn't work anymore. I haven't tested further, but I am pretty sure this is when loot containers are breaking as well.

 

Game is now hardcore mode-- get everything important (pans, etc) before saving the game, because after that you'll never get these items ever again. :P  Now I wonder if fixing this bug will result in these items appearing again in places I haven't visited yet... if so then I'd stop playing now and wait for a fix.


Yep, did a brief test, reloading a save messes up the loot distribution system, stuff seems to spawn alright on fresh new game, once saved and reloaded it goes haywire.

Share this post


Link to post
Share on other sites

I also experience the bug with the rain on the first floor and pouring water bug.
But the most annoying thing right now is item distribution.  Despite some empty houses, my character was burned and I made a ride to the West point pharmacy to get some pain killers. Imagine my face when the pharmacy was full with books, magazines and newspapers instead of medical supplies:) (Checked the book store, but it was also filled with books)
I also checked the police station for weapons but weapon closests were filled with hammers and flashlights...
This happened on 27th day in survival mode.

 

Share this post


Link to post
Share on other sites

I've just started playing around with this.

1.  It's pretty awesome seeing vehicles and a quick little joy-ride attested to fun physics and seemingly-smooth handling.

2.  It's really cool seeing vehicles in PZ :D

 

I've been playing on Sandbox mode, based on "Survival" preset with a few changes - erosion set to 200, 0-6 months water/power, and normal loot.

 

Game reloading, lights/power/loot:

After seeing about the reloading issues I quit and reloaded, in-game 5 hours in, so hadn't played for very long.  It seems the light switches have lost the on/off as if there's no power, but there is - fridges and ovens are working.

 

Loot:  I've not had a chance to check out the looting changes on reload.

 

Frequent "pause":

In a few plays I've had a frequent "pause" at some interval, maybe every <10 seconds or so.  It's not like a framerate stutter, everything just kinda stops momentarily.  Just after it's happened I've flicked to the console window and seen the below message:

<numbers> fmod: Java_fmod_javafmodJNI_FMOD_1Sound_1GetData:3930 JNI_FMOD_Sound_GetData correct buffer

 

Update:  I've been playing quite happily for a while now, and haven't had the pausing.  I'm not certain of the circumstances it's been occurring in, sorry.  I'm seeing the fmod sound correct buffer message in the console, so that may be a red herring.  I've just been driving around and only experienced some degradation at higher speed and further-out zoom.  I've always had a slight drop fully zoomed-out on foot anyways, so wasn't too unexpected.  In an earlier, separate game in which I'd only been to one other house besides my starting house, I'd had the pausing thing.  So from my experience, it's possibly not even related to vehicles in line-of-sight or control/influence.

 

Drawing order:

I've seen mention about the drawing order, and I've seen it, too.  My opinion is that if it turns out to be kind of a "rabbit hole" maybe it's not worth the time?  Especially if lots will be changing with the animation work anyway.

 

Interface:

Engine start key:  I remapped my start engine to [z].  On [v] I'd sometimes start the engine when I meant to open the wheel, or both.  Am I supposed to hold it for the wheel?  Either way, I prefer a separate key.

Vehicle info window:  I remapped to [t], replacing local chat.  I suggest pressing the key again should close the window.  That'd be easier than clicking a small x when I'm focused on driving and there's zombies.  (Player profile context:  If I'm looking for a house or something, I turn down my car stereo so I can see better :lol: )

 

Handling:

I know the handling/physics is still in the works.  I've been playing around with CarNormal and thought that the turning arc was a bit wide?

 

A cool addition to the "survival" aspect:

In the little I played of Dead Island, I gleefully ran down hordes of the things.  In CDDA, much the same, also there's spikes all over my car.

 

But, depending how one plays, I can see the humble sedan becoming something of great import in PZ, spikes or no.  Maybe you don't want to splatter zombies because if you break it and you can't fix it... well, maybe that's how you died.  Or maybe it's just plain inconvenient because it's got all your stuff in it.  I dunno, it's gonna be fun being all serious long-term survival-attempt just as much as tearing around Carmageddon-ing it!!

 

It's really cool though, you guys must be excited.  We are :)

Edited by Wayfarer
New info added

Share this post


Link to post
Share on other sites

Getting the fmod error at random too. Not sure what exactly triggers it, as i sometimes can play for hours without this to happen. 

 

About drawing order and players / zombies. Not sure if this is even worth to investigate if they are getting switched to full 3d models anyway at some point? If it'll work the way I think, the problem should be gone then "naturally"?

Share this post


Link to post
Share on other sites

New version!

 

  • The ‘engine ignition’ key has been changed to ‘W’. [Please take note of this!]
  • Wheel placement now correct on each individual vehicle
  • Handling/feel updated for each individual vehicle. [WIP! Feedback required!]
  • FPS optimization through adding new caching to the LightingJNI interface
  • ‘Survivor is stuck on top of a flipped car’ bug fixed

Share this post


Link to post
Share on other sites
28 minutes ago, RobertJohnson said:

New version!

 

  • The ‘engine ignition’ key has been changed to ‘W’. [Please take note of this!]
  • Wheel placement now correct on each individual vehicle
  • Handling/feel updated for each individual vehicle. [WIP! Feedback required!]
  • FPS optimization through adding new caching to the LightingJNI interface
  • ‘Survivor is stuck on top of a flipped car’ bug fixed


Starting with W is nice. Station Wagons are a lot easier to handle and in general turning is a lot easier, so that's nice.

All other vehicle unrelated annoying bugs are still there if someone's wondering.

Share this post


Link to post
Share on other sites
18 minutes ago, Svarog said:

All other vehicle unrelated annoying bugs are still there if someone's wondering.

 

Yeah, Yuri should be getting onto those this week.

 

We're especially interested in performance improvements with this build. Anything noticeable there?

Share this post


Link to post
Share on other sites

With the latest update, is it possible that some of the cars have been moved to the second elevation? My Van is sitting at the exact same spot as before, but I can only see it if I am far away. As soon as I am close enough for roof tiles to be hidden, the car disappears as well.

Share this post


Link to post
Share on other sites

FPS is a lot better.

That map streaming zombie / tree loading problem still exist.

Some vehicles start at lvl (elevation) 1,5-2. You can walk under them but if you hit them with another car they will fall down. (tested on new game)

When you log out inside a car the game crash if you load that save.

I would improve Vans turning rate a bit.

Share this post


Link to post
Share on other sites

Yep, some cars now start and stay in the air. Occasionally, when revisitng an area the car that was on the ground will respawn above it, some might stay there some will fall.

Far as performance goes, it stays the same for me, when driving around the areas of the map that I've seen before or don't have too many buildings it's a 24-30 (Which is exactly my average FPS on max zoom out anyway so I don't know if it can get any better for me personally), drops to 8 when driving around town with a bunch of buildings and game has to catch up with loading all of them.

I don't really know what causes those drops, if I go and turn on debug noclip mode and start running around at speeds probably faster than vehicles the map loads fine and those drops aren't nearly as bad.

Share this post


Link to post
Share on other sites

I'm trying cars out now, and so far it's just a little lag sometimes. I tried to use the mods I usually use, just because, and it crashed no matter what by lagging more and more till there were no longer any respons from the game. But I didn't expert it to actually work with the mods. I just had to try.

After I took off all mods and restarted the game and made a new game it worked fine. I did notice a few tings, but it's not the cars itself, but I'm still puzzled since it's while I'm testing a map with cars:

 

Singleplayer: sandbox

- It seems that sometimes the game lags and crashes within a few minutes of game start. It also seems like it starts lagging and crash shortly after I use a car.  I've tried all sorts of tests with this, and this only happens sometimes when I start a new game. I use the same settings every time. But I'll have to play for at least a few minuts before I know if it's going to lag and crash or not. I have kept testing over 10-15 minuts in every test I did.

Other than that, I haven't noticed much in single player mode.

Multiplayer: sandbox, no other player than me.

- Can't take down curtains. It says "You need to be standing inside", but I am inside.

- There are far less to loot in houses, even though I haven't changed anything about loot (Normal setting on loot). At one place, a medical house, there were noting there. Everything was empty. I've never seen that before. I believe this was the one called Cortman Medical in Muldraugh. This might have been a bug. I started a new game and loot seemed to be fine. Also, Cortman Medical were stuffed  with all sorts of medicinal equipment, as it should.

- Lightswitches don't work at all. So there's no light, unless the light is already on. Lamps can't be turned on or off either, but I could still take the bulb out.

 

I don't know if I'm just completely off by writing these thing here about the experience I had in multiplayer, but I decided to do it anyway because it's the vehicle version I'm trying out.

 

PC specs:

i5-2500 3.3GHz

8GB RAM

GTX 1060 - 6GB Asus Strix

Samsung 850 Evo 500GB SSD

Win7 64 bit

 

With this said. Oh. my. God! Cars are so awesome! And a much needed and fun tool to the game. Thank you for working on this.

Share this post


Link to post
Share on other sites

I like the new car handling with two notable exceptions. The vans turn at an extremely slow rate, which does not make sense given the tight turns of the roads of the PZ map. On the other extreme, the sports car turns excessive fast, so much so that if I do a very tight turn at relatively slow speeds, I will tip (or do an epic 180 degree turn). Its sensitivity could be lowered a tad. Besides the handling, I have to ask: do pickup trucks only spawn in Rosewood and March Ridge? Those are the only places I have ever seen pickup trucks in the numerous worlds I have loaded.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.


×
×
  • Create New...