Released: Vehicle Tech Test build
31 31

904 posts in this topic

Recommended Posts

4 hours ago, ramius86 said:

Thanks, but this directory is named "Project Zomboid", not "Project Zomboid Dedicated Server", are you hosting a dedicated server using client files?

Yep, it's a full install on my server.

Share this post


Link to post
Share on other sites
Svarog   

Police and Ranger Cars have some issues. Just like StepVan, turning is pretty much a guaranteed way to flip onto side, except they can't stay on the side, they hover above their wheels and if they happen to flip onto the roof... it's just funny what happens, they slideon the ground. Watch it until the end because best trick happens at the end.


Btw, the 2 errors that appeared in the console near the beginning are 2 of this.

Quote

java.lang.NullPointerException
    at zombie.vehicles.PolygonalMap2.allocChunkIfNeeded(PolygonalMap2.java:3627)
    at zombie.vehicles.PolygonalMap2.access$6(PolygonalMap2.java:3625)
    at zombie.vehicles.PolygonalMap2$ChunkUpdateTask.execute(PolygonalMap2.java:3108)
    at zombie.vehicles.PolygonalMap2.updateThread(PolygonalMap2.java:3779)
    at zombie.vehicles.PolygonalMap2$PMThread.runInner(PolygonalMap2.java:3892)
    at zombie.vehicles.PolygonalMap2$PMThread.run(PolygonalMap2.java:3881)

 

Edited by Svarog

Share this post


Link to post
Share on other sites
Svarog   

Played with the rest of the vehicles.

Fire Trucks have many of the same problems as Police Cars and Sports Car is waaaay too sensitive to turning backwards. Video Below.


Other than that:

PickUpTruck and PickUpVan - Handle fine, no mayor complaints there but they feel too fast. It's the opposite of what I feel about SmallCar.

Ambulance and VanRadio - Those are good if you ask me, handle like I'd expect them too, not too fast not too slow.

Share this post


Link to post
Share on other sites
sheesh   

Hello. I know I have a low laptop, but usually I play on 40-60 fps in normal build if I don't scroll up my camera too much. When I tested cars, I got about 15-20 fps with slowly walk, IDK how to explain it but it was weird asf.  Lags started when I tried to pick my skills, so I didn't play long.

 

Intel Celeron CPU 1007U @ 1.50GHz, 4 GB RAM, Intel HD Graphics.

Share this post


Link to post
Share on other sites

Another thing about loot not spawning in correctly - tested in a multiplayer scenario.

While it has been mentioned already that loot doesnt spawn in properly when you enter a chunk too fast, we think that we might have narrowed it down to only certain containers.
We noticed that if the loot didnt load in properly that it was almost always shelves, bookshelves and industrial metal shelves that spawned in completely empty. Crates, drawers and lockers on the other hand almost always had their respective loot and didnt seem to get affected by the issue.

We assume that this is because shelves have two visual states (empty and filled). Entering the chunk too fast might skip the change in states for the shelves therefore resulting in no loot spawning. Something that cant happen to crates, as they only have one visual state no matter how fast you enter the chunk/cell.


Another bug we found, but have yet failed to reproduce:

While driving around in a high load area the car we were driving bugged out and locked the driver inside. It became impossible to leave, access the players inventory or turn the engine on/off. The character went into full lockdown and only a server restart did fix the issue.  Trying to teleport the player via admin powers also failed.

As for feedback to specific cars:

The 4x4 pickup truck drives like a brickwall without wheels. Steering this thing is pretty hard, especially when compared to even bigger vehicles. 
Edit: Just found a different 4x4 - this one handles way better. 

 

Edited by Watermel0wned

Share this post


Link to post
Share on other sites
Svarog   
1 minute ago, Watermel0wned said:

While driving around in a high load area the car we were driving bugged out and locked the driver inside. It became impossible to leave, access the players inventory or turn the engine on/off. The character went into full lockdown and only a server restart did fix the issue.  Trying to teleport the player via admin powers also failed.
 


Happened to me in SP a couple times, holding Ctrl and Clicking (Basically, just attack nothing, even when inside the car) usually made my character get unstuck and able to interact with things again, the car from inside included.

Share this post


Link to post
Share on other sites
iwawa   

- Whenever entering a high-load area, such as the centre of towns, all players start getting 1-2 second freezes every few seconds. These freezes have eventually always lead to the game crashing for all players involved after a few minutes (screen freezing completely, cannot move, game unresponsive). Freezes increase drastically if driving. If leaving town before the game crashes, these freezes continue to some extent but have yet to result in a crash, forcing us to restart the server to avoid further lag.

edit: After a few crashes in the same town, players became unable to rejoin the server and the server host couldn't reload it properly. Stuck on "contacting server".

 

- Update on the loot situation: Any and all containers that appear empty have been shown to fill up for players that restart their game. This is however not much of an option for the host, nor for players who are using cars for temporary storage.

 

- The trunks of Vans are sometimes difficult to access, where its access area seems to be a lot smaller than other cars. It cannot be accessed from the back, but only from a small portion on the corner. (As for the driving feel of Vans, i find them to be very realistic and well done. I feel they handle how they should handle, but should long-term have bigger inventory than other cars.)

Edited by iwawa

Share this post


Link to post
Share on other sites
Neutz   

Here is a video of me testing the vehicles in a custom map, Its a bit more dense than the vanilla map.

 

Around the highway big traffic Jam it runs pretty smooth staying around 50+ fps but when i enter into the town and drive around buildings it drops down to 30-40. On foot its 50-60 fps steady as you can see when i hope out of the van.

For some reason when i turn corners my fps takes a huge hit at certain points going down to 12 fps at one point.

 

Max zoom was 225% and i show what Graphics settings i had on at the start. I also tested it after this with Medium lighting with no compressed textures and i lost about 5 Fps

 

GTX 1070

i7 2700K

16GB DDR3 1600mhz

 

Also check out the air time at the 1:31 mark xD

 

 

Edited by Neutralnz1

Share this post


Link to post
Share on other sites
Svarog   

If someone wants to make testing various vehicle model's handling easier for himself I've got something that might help a bit.

I've put a thing into NecroForge that swaps the car the player is in for another model, refuels it and makes it's engine good quality. It doesn't spawn vehicles yet but I figured I might as well share what I got in case someone finds it useful.

Sure cuts down the amount of running around necessary to find certain rare vehicles.

NecroForge 1.9b [Test] [10.06.2017] - Media Fire Download

 

Put it in your mods folder and activate it, NF menu is accessible by clicking the [NF] button in lower right or pressing the [~] button. Vehicles are under the Wheel icon on the lower left of NF window.

[YouTube Video of How it Works, Ambulance is in there too by now]

Spoiler

 

 

Share this post


Link to post
Share on other sites
1 hour ago, Svarog said:

If someone wants to make testing various vehicle model's handling easier for himself I've got something that might help a bit.

I've put a thing into NecroForge that swaps the car the player is in for another model, refuels it and makes it's engine good quality. It doesn't spawn vehicles yet but I figured I might as well share what I got in case someone finds it useful.

Sure cuts down the amount of running around necessary to find certain rare vehicles.

NecroForge 1.9b [Test] [10.06.2017] - Media Fire Download

 

Put it in your mods folder and activate it, NF menu is accessible by clicking the [NF] button in lower right or pressing the [~] button. Vehicles are under the Wheel icon on the lower left of NF window.

[YouTube Video of How it Works, Ambulance is in there too by now]

  Reveal hidden contents

 

AddVehicle() will spawn random vehicles in Lua

 

To see all vehicles in-game, edit the VehicleZones file in Muldraugh, KY folder:

 

1) Add string "{ name = "TestZone", type = "Test", x = 10815, y = 9780, z = 0, width = 8, height = 200 }" to and of file \workdir\media\maps\Muldraugh, KY\VehiclesZones.lua
2) Delete game saves;
3) Create new game player and go to position 10815, 9780.

Share this post


Link to post
Share on other sites
Svarog   
15 minutes ago, EnigmaGrey said:

Snip


AddVehicle(); spawns a random vehicle, that might be burned and useless or one which has a broken engine that will never, ever start and an empty tank (Gets better on quitting and reloading a save where it was spawned but still...)

The second method I tried too, that line is already there it just needs to be uncommented :P 

If someone wants to play with debug console here's this:

Run the game in Debug mode to play with Lua Console (Hold Shift while launching the game)
Here's some what do.
addVehicle(); - Will spawn a random vehicle, get in.
getPlayer():getVehicle():setEngineFeature(100,30); - Engine at max quality, 30 loudness.
getPlayer():getVehicle():getPartById("GasTank"):setContainerContentAmount(40); - Refuel
getPlayer():getVehicle():setScriptName("Base.CarNormal"); - Change Model to CarNormal
reloadVehicles(); - Reloads every vehicle, changes the model if command above was used.

Edited by Svarog

Share this post


Link to post
Share on other sites
NagashUD   

Just a small question, how do you refill the gas tank ? O_o

Also gas tank has Battery title, maybe that's why i can't refill it ? it is not "easy to use" option.20170611123237_1.thumb.jpg.7ab5040b233464a1bb936aac9fa4c888.jpg

Edited by NagashUD

Share this post


Link to post
Share on other sites
Svarog   
51 minutes ago, NagashUD said:

Just a small question, how do you refill the gas tank ? O_o

Also gas tank has Battery title, maybe that's why i can't refill it ? it is not "easy to use" option.20170611123237_1.thumb.jpg.7ab5040b233464a1bb936aac9fa4c888.jpg

 

Press V for radial menu when standing between car and pump and select refuel option.

Share this post


Link to post
Share on other sites
NagashUD   
10 minutes ago, Svarog said:

 

Press V for radial menu when standing between car and pump and select refuel option.

Thank you !!!

Share this post


Link to post
Share on other sites
Svarog   

There is a particularly annoying issue with inventory managemenet in the current vehicle Build, namely after getting inside a Car it's impossible to transfer items between player inventory and anything inside (Be it the glovebox or passenger seat).

For some reason attempting to do it causes the player character to Freeze and be unable to interact with anything. In previous builds it was possible to leave the vehicle in that state and the character would be utterly stuck in his standing animation (It was possible to slide around) until attacking.

The issue can be worked around while inside the car by Holding Ctrl and Clicking somewhere as if you wanted to attack something, it gets the character unstuck and makes it possible to transfer inventory items too.

This bug is very easy to replicate, just get inside a car and try try to transfer items into the glovebox by clicking and dragging. Occasionally everything will work fine but more often than not, it results in exactly what I'm describing.

Rarely, the character will get stuck in the walking animation after exiting the car and that can be only fixed by reloading the save. I don't know if it's related to this issue.

It can be seen in this video, I had to unstuck myself with the method described above [Ctrl+Click] which I did before I first exit the vehicle and later again before inventory transferring started to work.

2 hours ago, NagashUD said:

Refulled the gas tank but the gas jauge didn't actualised


Also, I can confirm that occasionally the Fuel Gauge doesn't update properly and is just stuck at whatever it was before refueling.

Share this post


Link to post
Share on other sites
NagashUD   

Got the same problem as well, plus i just got the bad experience to put things in the trunk in multiplayers in fact delete those but that was already reported . For 10 minutes i was wondering if that was the right car i put my stuff in ... -_-'

Share this post


Link to post
Share on other sites
leoliuos   

It was fun getting quickly to new locations I've never seen before!

 

1. As already stated they are quite overpowered. I'm wondering if they will have a damage model? If you'd drive over a zombie full speed the mass would definitely damage a car. Now they also change the gameplay completely as you clear whole areas just by driving over zombies until they are all dead and it's a bit silly. For zomboid difficulty the cars should break easy in my opinion, perhaps more speed -> more damage to the car.

 

2. I crashed the car couple times and I though oh sh* now I injured myself. I would love to see some broken bones and pay for my mistakes!

 

Edited by leoliuos

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
31 31