[SOLVED] Custom item icons not working
1 1

1 post in this topic

Recommended Posts

Can not seem to get my custom items icons to work.

I've put the icons in "C:\Users\<username>\Zomboid\mods\<modname>\media\textures".
I've added "Item_" before the icon names. (Example: Item_Test.png, didn't work without it either)
I've made the pictures indexed and 32x32. (Didn't work without indexed either)
I've added "Icon = Test," to the custom item. (Didn't work with Test.png either)
I've even tried adding the icons to "...\<modname>" and write a .lua with the code:

ModIcons = {}

function ModIcons.loadTextures()
    getTexture("Item_Test.png");
	getTexture("Item_Test2.png");
	getTexture("Item_Test3.png");
	getTexture("Item_Test4.png");
	getTexture("Item_Test5.png");
	getTexture("Item_Test6.png");	
end

Events.OnGameBoot.Add(ModIcons.loadTextures);

(But this method didn't seem to work)


Is the methods I'm using outdated?
Help would be much appreciated!
/Z


SOLVED:

The items and crafting needs to be in the same .txt

Edited by zeeb

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1 1