The One Stop TileZed Mapping Shop
6 6

94 posts in this topic

Recommended Posts

1 hour ago, Nanuk said:

 

So do maps I create get added to the edges of the game map?  Or can we impose them over parts of the official map?  I'd like to add a property to Muldraugh itself.  Including a driveway.  Is this possible?

See the last paragraph in Step 4) exporting. When you export your world you can specify a world offset so you can add to existing maps or replace cells on exisiting maps.

if you use: https://map.projectzomboid.com/ and click on map cor-ordinates on the left you will be able to see the co-ordinates for the cell you hover your mouse over, use this in conjunction with world offset option when exporting to add to or replace part of the vanilla map.

Share this post


Link to post
Share on other sites
6 minutes ago, RingoD123 said:

See the last paragraph in Step 4) exporting. When you export your world you can specify a world offset so you can add to existing maps or replace cells on exisiting maps.

if you use: https://map.projectzomboid.com/ and click on map cor-ordinates on the left you will be able to see the co-ordinates for the cell you hover your mouse over, use this in conjunction with world offset option when exporting to add to or replace part of the vanilla map.

 

Thank you, Ringo.  Love your game, by the way.  Best Steam purchase I've made in a long time.  Planning on getting another copy for my girlfriend so we can LAN it up.  I want to make our house for it so we can survive the horde together.  The first gift I ever got for her was The Zombie Survival Guide.  We'll put it to use.

Share this post


Link to post
Share on other sites

After watching a few tutorials, and reading others (I won't be mixing tutorial instructions, just trying to get a familiarity with this before I follow your tutorial) I have a few questions.

 

1.  When saving a .png in paint.net, the option save in 32, 16, or 8-bit as well as messing with dithering level and transparency threshold pop up.  What should these bet set to?

 

2.  Do I need to make a zombie spawn map if I plan on not having any zombies spawn in the cell?

 

3.  Is it possible to extract cells from the map to edit them?

 

4.  Is the reason custom maps have to be minimum of one cell in size a WorldEd limitation or a game limitation?  The reason I ask is because I'm wondering if there will be problems with overlaying a custom cell into coordinates where multiple cells will intersect with it.  For example, if I plop my cell into a zone where there is nothing but vegetation, will this break the game if multiple cells intersect where I choose to impose my custom cell?  Or are we limited to replacing a cell itself?  All the tutorials I've seen so far are not clear if a custom cell has to replace an entire cell or if we can offset the coordinates so it can be plopped anywhere on the world map.

Share this post


Link to post
Share on other sites

1) 16 or 32bit should be fine, I always use 32. dithering and transparency are greyed out when using either of those so you don't have to worry about them.

2) Yes, just make it all black where you don't want zombies spawning

3) No, unfortunately not.

4) The game world is split into cells which are 300x300 tiles, you can only replace or add cells within this grid. When you use the world offset it is in cell's not tiles so you cant place a new cell over the top of where multiple cells would meet, only replace exisiting cells or add new cells to the exisiting grid.

Share this post


Link to post
Share on other sites

Are you using the latest tileset (from this thread: https://theindiestone.com/forums/index.php?/topic/23816-latest-tilezed-worlded-and-tilesets-may-17-2018/ ) ?

If so you might have not set up your tiles folders correctly , In WorldEd, click on Edit and then Preferences, then in the Tiles Directory part of the preferences window, navigate to and select your tiles folder (make sure it is the tiles folder you select and not the 2x folder inside of it), you'll probably also need to do the same in Tiled by clicking on tools and then tilesets, and again make sure the tiles folder is the one selected at the top of that window.

 

Share this post


Link to post
Share on other sites
Posted (edited)
3 minutes ago, RingoD123 said:

Are you using the latest tileset (from this thread: https://theindiestone.com/forums/index.php?/topic/23816-latest-tilezed-worlded-and-tilesets-may-17-2018/ ) ?

If so you might have not set up your tiles folders correctly , In WorldEd, click on Edit and then Preferences, then in the Tiles Directory part of the preferences window, navigate to and select your tiles folder (make sure it is the tiles folder you select and not the 2x folder inside of it), you'll probably also need to do the same in Tiled by clicking on tools and then tilesets, and again make sure the tiles folder is the one selected at the top of that window.

 

I edited the name of the file in the folder and now it matched. But I will renew the folders with the latest version. Also my trees are acting up.

Screenshot (34).png

Edited by Legoland99

Share this post


Link to post
Share on other sites

Yeah if you've been renaming stuff to fudge a fix then god knows what else you've broken. Delete your tiles, re-download the latest and make sure your tiles directories are set up properly both in tilezed and worlded like described above.

Share this post


Link to post
Share on other sites
5 minutes ago, RingoD123 said:

Yeah if you've been renaming stuff to fudge a fix then god knows what else you've broken. Delete your tiles, re-download the latest and make sure your tiles directories are set up properly both in tilezed and worlded like described above.

Alright, just did that, reverted the changes I did to the tiles and changed them for new ones, yet the Dense Forest is not showing up, except in question marks. Is there a way to manually introduce the tiles or what should I do if the trees don't load up?

Share this post


Link to post
Share on other sites

If the trees are not loading up then you still have not set up your tiles folders correctly. Make sure that both in tilezed and worlded you have tiles folder selected and NOT the 2x folder inside of it.

Share this post


Link to post
Share on other sites
7 minutes ago, RingoD123 said:

If the trees are not loading up then you still have not set up your tiles folders correctly. Make sure that both in tilezed and worlded you have tiles folder selected and NOT the 2x folder inside of it.

You mean here ? I'm new to the map modding so I'm not that technical, sorry. I'm not sure if this is the right one or where to go to make the changes in TileZed and WorldZed.

Screenshot (36).png

Screenshot (37).png

Share this post


Link to post
Share on other sites

Yes, that looks correct for tilezed but you also need to check that worlded is correct, in wordled click on edit and then preferences and make sure the same tiles folder is selected there.

Share this post


Link to post
Share on other sites
5 minutes ago, RingoD123 said:

Yes, that looks correct for tilezed but you also need to check that worlded is correct, in wordled click on edit and then preferences and make sure the same tiles folder is selected there.

Both of them say to change it in the config program, is this in Tilezed or WorldEd or is it a program in the folders ?

Screenshot (38).png

Screenshot (39).png

Share this post


Link to post
Share on other sites

You do not want to do anything with the config folders, leave them as is.

However it does look like your tiles folder is set to the correct one...

For sanity's sake I would completely remove Tilezed from your system and download/unzip it again (make sure it's the latest one from the same thread as the latest tiles that i linked you above), then make sure both tilezed and worlded have the tiles folder set correctly again:

 

"In WorldEd, click on Edit and then Preferences, then in the Tiles Directory part of the preferences window, navigate to and select your tiles folder (make sure it is the tiles folder you select and not the 2x folder inside of it), you'll probably also need to do the same in Tiled by clicking on tools and then tilesets, and again make sure the tiles folder is the one selected at the top of that window."

 

Once done you shouldn't have any issues with missing trees or anything else.

Share this post


Link to post
Share on other sites
3 minutes ago, RingoD123 said:

You do not want to do anything with the config folders, leave them as is.

However it does look like your tiles folder is set to the correct one...

For sanity's sake I would completely remove Tilezed from your system and download/unzip it again (make sure it's the latest one from the same thread as the latest tiles that i linked you above), then make sure both tilezed and worlded have the tiles folder set correctly again:

 

"In WorldEd, click on Edit and then Preferences, then in the Tiles Directory part of the preferences window, navigate to and select your tiles folder (make sure it is the tiles folder you select and not the 2x folder inside of it), you'll probably also need to do the same in Tiled by clicking on tools and then tilesets, and again make sure the tiles folder is the one selected at the top of that window."

 

Once done you shouldn't have any issues with missing trees or anything else.

I will do that once I come back home and let you know, thank you!

Share this post


Link to post
Share on other sites
On 7/12/2019 at 4:15 PM, RingoD123 said:

You do not want to do anything with the config folders, leave them as is.

However it does look like your tiles folder is set to the correct one...

For sanity's sake I would completely remove Tilezed from your system and download/unzip it again (make sure it's the latest one from the same thread as the latest tiles that i linked you above), then make sure both tilezed and worlded have the tiles folder set correctly again:

 

"In WorldEd, click on Edit and then Preferences, then in the Tiles Directory part of the preferences window, navigate to and select your tiles folder (make sure it is the tiles folder you select and not the 2x folder inside of it), you'll probably also need to do the same in Tiled by clicking on tools and then tilesets, and again make sure the tiles folder is the one selected at the top of that window."

 

Once done you shouldn't have any issues with missing trees or anything else.

Done! Perfect, did all you said and deleted all files and reinstalled it, and now it works. I will further test the map making process but thank you for your fast response <3 

Screenshot (40).png

Share this post


Link to post
Share on other sites
3 hours ago, Legoland99 said:

What are the yellow bulbs representing ? I've reached the state of adding buildings and for some it shows up. 

Screenshot (41).png

Pretty sure they represent different rooms in your building, shouldn't need to have it turned on to be fair. Just click on view and then make sure "highlight room under pointer" is unticked, close the cell and then re-open it, bulbs should be gone, you can always bring them back by re-ticking the "highlight room under pointer" option.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
6 6