Jump to content
josef733

Possible memory leak or spawning issue.

Recommended Posts

I host a private server for me and my friends. Around 25-30 days into surviving, I start running into a rhythmic lag, every 30 seconds or so I experience a lag for about 1 second. It has nearly killed me.

 

Is it a memory leak after playing for about 13-15 hours? Maybe its because I've set stuff to respawn after 1 month (We're stationed at Twiggy's, near the gun store in West Point) and we are close to the centre of town.

 

Anyone else having similar issues?

Share this post


Link to post
Share on other sites

Generally the server needs quite a bit of RAM for any more than 2-4 players. The longer it's up, the more it'll use.

 

So, it depends. How much  RAM do you have it set for and how may players do you have on?

 

If it is related to RAM, simply shutting it down and relaunching it should resolve it.

Share this post


Link to post
Share on other sites
2 minutes ago, Butter Bot said:

Generally the server needs quite a bit of RAM for any more than 2-4 players. The longer it's up, the more it'll use.

 

So, it depends. How much  RAM do you have it set for and how may players do you have on?

 

If it is related to RAM, simply shutting it down and relaunching it should resolve it.

I have 8 Gigs of RAM and I use 1GB (For whatever reason, the server wont allow me to start with 1.25GB). We are 3 people.

Share this post


Link to post
Share on other sites

i had this happen on my private coop server, everyone playing on it experienced it (we used a lot of mods), we all increased the ram limit on our clients to 2-3gb and the problem went away

 

the default limit was 1024mb on 64-bit

Edited by Jason132

Share this post


Link to post
Share on other sites
2 minutes ago, Butter Bot said:

When starting the game, select the 64-bit mode.  That'll then let you pick a higher RAM value -- I'd go with 4 GB since you have the extra RAM.

Ahh of course, i'm just starting the game on the standard mode. Thanks for that :D

Share this post


Link to post
Share on other sites
19 hours ago, Butter Bot said:

When starting the game, select the 64-bit mode.  That'll then let you pick a higher RAM value -- I'd go with 4 GB since you have the extra RAM.

I started with 2GB of RAM today, we played for about 4 hours. No problems anymore! Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...