Jump to content
EasyPickins

RELEASED: IWBUMS 32.25

Recommended Posts

HOW DO I GET THIS?
http://theindiestone...my-save-branch/

  • Fixed highlighting on carpentry doors when placing them. (Issue #002080)
  • Fixed being able to build multiple doors on a door frame. (Issue #002079)
  • Fixed not being able to build doors in "walls with door hole" without a frame.
  • Fixed destroying a door frame leaving a floating door. (Issue #002077)
  • Fixed exception when a controller.config file specifies an invalid axis.
  • Fixed non-admins sometimes seeing local chat of invisible players in chat log.
  • /grantadmin and /removeadmin now update the 'admin' status of connected players.
  • Fixed spamming "Chop Tree" cutting trees faster. (Issue #002054)
  • Fixed exception after removing a DrainableComboItem from inventory. (Issue #002086)
  • When loading items, discard any items whose saved type does not match that in items.txt.
  • Fixed deactivating a mod deactivating all it's required mods.  (Issue #002091)
  • Crafted items that don't fit in the player's inventory are dropped. (Issue #002085)
  • Fixed axe condition lowering 2x as fast when attacking a tree compared to the "Chop Tree" action. (Issue #002090)
  • "Not effected" -> "Not affected" Outdoorsman trait description. (Issue #002089)
  • Instead of writing the server's IP address in player files to prevent copying, give each server a randomly-generated ID number saved as ServerPlayerID= in the server's INI file.  If ServerPlayerID="", then this protection is disabled.
  • Added right-click menu to Chat with Clear command.
  • Limit chat messages to 256 characters to combat spamming.
  • Added "Local IP" to the saved-servers list for Steam servers.  If you are trying to connect to a server on your local network and it fails when testing the TCP download port, set your server's LAN address in the Local IP field.  (Issue #002092)
  • Limit helicopter sounds to one every half hour of game time.
  • Added Mac server scripts for running a server from the install directory (not SteamCMD).

There's a new UI to help people configure their controllers.  The blue area on each axis is the "dead zone".  The number of each axis and button are what go in the controller's .config file.

ControllerUI.png

Share this post


Link to post
Share on other sites
  • Limit helicopter sounds to one every half hour of game time.

errr every half hour in real life ? or IG half hours (which would be like helicopters constantly )

 

 

In previous versions, there was nothing to stop 10 helicopter sounds at the same time.  Now there won't be more than one helicopter sound during any 1/2 hour of game-world time.  It doesn't mean there will be a helicopter every 1/2 hour, only that there won't be more than one during any 1/2 hour period.  I only changed this because some people seemed to have a run of bad luck and get constant helicopters all day long.

Share this post


Link to post
Share on other sites

I finally figured out a config that works for OS X with XBox controllers. If someone else could try it out as well and confirm that'd be awesome:

Version=1MovementAxisX=0MovementAxisXFlipped=falseMovementAxisY=1MovementAxisYFlipped=false// Set the dead zone to the smallest number between 0.0 and 1.0.// This is to fix "loose sticks".MovementAxisDeadZone=0.0AimingAxisX=2AimingAxisXFlipped=falseAimingAxisY=3AimingAxisYFlipped=falseAimingAxisDeadZone=0.0AButton=11BButton=12XButton=13YButton=14LBumper=8RBumper=9L3=6R3=7Back=5Start=4// Normally the D-pad is treated as a single axis (the POV Hat), and these should be -1.// If your D-pad is actually 4 separate buttons, set the button numbers here.DPadUp=0DPadDown=1DPadLeft=2DPadRight=3// Triggers= is the axis number of both the left and right triggers.Triggers=5TriggersFlipped=false// If your triggers are buttons, set the button numbers here.// If these are set to something other than -1, then Triggers= is ignored.TriggerLeft=-1TriggerRight=-1Disabled=false

Share this post


Link to post
Share on other sites

Dedicated server doesn't seem to be working for me.  I see myself and a friend try to connect and in the server screen I see "Received: 255" but it fails to connect.  I have the ports mapped, etc and this worked before.

 

Has something changed with the IWBUMS branch server setup?

Share this post


Link to post
Share on other sites

Dedicated server doesn't seem to be working for me.  I see myself and a friend try to connect and in the server screen I see "Received: 255" but it fails to connect.  I have the ports mapped, etc and this worked before.

 

Has something changed with the IWBUMS branch server setup?

 

It's working for some people.  Is the server Linux/Mac/Windows?  Make sure to validate the server's files.

Share this post


Link to post
Share on other sites

If anyone has that bug where zoom doesn't work without turning it on/off every time, I'd like to see your console.txt logs.  In particular, there should be lines starting with "ZOOM:" that show various flags related to zoom.

From the first appearance of Zoom in console.txt to changing the option to True in options and turning the game off. I can post the entire Console.txt if need be.

ZOOM: initFBOs() bSupportsFBO=true OptionZoom=true SafeMode=true SafeModeForced=false bZoomEnabled=trueSafeMode is onGL_ARB_framebuffer_object supportedLoading 3D modelsLoading spraypaint tilesLoading: media/maps/Muldraugh, KY/spawnpoints.luausing spawn region Muldraugh, KY13 possible spawn pointstiledef: loading media/tiledefinitions.tilestiledef: loading media/newtiledefinitions.tilestiledef: loading media/tiledefinitions_erosion.tileserosion: reading C:\Users\Draken\Zomboid\Sandbox\TestingSite\erosion.iniLoading: media/maps/West Point, KY/objects.luaLoading: media/maps/Muldraugh, KY/objects.luaALARMS: 73/1008 buildings have alarmsMAX #ZONES is 7reanimate: loaded 0 zombiesreanimate: saved 0 zombiesgame loading took 116 secondsSTATE: exit zombie.gameStates.GameLoadingState1 players foundplayer 0 is mousePLAYER DATA OFFSET 0325.750325.75248.66666666666666createInventoryInterface player=0loot inv createdloot all visiblecontext menu createdcontext menu initialisedcontext menu addedSTATE: enter zombie.gameStates.IngameStateAdding CheatItems to NecroForgeAdding DRK Items to NecroForgeAdding LitteringItems to NecroForgeAdding spraycans to NecroForgeEvents.OnKeyPressed.Add(31)Events.OnKeyPressed.Add(30)Events.OnKeyPressed.Add(17)Events.OnKeyPressed.Add(32)Events.OnKeyPressed.Add(1)ZOOM: zoomOptionChanged() bSupportsFBO=true OptionZoom=true SafeMode=true SafeModeForced=false bZoomEnabled=falseZOOM: setupMultiFBO() bSupportsFBO=true OptionZoom=true SafeMode=false SafeModeForced=false bZoomEnabled=trueFBO: creating 16x16FBO: creating 2048x2048SafeMode is offEvents.OnKeyPressed.Add(1)Events.OnKeyPressed.Add(32)Events.OnKeyPressed.Add(42)Events.OnKeyPressed.Add(17)Events.OnKeyPressed.Add(30)reanimate: saved 0 zombies[ZNetJNI] Java_zombie_core_znet_SteamUtils_n_1Shutdown

When the game was loading the option seems to have been set to true, in the menu, "True" was visible despite it not working until reset. Don't mind the long load time, it was 17 seconds the next time it's that long because of world conversion. Same thing happened later anyway.

Might be related somehow to SafeMode? It turned off after I set zoom back to true, (as console.txt shows) and it always seems to turn itself back on.

Note: Same thing happens with Shaders but I don't use them anyway as they tank my framerate.

Specs:

Intel Pentium G2030 2x3GHz

Intel HD Graphics [Allowed to use 256MB RAM Memory]

4GB DDR3 RAM (Only 3GB is useful for applications)

Windows 7 64bit

Edit: I can post it without mods too if you want, there is a lot of mod stuff in that console but the same thing happens regardless of mods being on/off.

Edit 2: I ran the game from the steam client, but it doesn't matter either. I can run it from .exe, .bat or from steam, same thing happens every time regardless of which .exe, .bat or steam option I use.

Share this post


Link to post
Share on other sites

 

I swear the house alarm/house noise follows my person and not the spot where the sound were generated. any thoughts anyone? 

I've successfully outran it with high sprinting before. It's just loud.

 

Yeah, those things are really damn loud IRL too, some dude's house alarm went off at 2AM where I live, I could hear it from ~500 meters away. If it wasn't for the cars I could have probably heard it from even further away.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...