Jump to content
EasyPickins

IWBUMS 31.13

Recommended Posts

HOW DO I GET THIS?:

http://theindiestone.com/forums/index.php/topic/4183-iwbums-the-i-will-backup-my-save-branch/

 

 

Finally found an honest-to-god cause of map corruption in multiplayer, a static variable being modified by more than one thread.  The more bodies lying around on the server, the more likely the bug was to happen.  Thanks to Zeek and all the people who helped hunt down this bug this week!

  • Fixed "House in the Woods 2" font glitch with some languages.
  • Sledgehammer destroys entire staircases instead of one tile at a time.
  • Disallow destroying the floor tile at the top of a staircase.  The floor tile will get destroyed if the stairs are destroyed and the floor tile is not adjacent to other floor tiles.
  • Added translation for "Are you sure you want to delete that player?" in Challenges.
  • Client deletes chunk files it has that the server does not have, this prevents loading obsolete chunk files.
  • The player is moved down to solid floor when joining a server if the thing they were standing on was destroyed while they were logged out.
  • Server performance fix: server creates zip files to send to clients off the main thread.
  • Fixed "Lighting updates" option not selecting the 45 or 60 values after loading. (Issue #001582)
  • /grantadmin and /banuser give more informative message when the user is not in the whitelist. (Issue #001579)
  • Automatically climb down a sheetrope if there is no floor to stand on at the top.
  • Fixed water tiles running out of water.
  • Fixed drinking directly from a tainted-water tile not increasing food poisoning.
  • Fixed being able to sledgehammer sheetropes.
  • Fixed exception with the chat window if the mouse button was never clicked.
  • Fixed equipped flashlight not being unequipped when building Lamp on Pillar. (Issue #001588)
  • Fixed food sometimes not rotting in multiplayer.
  • Made /teleport multiplayer admin command faster.
  • Fixed multiplayer map corruption caused by a static variable being used from different threads. (Issue #001486)
  • Limit the number of blood splats saved.  The client limits the number of splats when rendering, but the server never did.

Share this post


Link to post
Share on other sites

Yay this fixed so many things.

Map Corruption Bug and also the dreaded sheet rope window traps!

 

Now I just got to get my pc back up and running... T_T hope something did not get fried during the thunder storm dang pc will not even load gotta check every part T_T...

Edited by wsensor

Share this post


Link to post
Share on other sites

Yay this fixed so many things.

Map Corruption Bug and also the dreaded sheet rope window traps!

Now I just got to get my pc back up and running... T_T hope something did not get fried during the thunder storm dang pc will not even load gotta check every part T_T...

Bah, good luck with that, wsensor.

Thanks for the update, PZ team! I don't play multiplayer so this doesn't effect me much, but it's still good to see you guys addressing issues and fixing them...thanks, and keep it up! :D

Share this post


Link to post
Share on other sites

I think I am going to put my old vid card or the one sitting in my currently crapped out pc into my dad's pc. Just so I can play while figuring this out.

Currently finally got into the bios... Hard Drive is not being detected (at all so far)... Sometimes the dvd drive is not detected. Sometimes it just gives me that stupid 1 loud beep then just sits there for awhile then runs fans faster slower faster then loud beep again...

 

Just gonna replace the motherboard probably as the ram is not the issue seeing as it finally loaded into the bios. (Also tried the ram in another pc to make sure haha.)

I probably should have replaced the motherboard when I first got it but asus game me a runaround and I just gave up and kept hitting the RAM config button on the motherboard to start the pc up haha.

 

I just want to play zomboid T_T... Its an addiction!

T_T my pc hates me... Booted to bios finally... Harddrive appears to be dead or in a coma... Checked wires cleaned everything out rewired everything... Bios says POWERSUPPLYFLUCUATEBAD! guess the powersupply is now going... thought it would have went 2 years ago as it said the bundle contained a harddrive that would haveten go bad within a year... lasted 3 years yay! so to replace so far... hard drive (all my data nooooo! I don't have backups of the newer stuff yet T_T, powersupply, motherboard in that order lol... well actually no matter what I need a new hd and powersupply at least...)

 

Gave up and put my old vid card in my dads pc... Also added 4 more gigs of ram to it seeing as it was just sitting there unused forever...

Now to install steam and zomboid!

Share this post


Link to post
Share on other sites

Will the map corruption fix players who get locked out of their players on disconnect unless the server is restarted. Even admin kicking command won't work on the players stuck ghost player.

Share this post


Link to post
Share on other sites

Will the map corruption fix players who get locked out of their players on disconnect unless the server is restarted. Even admin kicking command won't work on the players stuck ghost player.

 

Doesn't sound related. Is there a bug report on the tracker for this?

Share this post


Link to post
Share on other sites

 

Will the map corruption fix players who get locked out of their players on disconnect unless the server is restarted. Even admin kicking command won't work on the players stuck ghost player.

 

Doesn't sound related. Is there a bug report on the tracker for this?

 

Yep, he made this a little while ago. =)

 

http://theindiestone.com/forums/index.php/tracker/issue-1609-multiplayers-cannot-log-back-in-after-random-issues/

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...