Hydrocraft Mod
116 116

4181 posts in this topic

Recommended Posts

12 minutes ago, francogp said:

Thanks!

Can you share a folder instead of a file? so it's easier when you share a new version..

If you remove the 'Hydrocraft9.6.zip' from the end of that link, it gives you the folder.  Any new versions get dumped in there.  But since I'm not a steam user either, I really only update that after Petra (or anyone else) uploads it somewhere else first.

Share this post


Link to post
Share on other sites
Posted (edited)

Not sure if this is where this goes.
Where to begin. So ive had this game for some time now. Play it off and on solo, with no mods, been working great over the years. Then recently a few of us decided to do some MP. So we tryed the vehical build but that was trash, then decided to revert back to 38.30. Played for a bit, found it dull. On a whim, we deceided to get the Hydrocraft mod. Once installed and server was up, things ran great, for a time. Then one day after logging in to the server, I noticed my stuff was missing icons. So i thought, its not an early access game if its not corrupting mod files\save files, so like any good user, i removed the mod, then re-subbed agian. No luck, still blank spaces where items should be in the inventory, although the text was still there. So I then took more actions, removed zomboid from steam, purged all traces of it from the pc. Once that was done i re-installed zomboid, ran it once to build w\e file\folders it may\may not need. Proceded to re-sub to the mod. Fired it back up, and it worked. Untill the next time i logged in. Back to missing icons and stuff misisng from the ground. Now at this point, im getting pissy, and with good reason. Previously everthing worked great, no fuss no muss. Now, its simply not working. So here we are today. I said to hell with it, perhaps its my pc\system. Bit the bullet and wiped it clean, freash windows 10 home install. After getting all the updates, newest drivers, ect, I proceded to DL steam. Once that was installed I once agian installed PZ, this time i did the valadate files. 100% perfect as one would assume. After that, I once agian subbed to the mod. Once that got done DL'ing i did the valiadate files again, and agian no problems. So now i fired up the game, jumped into the server and it worked absolutely perfectly, no missing icons in the inventory, no missing objects\items on the ground. Now at this point im feeling good about; Life, the universe, and everything. Close the game to do some more installing, remember i just wiped the pc and have nothing. After about an hour getting done what needed to get done, i was asked by a buddie to fire it up and we could play......Low and behold, more zomboid Fuckary....Missing icons, objects\items on the ground. So here I am pissing in ya'lls ears, hopeing for a fix. 
I have tryed so many things to get this to work, New drivers, old drivers, muti-re-installs, compatiblity settings (windows), Fullscreen\windowd, 2x tiles both on and off, texture comprission.....you name it. Still nothing. The only thing that makes this work again is launching the game in "Compatibilty mode", but in doing so, I get no zoom. and everything in teh game world is big, I mean BIG AF! Now at this point im a thin blond hair away from giving up entirely. As i would love to show you the issues,but this site will not allow me to upload images or use the insert other media for where the pics are at. (www DOT  imgur DOT com/a/RukWT ) 

console.txt

Edited by Dirty Rider
added console.log file

Share this post


Link to post
Share on other sites

Hydrocraft has some sort of "soft incompatibility" (best phrase I could come up with) with vehicles beta (31.1 and 31.2 as far as I know). Hovering my cursor over item names murders FPS. There's nothing in console.txt that gives any hints away, and no other mods seem to be causing it. Just thought I'd drop a little note, I know Hydrocraft doesn't need to be 100% compatible with a beta branch, but in case something like this pops up in the future, we have (some, very limited lol) documentation.

Share this post


Link to post
Share on other sites
14 hours ago, iyarkonan said:

Hydrocraft has some sort of "soft incompatibility" (best phrase I could come up with) with vehicles beta (31.1 and 31.2 as far as I know). Hovering my cursor over item names murders FPS. There's nothing in console.txt that gives any hints away, and no other mods seem to be causing it. Just thought I'd drop a little note, I know Hydrocraft doesn't need to be 100% compatible with a beta branch, but in case something like this pops up in the future, we have (some, very limited lol) documentation.

 

This one is 'on us' as I believe it occurs in the vanilla game too.

 

I think it relates to some garbage collection optimization from Steve that perhaps went awry. He's going to dig into it on Friday.

Share this post


Link to post
Share on other sites

I put a push cart into a hiking bag, brought it back home, dropped it on the floor next to some other items and now it is stuck there forever. Nothing happens if I try to "grab" it or if I try to "equip with both hands". I'm playing on the current normal branch in multiplayer with a single friend.

Share this post


Link to post
Share on other sites
On 1/9/2018 at 6:06 AM, Batsphinx said:

 

This one is 'on us' as I believe it occurs in the vanilla game too.

 

I think it relates to some garbage collection optimization from Steve that perhaps went awry. He's going to dig into it on Friday.

 

Thats's interesting, since I don't get this issue when I play in the stable build with the same set of mods, Hydrocraft included. I haven't tried playing without any mods in stable branch, though, so I'm not sure how often the bug occurs to others based on the mods they use/the branch they're in. I snooped around my files a bit more and still couldn't find any logical record of the lag spikes happening except for me pretty much pointing at the FPS counter and saying "it's dropping," but if some file finally records something strange, I'll definitely report it.

Share this post


Link to post
Share on other sites
1 hour ago, iyarkonan said:

 

Thats's interesting, since I don't get this issue when I play in the stable build with the same set of mods, Hydrocraft included. 

 

Ah - didn't mean it like that. I meant that it's in the vehicles build anyway, before any mods run alongside it. We have Steve tomorrow so I think it's on his list, as it's probably some optimization he did that's gone wonky,

Share this post


Link to post
Share on other sites
16 hours ago, Batsphinx said:

 

Ah - didn't mean it like that. I meant that it's in the vehicles build anyway, before any mods run alongside it. We have Steve tomorrow so I think it's on his list, as it's probably some optimization he did that's gone wonky,

 

Hmm. Actually he's have trouble reproducing it in the no mods vehicles build.

Share this post


Link to post
Share on other sites

Hydrocraft v9.7 has been released!

 

Which includes ...

 

- Can Wash Leather and Animal Skin Clothing now

- Fixed dried Garlic and Onion Art

- Fixed Chainsaw Bugs

- Fixed Mussel Shell

- Removed Zinc and Chromite Veins

- Fixed Feed Cat

- Fixed Irish Coffee and Black Coffee

- Fixed Rice Flour

- Fixed Feathers

- Fixed Christmas Ham

- Fixed Dried Fruit

- Fixed Carrot & Beet

- Fixed Boxes of Plastic Untizels

- New Art for Some Dogs

- New Ways of Making Poison

- Fixed Tin Rod

- Fixed Horse Saddle Recipe

- Fixed Beta Blocker Recipe

- Fixed Grape and Watermelon Yogurt

- Fixed Cream Cheese

- Can Make Glue from Bluebells

- Added Paramedic Armor

- Added Potassium Permagrade

- Added Cigarette Butt

- Added Fiberglass

- Added Tank of Refrigerant and Cooling Rack

- Added Fruit Leather

- Added Dried Anemone and Daisy

- Added Anemone and Daisy Tea

- Added Fish Oil

- Added Clay and Bronze/Brass Oil Lamps

- Added Chaff, Bran, Kurtan, Momigalite and Thresher

- Added Brown Rice

- Added Sparrows Changes to Farm Animals!

- Thanks to everyone who helped!

 

Enjoy!

Share this post


Link to post
Share on other sites

Good afternoon!

 

Firstly my thanks for all your hard, continued work, Hydromancer. Impressive stuff! My thanks extend to the community for all their contributions, suggestions and bug testing etc. And thanks also to Nolan? for the Undeniable site!

 

I feel I must fight the good fight in respect of bug reporting. I am new to Hydrocraft but I'm starting to get the hang of it. The only thing I've spotted so far was a weird occurrence with the field guides when trying to use them to forage (i.e. right click on a guide to "gather flora"). I had the main three guides on the floor in a forest area in Rosewood. I was experimenting to see the difference in foraging skill/xp gains using one book (in main inv) compared to multiple books and I was not presented with the option to "gather flora" until I did a lot of swapping about moving books to floor and secondary containers. It let me do it from the ground in the end and my guy picked up all three books. Do you need all 3 or is this a bug of some sort?

 

You can watch it here (this clip forms part of one of my 'fast forwards' so there is no dialogue from me):

 

 

I am only running Hydrocraft (no other mods) and I'm using the most current version of the game (before it updated itself today!)

Be warned that if you choose to watch any of my series I have a bit of a potty-mouth.

 

Cheers,

 

Jonno

 

Share this post


Link to post
Share on other sites

Hydro,

 

Wanted to say thanks for your great mod, it's really made PZ a standout game for me (helps bring it closer to CDDA which is my other big timewaster).

 

Just some feedback on the Smithing  system - I think having blunt maintenance 2 as a requirement for the smithing hammers is not the best choice for game progression. My current character is almost two months into the apocalypse and after building a mine with pulley, kiln, smelter and digging up enough stuff to smelt, then dealing with the inevitable burn injuries I was finally able to start some smithing - I thought. My character specializes in blade weapons though and almost all of my 500+ kills on this character where with knives, so I've got zero in blunt maintenance. It seems kinda harsh that I've hit a hard stop on the crafting progression because of my choice of blade over blunt. I think having blunt maintenance as a req for the advanced blunt weapons makes sense, but having in restrict the crafting of the smithing hammers you need to make advanced bladed weapons seems arbitrary and unnecessary since getting to the point when you can make the hammers is an ordeal in itself.

 

Also, regarding burn injures during smelting, is the chance of this only based on protective equipment or does higher metalworking skill lower the risk of burns? As an amateur blacksmith IRL I can tell you that most of avoiding burns when working with hot metal is a matter of knowing what not to touch and how to do things safely.  I've also done aluminum casting with full protective fire suit but if you're relying on the suit (i.e. getting molten metal on it frequently) then you're in trouble. Additionally, different metals have different risks associated with their different metal points, so for example lead/copper/tin/bronze should be less risk of burns as you use lower temperature and iron/steel should be highest risk based on their melt temps.

 

Image result for melting temperature of copper iron bronze steel

 

Also, I hope in the future there will be some way to repurpose automotive steel for new blacksmithing. When cars showed up in parts of Africa they basically stopped smelting their own steel and just made tools out of car parts. In CDDA my favorite is taking bits of cars and forging a katana out of them!

 

Thanks again for your wonderful mod!

Share this post


Link to post
Share on other sites

@Logiwonk

 

1. Thanks for the feedback! Glad you like the mod.

 

2. Getting Blunt 2 is not hard especially if you "punch a tree". But I understand if you use all slashing weapons first and then realize you need blunt, it can be frustrating. However using blade weaponry to fight is way easier than using blunt. So some trade off there.

 

3. The burn chance is based on the equipment. Where things like Blacksmith Apron and Welding Mask are worst, Fire Fighter Jacket and Helmet are medium and Firesuit is the best. However if you do get burned it can be a nice way to improve your first aid skill without risking zombie infection.

 

4. Yeah at the moment as complex as the mod is the metallurgy is VERY over simplified. For instance we only have steel and iron vs say cast iron and wrought iron. However I may change it eventually. As for the temperatures this was a very hard thing to balance since in real life temperatures are less than ideal for setting up the metals in tiers of usefulness. I am not saying I will not change it to reflect the real life temperatures but I also have to account for game balance and progression.

 

5. Sounds interesting. There are car parts already in the mod. If you have specific ideas please let me know.

Share this post


Link to post
Share on other sites

Thanks again Hydro, now back to disassembling all the electronics in muldraugh to get enough aluminum to craft a firesuit! I have to say, scrounging up the parts for the electronics workbench and the laboratory felt very post-apocalyptic tinkerer. I think I had to source parts from two warehouses, two different storage units, two neighborhoods and one shed (propane tank). Picking through neighborhood trash cans and kitchens for the corks was a particularly nice example of emergent gameplay.

 

And you're right the burns have done a lot for my first aid skill, but right now I'm averaging 1 burn per three ingots, so I need to get on making that firesuit.

 

And you're right, after crafting some of the improved baseball bat weapons in this mod I'm wailing on zed and should have blunt 2 in no time.

Edited by Logiwonk

Share this post


Link to post
Share on other sites

Oh, odd bug. Trying to craft the Add Sink to Makeshift shower recipe, the recipe does not seem to recognized regular soap that spawns in bathroons (the blue bar you use to wash  clothing), I had multiple full bars on me and the soap item on the recipe was still greyed out and I couldn't craft it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
116 116